Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Problema di codifica Server POP3

Il forum per tutti i developer. Leggere attentamente il regolamento di sezione prima di postare.

Problema di codifica Server POP3

Messaggioda Luker94 » lun ago 10, 2009 12:39 pm

Scusate, ero in deciso se mettere questo topic nel settore sulle reti o qui, casomai chiedo scusa per l'errore... [8)]

Dunque, ho appena scritto un server POP3, progettato per funzionare in locale e che ha lo scopo di scaricare i messaggi privati di un forum come se fossero e-mail, quindi si connette ad un web service che ho scritto in PHP che per mezzo dei sockets si connette al forum,effettua il login, scarica le pagine, le parserizza e manda al server POP3 gli MP in formato XML (che quindi in realtà altro non è che un ponte), il che permette a Thunderbird o ad un altro client di scaricare i messaggi privati come se fossero e-mail.
Una volta terminato il lavoro, provo il tutto (prima avevo provato esclsivamente le singole parti del progetto), e, dopo aver ammirato il risultato funzionante (ogni volta che finisco un progetto mi esalto, non posso farci niente [rotolo] ), noto con ORRORE ( [acc2] ) che alcuni caratteri (fra cui le lettere accentate) non vengono visualizzati correttamente, neanche nel titolo della mail...i classici problemi di codifica
Allora ho iniziato a sniffare il traffico del download di una mail (vera, stavolta), e mi sono accorto che invece che avere l'header Subject
tipo
Codice: Seleziona tutto
Subject: Questo è un messaggio di prova

L'aveva codificato così
Codice: Seleziona tutto
Subject: =?iso-8859-1?Q?Ciao!_Ques?= =?iso-8859-1?Q?to_=E8_un_me?= =?iso-8859-1?Q?ssaggio_di?= =?iso-8859-1?Q?_prova.?=

Mentre nel corpo del messaggio i caratteri che prima non venivano visualizzati venivano sostiuiti da codici del tipo =E8 (per è)...chiaramente E8 è il codice esadecimale della è...
Un altro header che ho considerato significativo è
Codice: Seleziona tutto
Content-Type: text/plain; charset="iso-8859-1"

...
Vi starete chiedendo...qual è il provlema? Basta scrivere una semplice funzione in grado di codificare come sopra il titolo del messaggio, e sostituire tutti i caratteri non visualizzabili con =HEX, dove HEX è il loro codice esadecimale...ho fatto entrambe le cose, ma la situazione è peggiorata, perché Thunderbird (il mio client di posta) NON decodificava proprio niente. [V]
E vedersi arrivare una mail col titolo "=?iso-8859-1?Q?Ciao!_Ques?= =?iso-8859-1?Q?to_=E8_un_me?=
=?iso-8859-1?Q?ssaggio_di?= =?iso-8859-1?Q?_prova.?=
" non è proprio ciò che volevo ottenere [:p] .
Eppure la sequenzadi bytes inviata dal mio server era praticamente identica da quella inviata da un vero server web. [boh]
Qualcuno conosce meglio di me il protocollo POP3 o ha mai dovuto affrontare un simile problema? [...]
Alla peggio andrò a leggermi per bene la RFC, ma mi pare che neanche lì ci siano indicazioni in merito.

Ringrazio eventuali risponditori con anticipo [^]
Avatar utente
Luker94
Aficionado
Aficionado
 
Messaggi: 116
Iscritto il: lun ago 11, 2008 12:20 pm
Località: Zena

Re: Problema di codifica Server POP3

Messaggioda dararag » sab ago 15, 2009 2:43 pm

visto che di codifica purtroppo ne capisco poco, posso solo darti un consiglio... perché, una volta ottenuto il testo dell'MP, non invii una email con le funzioni del php? [;)]
Maledette aziende produttrici, l'unico telefilm interessante degli ultimi tempi l'hanno interrotto alla decima puntata... e chi voleva sapere la fine?
Avatar utente
dararag
Silver Member
Silver Member
 
Messaggi: 1116
Iscritto il: mar gen 22, 2008 8:57 pm
Località: Casoria

Re: Problema di codifica Server POP3

Messaggioda Luker94 » sab ago 15, 2009 9:24 pm

In effetti può essere una buona soluzione...se proprio non riuscissi a far andare il Server POP3...è un peccato...funzionava così bene!! [acc2]
Ma ci proverò ancora [...]
Avatar utente
Luker94
Aficionado
Aficionado
 
Messaggi: 116
Iscritto il: lun ago 11, 2008 12:20 pm
Località: Zena


Re: Problema di codifica Server POP3

Messaggioda dararag » dom ago 30, 2009 9:20 pm

comunque, nel file xml, nella prima riga (<?xml ecc.), prova ad aggiungere encoding="iso-8859-1"
Maledette aziende produttrici, l'unico telefilm interessante degli ultimi tempi l'hanno interrotto alla decima puntata... e chi voleva sapere la fine?
Avatar utente
dararag
Silver Member
Silver Member
 
Messaggi: 1116
Iscritto il: mar gen 22, 2008 8:57 pm
Località: Casoria

Re: Problema di codifica Server POP3

Messaggioda Luker94 » lun ago 31, 2009 1:55 pm

Già fatto, dall'inizio, ma non serve perché l'errore avviene quando il client di posta riceve i messaggi dal Server POP3 [rolleyes]
Avatar utente
Luker94
Aficionado
Aficionado
 
Messaggi: 116
Iscritto il: lun ago 11, 2008 12:20 pm
Località: Zena

Re: Problema di codifica Server POP3

Messaggioda dararag » lun ago 31, 2009 2:27 pm

ha provato anche con l'utf-8?
Maledette aziende produttrici, l'unico telefilm interessante degli ultimi tempi l'hanno interrotto alla decima puntata... e chi voleva sapere la fine?
Avatar utente
dararag
Silver Member
Silver Member
 
Messaggi: 1116
Iscritto il: mar gen 22, 2008 8:57 pm
Località: Casoria


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron
Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising