Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Classe non registrata

Problemi con i sistemi operativi di casa Microsoft? Questa è la sezione che fa per te!

Classe non registrata

Messaggioda linuxsun » mer apr 23, 2003 11:08 pm

Innanzitutto ne approfitto per salutare tutti,(sono nuovo del forum)
Il problema che intendo sottoporvi è il seguente, o meglio sono due e non credo siano collegati o dipendenti l'uno dall'altro, veniamo al dunque;
primo problema
SO W2K sp3 ita perfettamente funzionante (circa 2 anni)
un bel giorno non sono mai riuscito a capire il perché avviando un programma che usa il sottosistema a 16 bit compare il messaggio "SystemCurrentControlSetControlVirtualDeviceDrivers. Il formato del driver del dispositivo virtuale nel registro di sistema non è valido" Chiudi-Ignora cliccando su ignora il prog parte e non dà alcun problema. ho girato in lungo e largo il registro, ho reinstallato il service pack ma nulla da fare. Inutile dire che non dipende dal prog che si avvia in quanto l'ho reinstallato. comunque il tutto funziona bene a parte la schermata antipatica che appare.
secondo problema
sempre con il pallino di risolvere il problema precedente ed anche per dare una doverosa pulita al registro di W2K (dopo due anni leggermente appesantito) ho deciso di installare jv16PowerTools (davvero ottimo programma anche a confronto dei system mechanic) ho iniziato la pulizia del registro e a dire il vero l'ho effettuata in più riprese riflettendo su ciò che facevo. Adesso il registro è notevolmente più snello e la macchina sembra aver riacquistato nuova vita ma..... c'è sempre un ma!!!!! accidenti excel all'avvio dà il seguente errore "Classe non registrata
CLSID AC9F2F90-E877-11CE-9F68-00AA00574A4F" ovviamente continuando a cliccare sparisce ed excel funziona ma caricando dei fogli di lavoro con macro non c'è verso di farli andare. Ovviamente anche in questo caso "il classico rileva problemi e ripristina è stato più volte eseguito etc. etc." La chiave nel registro esiste e fà riferimento a REG_SZ Microsoft Forms 2.1 FormPackage
poi c'è una sottochiave InprocServ32 che contiente REG_SZ (valore non impostato)
e ThreadingModel REG_SZ Apartment.
Spero che qualcuno mi dia una mano non ho nessuna voglia di reinstallare tuttoooo. Aiuto e grazie (Scusate la lunghezza)[8D][8D]
Avatar utente
linuxsun
Aficionado
Aficionado
 
Messaggi: 71
Iscritto il: mer apr 23, 2003 2:37 am

Classe non registrata

Messaggioda linuxsun » mer apr 23, 2003 11:08 pm

Innanzitutto ne approfitto per salutare tutti,(sono nuovo del forum)
Il problema che intendo sottoporvi è il seguente, o meglio sono due e non credo siano collegati o dipendenti l'uno dall'altro, veniamo al dunque;
primo problema
SO W2K sp3 ita perfettamente funzionante (circa 2 anni)
un bel giorno non sono mai riuscito a capire il perché avviando un programma che usa il sottosistema a 16 bit compare il messaggio "SystemCurrentControlSetControlVirtualDeviceDrivers. Il formato del driver del dispositivo virtuale nel registro di sistema non è valido" Chiudi-Ignora cliccando su ignora il prog parte e non dà alcun problema. ho girato in lungo e largo il registro, ho reinstallato il service pack ma nulla da fare. Inutile dire che non dipende dal prog che si avvia in quanto l'ho reinstallato. comunque il tutto funziona bene a parte la schermata antipatica che appare.
secondo problema
sempre con il pallino di risolvere il problema precedente ed anche per dare una doverosa pulita al registro di W2K (dopo due anni leggermente appesantito) ho deciso di installare jv16PowerTools (davvero ottimo programma anche a confronto dei system mechanic) ho iniziato la pulizia del registro e a dire il vero l'ho effettuata in più riprese riflettendo su ciò che facevo. Adesso il registro è notevolmente più snello e la macchina sembra aver riacquistato nuova vita ma..... c'è sempre un ma!!!!! accidenti excel all'avvio dà il seguente errore "Classe non registrata
CLSID AC9F2F90-E877-11CE-9F68-00AA00574A4F" ovviamente continuando a cliccare sparisce ed excel funziona ma caricando dei fogli di lavoro con macro non c'è verso di farli andare. Ovviamente anche in questo caso "il classico rileva problemi e ripristina è stato più volte eseguito etc. etc." La chiave nel registro esiste e fà riferimento a REG_SZ Microsoft Forms 2.1 FormPackage
poi c'è una sottochiave InprocServ32 che contiente REG_SZ (valore non impostato)
e ThreadingModel REG_SZ Apartment.
Spero che qualcuno mi dia una mano non ho nessuna voglia di reinstallare tuttoooo. Aiuto e grazie (Scusate la lunghezza)[8D][8D]
Avatar utente
linuxsun
Aficionado
Aficionado
 
Messaggi: 71
Iscritto il: mer apr 23, 2003 2:37 am

Messaggioda Terno » gio apr 24, 2003 5:45 pm

Allora!
<b>TROVATA la SOLUZIONE</b> per il primo problema, che trovi QUI: è dovuto al fatto che una voce nel registro è corrotta! Trovi indicato come risolvere.

Per il secondo ... è ancora presto [;)].
Però puoi dirmi che versioni di Excel usi?
Avatar utente
Terno
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2800
Iscritto il: dom gen 26, 2003 5:16 pm
Località: Emilia Romagna

Messaggioda linuxsun » gio apr 24, 2003 6:50 pm

Ti ringrazio moltissimo !!!!
Era un problema che mi tormentava da più di un anno, in effetti avevo individuato la chiave e ci avevo anche smanettato ma senza risultati invece era sufficiente inserire la stringa "tipo dati" invece che una DLL specifica!!!! Grazie di nuovo [:D][:D][:D][:D][:D]
Excel e la versione 2000
[:D][:D][:D][:D][:D]
Avatar utente
linuxsun
Aficionado
Aficionado
 
Messaggi: 71
Iscritto il: mer apr 23, 2003 2:37 am

Messaggioda Terno » sab apr 26, 2003 6:22 pm

Prova ad usare RegMon e a fornire un listato di tutte le chiamate di Excel all'avvio; RegMon lo trovi QUI!
Avatar utente
Terno
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2800
Iscritto il: dom gen 26, 2003 5:16 pm
Località: Emilia Romagna


Torna a Sistema Operativo

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising