Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Stranissimo problema con XAMPP

Malfunzionamenti della LAN, suggerimenti sulla condivisione e altro legato alle reti.

Stranissimo problema con XAMPP

Messaggioda Avensis » mar lug 26, 2011 2:10 pm

Salve ragazzi,

Ho appena installato XAMPP e, almeno in locale, funziona alla perfezione: digitando "127.0.0.1" nella barra degli indirizzi del browser riesco ad accedere senza problemi al mio sito locale. Ho quindi creato un indirizzo statico con no-ip e l'ho puntato al mio indirizzo IP dinamico (installando anche il client) in modo che ci si possa collegare anche dall'esterno... il problema è che non è possibile! Se si prova ad accedere tramite l'indirizzo di no-ip (o anche digitando il mio IP esterno) la pagina si carica all'infinito e non succede niente.

Preciso che ho già effettuato il port forwarding della porta 80 verso il mio indirizzo 192.168.0.2 dove c'è il server XAMPP e, in effetti, secondo i vari siti di port testing tale porta risulta aperta quando XAMPP è in esecuzione... ma comunque non è possibile accedere. Ho anche disabilitato il firewall, provato a cambiare la porta, riavviato sia il computer che il router... insomma le ho provate tutte, ma niente da fare.

Qualcuno ha qualche altra idea? Tenete presente che non ho Fastweb (lo so che in tal caso per creare un server accessibile dall'esterno servono Hamachi o simili), che il mio router è un Netgear DG834G e che ho già utilizzato XAMPP qualche anno fa, funzionante anche dall'esterno. Non capisco proprio dove possa essere il problema.

Grazie.
Avatar utente
Avensis
Aficionado
Aficionado
 
Messaggi: 69
Iscritto il: gio mar 06, 2008 1:49 pm

Re: Stranissimo problema con XAMPP

Messaggioda Andy94 » sab lug 30, 2011 12:04 pm

Non so se possa esserti d'aiuto, ma quando io ho avuto lo stesso problema (con server HTTP homemade, senza XAMPP) avevo risolto inserendo nel file hosts il mio indirizzo IP locale e il riferimento a No-IP. Da fuori funzionava, non riuscivo ad accederci da dentro e con questo stratagemma ha funzionato.

A te da fuori funziona sempre?
Avatar utente
Andy94
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 9998
Iscritto il: lun apr 09, 2007 8:39 pm

Re: Stranissimo problema con XAMPP

Messaggioda Valerio matrix » ven set 30, 2011 6:23 pm

prova qui
topic68323.html
Avatar utente
Valerio matrix
Aficionado
Aficionado
 
Messaggi: 86
Iscritto il: dom nov 28, 2010 6:14 pm
Località: Anzio

Re: Stranissimo problema con XAMPP

Messaggioda Andy97 » sab ott 22, 2011 8:00 pm

Fastweb blocca tutte le connessioni in uscita comprese quelle dei web server (porta 80). Puoi risolvere il problema solo usando una vpn
Avatar utente
Andy97
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5514
Iscritto il: dom dic 26, 2010 10:38 am
Località: localhost | Lecce


Torna a Reti e Internet

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising