Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Disattivare touchpad

Per chi muove i primi passi nel mondo del pinguino

Disattivare touchpad

Messaggioda Pct » lun lug 11, 2011 2:32 pm

Ciao a tutti

volevo disattivare il touchpad (netbook asus Eeepc) su lubuntu 11.04.. per farlo, dò questo comando da esegui :

Codice: Seleziona tutto
synclient TouchpadOff=1


funziona, però quando riavvio il pc il touchpad si riattiva.. qualcuno sa come fare per disabilitarlo completamente? [uhm]
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda farbix89 » lun lug 11, 2011 2:42 pm

I dispositivi di inserimento sono controllati da Xorg,il server grafico.

Disattivando da lì il touchpad,non funzionerà più.

Puoi postarmi il contenuto del file /etc/X11/xorg.conf?
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » lun lug 11, 2011 3:01 pm

Come faccio ad aprire il file xorg.conf? [uhm] perché praticamente, ho provato da terminale a digitare cd /ect/X11/xorg.conf ma mi diceva bash: file o directory non esistente. Ho provato allora cd etc/X11 e poi a scrivere xorg.conf ma non funziona. Ho provato anche a scrivere Xorg da esegui, ma non succede niente [boh] (non mi dà nemmeno errore però)

se da etc/X11 dò il comando dir, non trovo nessun riferimento o xorg.conf o qualcosa del genere [8)]
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm


Re: Disattivare touchpad

Messaggioda farbix89 » lun lug 11, 2011 3:45 pm

Quasi dimenticavo [acc2] [B)]

Da qualche edizione di Ubuntu questo file non è più presente perché X viene già configurato a dovere durante l'installazione del sistema

Cerco strade alternative.
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » lun lug 11, 2011 3:54 pm

grazie farbix [^]

non starci solo a impazzire eh, se non trovi niente non importa, più che altro era per comodità [;)]
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda ninjabionico » lun lug 11, 2011 11:15 pm

Con Fn+F7 non funziona? (almeno sul mio Acer la combinazione di tasti è questa)
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 8:16 am

No, non so perché ma su lubuntu i tasti funzione non funzionano (scusate il gioco di parole); eppure su ubuntu funzionano regolarmente (almeno quelli del volume, gli altri non li ho provati) [boh]

Anche i tasti per spegnere monitor, ingrandire o rimpicciolire lo schermo ecc. su Ubuntu funzionano ma su lubuntu no
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda farbix89 » mar lug 12, 2011 8:25 am

Ci avevo visto giusto [:)]

http://blog.skydiamond.org/linux/disabi ... -su-linux/

se non hai il file xorg.conf,puoi generarlo da una shell (quindi niente terminale) digitando
Codice: Seleziona tutto
sudo Xorg -configure


Un bel file xorg.conf.new verrà depositato nella cartella di root.

Posizionalo nella cartella giusta

Codice: Seleziona tutto
mv /root/xorg.conf.new /etc/X11/xorg.conf


Riavvia tutto e digita il comando indicato nell'articolo.
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 9:21 am

Grazie farbix [;)] Mi sono venuti però alcuni dubbi:

Niente terminale, nel senso che non devo dare quei comandi da terminale? E poi, che cos'è una shell? [?] pensavo che terminale e shell fossero la stessa cosa xD Scusa l'ignoranza [:-H]
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda farbix89 » mar lug 12, 2011 10:07 am

Il terminale come lo conosciamo nei vari ambienti grafici è l'emulazione della shell,ossia la vera riga di comando

http://www.MegaLab.it/2208/primo-incont ... l-testuale
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 10:35 am

Grazie mille, chiarissimo come sempre [^]

Allora: ho dato il comando che mi hai detto da shell, ovvero sudo Xorg -configure , ma la risposta è stata questa :

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock and start again.

Please consult The X.Org Foundation support at http://wiki.x.org for help.

ddxSigGiveUp: Closing log.
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda farbix89 » mar lug 12, 2011 10:45 am

Devi chiudere l'interfaccia grafica....non funge con GNOME/Unity attivo.

Leggi l'articolo che ti ho postato...all'inizio indica come entrare nella shell [;)]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 11:52 am

farbix89 ha scritto:Devi chiudere l'interfaccia grafica....non funge con GNOME/Unity attivo.

Leggi l'articolo che ti ho postato...all'inizio indica come entrare nella shell [;)]


sisi, l'avevo letto (avevo letto l'inizio, su coem aprire la shell), solo che avendo un solo utente non mi dava la schermata di login, si avviava lubuntu automaticamente e per fare in fretta ho caricato la shell da lì [bleh] (non pensavo desse problemi [:-H] )

Ora riprovo
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 12:12 pm

non riesco a impostare lubuntu in modo che invece che avviare automaticamente l'utente, mi chieda la password per entrare.. così lxde non dovrebbe essere attivo, giusto? Oppure conosci un altro modo per disattivarlo?

perché se vado su utenti e gruppo, sembra che sia impostate come se dovesse già chiedermi la password prima di accedere alla sessione (e invece non lo fa), infatti l'opzione "non richiedere la password all'accesso della sessione" è grigia, non è attiva, non si può cliccare [boh]

P.S. che stupido, non avevo pensato di fare semplicemente chiudi sessione [acc2]

Ora procedo :P
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 12:18 pm

Niente da fare.. anche se chiudo la sessione, ritrovandomi così davanti alla schermata di login come scritto nell'articolo, se scrivo dò dalla shell quei comandi mi dà sempre lo stesso errore [8)]
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda farbix89 » mar lug 12, 2011 1:37 pm

Pct ha scritto:Niente da fare.. anche se chiudo la sessione, ritrovandomi così davanti alla schermata di login come scritto nell'articolo, se scrivo dò dalla shell quei comandi mi dà sempre lo stesso errore [8)]


Idea [:)]

Ho capito l'inghippo: nell'articolo viene mostrato come avviare una shell all'interno del server X....se non spegni questo,la shell che ottieni è inutile.

Puoi spegnere temporaneamente Xorg seguendo queste istruzioni

topic72703.html
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 2:17 pm

Ecco fatto, grazie mille [^]

Ho creato e spostato il file xorg.conf

Non riesco però ad aprirlo da terminale; mi dice file o directory non esistente.. eppure nella directory ect/X11 riesce a entrare e se faccio dir il file xorg.conf me lo trova [boh]

Così l'ho aperto dal file manager; non riesco però a trovare la parte di "input device" relativa a "Synaptics Touchpad"; ci sono solo le parti relative a "mouse0" e "Keyboard0" ( Section "InputDevice" Identifier "keyboard0" ecc. , e dopo quella sezione c'è Section "InputDevice" Identifier "mouse0".. devo modificarne una delle due? Se si quale? (dato che SHMConfig non c'è in nessuna delle due) ) [uhm]

Ti posterei il contenuto di tutto il file xorg.conf, se fosse così gentile da farmelo incollare.

Oppure non modifico nessuna delle due e aggiungo direttamente tutto questo ? :

Codice: Seleziona tutto
Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
Option "SHMConfig" "on"
EndSection


Tra l'altro, ho provato a modificare, ma non mi fa salvare nulla.. se faccio salva, o salva con nome, o provo a chiederlo e a dirgli di salvare le modifiche, mi chiede prima dove salvarlo, poi mi dice che il file xorg.conf esiste già e mi chiede se sovrascriverlo, quindi se do l'ok mi dice "impossibile aprire il file per la scrittura" (penso che faccia così per forza visto che lo aperto da file manager tramite leafpad. Da terminale non riesco proprio ad aprirlo..

Comunque se non si riesce non importa, ti ringrazio comunque per l'aiuto e la pazienza [;)]
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm

Re: Disattivare touchpad

Messaggioda farbix89 » mar lug 12, 2011 2:20 pm

Pct ha scritto:
Ti posterei il contenuto di tutto il file xorg.conf, se fosse così gentile da farmelo incollare.


Copia il contenuto del file qui

http://pastebin.com/

e posta il link
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Disattivare touchpad

Messaggioda Pct » mar lug 12, 2011 3:07 pm

Ho scoperto che solo se facevo seleziona tutto, e poi copia, non lo incollava (o non lo copiava?); se copio un pezzetto per volta funziona.. avrei dovuto pensarci prima [acc2]

Ecco il log:

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
Screen 2 "Screen2" RightOf "Screen1"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "dri2"
Load "record"
Load "extmod"
Load "dbe"
Load "glx"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "Monitor2"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "AccelMethod" # [<str>]
#Option "DRI" # [<bool>]
#Option "ColorKey" # <i>
#Option "VideoKey" # <i>
#Option "FallbackDebug" # [<bool>]
#Option "Tiling" # [<bool>]
#Option "Shadow" # [<bool>]
#Option "SwapbuffersWait" # [<bool>]
#Option "XvMC" # [<bool>]
#Option "XvPreferOverlay" # [<bool>]
#Option "DebugFlushBatches" # [<bool>]
#Option "DebugFlushCaches" # [<bool>]
#Option "DebugWait" # [<bool>]
#Option "HotPlug" # [<bool>]
#Option "RelaxedFencing" # [<bool>]
Identifier "Card0"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "Rotate" # <str>
#Option "fbdev" # <str>
#Option "debug" # [<bool>]
Identifier "Card1"
Driver "fbdev"
BusID "PCI:0:2:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
### <percent>: "<f>%"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
#Option "ModeSetClearScreen" # [<bool>]
Identifier "Card2"
Driver "vesa"
BusID "PCI:0:2:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Card1"
Monitor "Monitor1"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen2"
Device "Card2"
Monitor "Monitor2"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
È più facile spezzare un atomo che un pregiudizio - Albert Einstein
Avatar utente
Pct
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1933
Iscritto il: dom set 09, 2007 4:38 pm


Torna a NewBie

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising