Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Selezione SO sparita

Problemi con i sistemi operativi di casa Microsoft? Questa è la sezione che fa per te!

Selezione SO sparita

Messaggioda gippo79 » mar giu 28, 2011 6:49 pm

ciao a tutti ho un problema:
avevo due SO, Xp 64 bit e Xp 32 bit,
dopo aver installato Windows 7 64 bit al posto di Xp 64 bit (installazione pulita)
mi è sparita la schermata di selezione del SO al riavvio del Pc, ho controllato dal Pannello di controllo le opzioni avanzate del sistema e mi risultava solo Windows 7 (non c'era traccia di Xp 32 bit), nonostante vedessi chiaramente che tutte le cartelle relative al SO di Xp siano presenti nella partizione, allora ho installato easybcd ma anche da là mi risultava solo Windows 7,allora ho creato un nuovo SO da Easybcd di Xp 32 bit, così facendo sono riuscito a ripristinare la schermata di selezione al riavvio del Pc però se scelgo Xp 32 bit il sistema non parte perché mi dice che il percorso \NST\ntldr non è presente (NB Da Easybcd: Bootloader Path: \NST\ntldr!!!!).
Come faccio a poter scegliere di caricare Xp 32 bit senza problemi? chiedo aiuto
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda crazy.cat » mar giu 28, 2011 6:57 pm

fixboot e fixmbr http://www.MegaLab.it/4024/risolvere-gl ... e-di-linux
oppure pagina 3 http://www.MegaLab.it/4024/3/risolvere- ... e-di-linux

(ma temo non serviranno a molto e ti toccherà reinstallare xp e poi seven)
Quando i molti governano, pensano solo a contentar sé stessi, si ha allora la tirannia più balorda e più odiosa: la tirannia mascherata da libertà.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Re: Selezione SO sparita

Messaggioda gippo79 » mar giu 28, 2011 7:09 pm

io ti ringrazio ma ti chiedo come mai?
cioè perché dovrò re-installare anche XP? quel sistema operativo io non l'ho toccato e non capisco perché ora mi dà questo problema..........e soprattutto come avrei dovuto procedere per non incappare in errori simili?
non posso avere due SO come Windows 7 e Xp e scegliere ogni volta quale caricare?
ciao e grazie ancora
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm


Re: Selezione SO sparita

Messaggioda crazy.cat » mar giu 28, 2011 7:17 pm

gippo79 ha scritto:non posso avere due SO come Windows 7 e Xp e scegliere ogni volta quale caricare?

Si, si installa prima xp e poi seven che va a riscrivere il boot e se ne assume la gestione.
Se mi chiedi di spiegarti il perché non saprei cosa dirti al momento...
Quando i molti governano, pensano solo a contentar sé stessi, si ha allora la tirannia più balorda e più odiosa: la tirannia mascherata da libertà.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Re: Selezione SO sparita

Messaggioda gippo79 » mar giu 28, 2011 7:35 pm

Ah ok, ora già ho più chiara la situazione almeno......quindi dovevo reinstallare prima Xp.......ma siamo sicuri che così facendo la schermata di selezione del SO non scompare? e come mai Seven non legge proprio Xp? come ho scritto sopra, se andavo nel sistema,opz avanzate ecc ecc non risultava nemmeno Xp tra i sistemi operativi..........

PS: ho provato la prima soluzione ma,una volta caricati i files dal cd di Xp, non ho la possibilità di premere R per la console di ripristino,mi dà subito la schermata con le varie partizioni e i vari HD.................come faccio? grazie ancora
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » mer giu 29, 2011 12:09 pm

per installare i due sistemi senza avere piu di questi problemi, ti consiglio di seguire questa guida:
http://www.MegaLab.it/4115/dual-boot-installare-windows-xp-vista-e-windows-7-sullo-stesso-pc-nel-modo-corretto

il motivo per cui si è danneggiata la seconda installazione di xp credo sia nel fatto che il sistema che hai cancellato era il primario, e conteneva i files di boot di entrambi i sistemi.
prova come ha detto crazy.cat con un fixboot e fixmbr, ma anche secondo me non risolvi.
dovrai salvare i dati dall'xp e reinstallarlo seguendo la guida sopra.
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » mer giu 29, 2011 1:18 pm

mattpillon ha scritto:per installare i due sistemi senza avere piu di questi problemi, ti consiglio di seguire questa guida:
http://www.MegaLab.it/4115/dual-boot-installare-windows-xp-vista-e-windows-7-sullo-stesso-pc-nel-modo-corretto

il motivo per cui si è danneggiata la seconda installazione di xp credo sia nel fatto che il sistema che hai cancellato era il primario, e conteneva i files di boot di entrambi i sistemi.
prova come ha detto crazy.cat con un fixboot e fixmbr, ma anche secondo me non risolvi.
dovrai salvare i dati dall'xp e reinstallarlo seguendo la guida sopra.

intanto grazie per la risposta,
ma, come ho scritto prima, ho provato la procedura fixboot e fixmbr ma neanche riesco a farla partire, perché non mi si presenta la possibilità di premere R per caricare la console di ripristino una volta caricato il cd di installazione di Xp (l'ho scritto sopra).
Mi chiede direttamente dove voglio installare Xp da zero.......(schermata di selezione hard disk).
comunque sto già provvedendo al salvataggio dei dati del vecchio Xp,se non risolvo a questo punto installo Seven 32 bit nell'altra partizione direttamente........che ne dite?
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » mer giu 29, 2011 1:28 pm

secondo me va bene, ma segui sempre la guida che ti ho postato, altrimenti ti si ricrea un boot misto e alla prossima disinstallazione rischi di avere lo stesso problema.
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » lun lug 04, 2011 11:01 am

Allora: seguendo quella guida, dopo aver masterizzato il cd bootloader, provo ad inserirlo nel pc ed a caricarlo riavviando tutto col boot in Cd-Rom, ms-dos carica ma poi compare una scritta diversa da quella che vedo nella guida:
Driver version V340
Device Name Banana
No drives found, aborting installation

Device driver not found: BANANA
No valid CdRom device drivers selected
A:\>

e ovviamente se digito mrbooter non succede proprio nulla........non carica nulla........

Che devo fare? come mai non carica il cd bootloader?
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » lun lug 04, 2011 1:57 pm

al momento non ho sottomano il cd per provare, comunque prova a dare il comando
Codice: Seleziona tutto
dir

e vedi cosa esce fuori.
se dice che il disco è vuoto, prova a cambiare drive , scrivi
Codice: Seleziona tutto
c:

e poi usai di nuovo dir, e vedi se ti appare l'elenco dei file contenuti nel cd.
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » lun lug 04, 2011 3:44 pm

allora

ho dato il comando dir ed effettivamente compare la lista dei files nel Cd...........c'è anche l'exe MRBOOTER, però se dò il comando mrbooter non succede ancora nulla..............che devo fare?

EDIT: mi correggo, non succede nulla ma comunque mi blocca tutto.....h riprovato a dare il comando dir ma il cursore ormai è bloccato a capo del comando MRBOOTER e non mi fà digitare più niente...........boh
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » lun lug 04, 2011 6:33 pm

forse ha problemi con il tuo lettore, come annotato anche nella guida di zane.
prova ad installarlo da una penna usb.
scarica la iso di masterbooter, dal sito originale e non da MegaLab, estraila con winrar o un programma simile in una cartella.
poi prendi questa utility, crea una penna bootable in dos, e copiaci dentro tutti i files che hai estratto dalla iso di masterbooter.
riavvia il pc con il boot da usb e vedi se funzia.......
ps prima di fare tentativi vari, ricordati di fare un backup di tutti i dati importati che hai sul disco, perché quando si gioca con queste cose non si sa mai cosa puo succedere alle partizioni.....
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » lun lug 04, 2011 9:04 pm

allora, ho scaricato BootFlashDos che però non mi riconosce la mia chiavetta usb, poi dal link che mi hai dato tu ho visto che è solo per Xp/2003............un problema dietro l'altro..........credo proprio che se non trovo nessuna soluzione passo alla formattazione violenta.....tanto i dati importanti li ho salvati tutti prima............comunque grazie dei tentativi.......
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » lun lug 04, 2011 9:13 pm

allora, ho scaricato BootFlashDos che però non mi riconosce la mia chiavetta usb

sotto windows 7, devi lanciarlo da amministratore perché abbia accesso ai drive usb: click dx sull'eseguiblle, esegui come amministratore. [ciao]
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » mar lug 05, 2011 11:05 am

ooops hai ragione.....ancora mi devo abituare ad eseguire i programmi come amministratore..........in ogni caso avrai capito che non sono proprio "esperto" di queste cose.........per creare la USB bootable in DOS, quale delle 4 opzioni devo spuntare in BootFlashDos?
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » mar lug 05, 2011 12:14 pm

seleziona solo la prima opzione, quick format, il resto non ti serve.
fai attenzione a scegliere il drive giusto, controlla in risorse del computer la lettera assegnata alla penna usb, perché il disco che scegli verrà formattato.
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » mar lug 05, 2011 12:31 pm

ok............ma scusa allora non ho mica capito a che serve BootFlashDos......serve solo a formattare la chiavetta USB? e non potevo formattarla anche con Windows? vabbè comunque ora formatto e poi copio i files estratti dalla ISO (che poi ISO non è.....infatti mi chiedo perché la chiamate ISO quando è un file .zip) di Masterbooter......e poi riavvio il pc con il boot da USB (che non sono sicuro di avere tra le possibilità....)

grazie
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda gippo79 » mar lug 05, 2011 12:49 pm

ho provato spuntando il quick format e senza, ma mi dà sempre lo stesso errore:FormatEx Error[11]:An error occurred formating the drive.
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm

Re: Selezione SO sparita

Messaggioda mattpillon » mar lug 05, 2011 2:09 pm

in effetti il file è zip, ricordavo male.
bootflashdos non formatta solamente la penna, ma la rende bootable in dos, con alcuni comandi di base.
la procedura che ti ho indicato funziona, ho appena provato sul mio pc, crea una penna usb bootable con dentro il bootloader.
eventuali errori devono essere dovuti ad altri problemi di cui sinceramente adesso non ho idea.... [uhm]
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: Selezione SO sparita

Messaggioda gippo79 » mar lug 05, 2011 5:06 pm

il mio problema è che Bootflashdos non riesce a finire la formattazione e mi dà quell'errore di cui sopra........ci fosse una cosa che mi riesce senza problemi oh :P
Avatar utente
gippo79
Neo Iscritto
Neo Iscritto
 
Messaggi: 24
Iscritto il: lun set 03, 2007 7:08 pm


Torna a Sistema Operativo

Chi c’è in linea

Visitano il forum: Nessuno e 3 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising