Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

perché Linux da pen drive USB non si avvia?

Questa è la sezione per chiedere e dare aiuto e consigli su Mac OS e sui software per Mac, per risolvere ogni dubbio sul mondo della mela mordicchiata, per sfatare ogni strana idea che avete o che vi hanno riferito sul Mac, per fare il grande salto, o anche solo per semplice curiosità...
Qui vige una sola regola: Think Different!

perché Linux da pen drive USB non si avvia?

Messaggioda spike_20 » ven apr 01, 2011 8:59 am

Sto tentando a tutti i costi di riuscire a far avviare LInux MInt 10, nome in codice Julia, da chiavetta USB, ma, a dispetto dei diversi tentativi, non sono ancora riuscito nel mio intento.

La prima prova che ho fatto è ricorrere al programma UnetBootin (una volta creata la chiavetta bootabile, ho lasciato il file syslinux.cfg così com'era di default, senza editarlo), e questo è stato il primo dei tentativi fallimentari: da Mac Pro, usando sia rEFIt, sia poi il cd bootable di Plop Boot Manager, la pen drive USB neo creata non vuole saperne di avviarsi (non compare neppure il GRUB Boot Screen). Ho cambiato anche flash disk, ma invano, escludendo così eventuali problemi della stessa.

Il secondo tentativo è consistito nel creare la chiavetta persistente manualmente, masterizzando l'iso di Mint Julia su dvd. Bootando poi da quest'ultimo ho eseguito l'installazione partizionando la chiavetta usb da 8 GB di cui dispongo, secondo questo schema:

1a partizione --------> dedicata a rEFIt, file system HFS+ (25 MB)

2a partizione --------> grub, file system ext4, settata su partizione di avvio EFI (100 MB)

3a partizione --------> root, file system ext3 journaled, punto di mount / (3072 MB)

4a partizione --------> dedicata ai dati da salvare, file system ext3 journaled, punto di mount /usr/local (4800 MB)


L'installazione si conclude con successo, ma avviando poi da pen drive si blocca sempre al prompt dei comandi. Cosa ho sbagliato ancora? Mi sto arrovellando il cervello!!! [cry]

Non è che per caso la seconda partizione allocata per il boot loader (GRUB) deve avere come punto di mount /boot, e magari un file system diverso, tipo ad esempio FAT32, invece che essere indicata come "partizione di avvio EFI"?
E la terza partizione, invece, è giusto che abbia il file system ext3 oppure deve essere formattata in FAT32?
Infine, l'ultima, la quarta, ha il punto di mount corretto?


Ultimo tentativo, sempre allocando le varie partizioni manualmente, seguiva questo schema:

1a partizione --------> GRUB, file system ext2, punto di mount /boot (100 MB)

2a partizione --------> root, file system ext2, punto di mount / (3072 MB)

3a partizione --------> swap, file system linux-swap (1024 MB)

4a partizione --------> dedicata ai dati da salvare, file system ext2 (spazio restante di circa 4096 MB)


Tendando il boot, anche così, comunque si blocca sempre allo stesso punto e senza neppure arrivare al GRUB boot screen. Non so più come procedere per dipanare la matassa!!! [cry]

Ho provato invece a avviare la chiavetta così partizionata, da PC, e mentre lì il GRUB boot screen compare, poco dopo aver avviato LInux MInt 10 si blocca anche lì, e un messaggio a video sotto dos recita quanto segue:

/dev/sdb2 root device doesn't exist

ma come può non esistere la partizione di root se l'ho creata e c'ha installato la distro? Forse è il file system ext2 su cui non riesce a leggere? Ma se formatto la partizione di root ("/") in FAT32, quando vado ad attribuirgli il punto di mount non posso assegnargli lo slash ("/"), solo /dos o /win: come procedo allora? Qualcuno può aiutarmi? E comunque rimane sempre il problema che da Mac Pro (il desktop, appunto) non mi compare neppure la schermata del GRUB, appena avvio con rEFIt (se provo poi ad avviare con Plop Boot Manager si blocca proprio il programma)... [cry]


Un grazie anticipato a tutti coloro che mi presteranno manforte. [;)]
Avatar utente
spike_20
Bronze Member
Bronze Member
 
Messaggi: 679
Iscritto il: ven gen 18, 2008 2:31 pm

Re: perché Linux da pen drive USB non si avvia?

Messaggioda andy » ven mag 13, 2011 5:34 pm

A me una volta MrTFM ha risposto che il boot da usb su Mac è una cosa alquanto difficile, se non impossibile.
Altro non sono in grado di dirti.
Con MegaLab non si finisce mai di imparare!!
Avatar utente
andy
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1955
Iscritto il: mer mar 30, 2005 9:27 pm
Località: Rimini


Torna a Sistema Operativo e Software Mac

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising