Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Installazione OpenSuse e partizionamento HD esterno USB

Per chi muove i primi passi nel mondo del pinguino

Installazione OpenSuse e partizionamento HD esterno USB

Messaggioda Dam » mar giu 23, 2009 3:17 pm

Ciao ragazzi!

Volevo ritentare l'approccio al mondo Linux per la seconda volta (dopo aver fatto litigare Ubuntu e il mio modem ADSL la prima volta... [acc2] ).Ho scelto così di provare con OpenSuse, dopo aver letto la guida di Zane.

Prima domandona:
-Avendo io un HD interno poco capiente (80 GB, 65 dei quali pieni) e un DH esterno con alimentazione separata da 500GB, vorrei sapere se fosse possibile installare OpenSuse sull'hard disk esterno anzichè in quello interno...è un pasticcio, o si può fare?

Seconda domandona:
-Siccome mi hanno installato da poco il nuovo modem Alice wi-fi, mi sono munito di una chiavetta D-Link DWL-G122 ver. C1 FW ver. 3.30, che con Windows XP SP3 funziona divinamente.

Ho scaricato e masterizzato il LiveCD di OpenSuse e l'ho provata, ma c'è però il problema della connessione: la rete veniva rilevata, ma una volta inserita la chiave Wpa e salvate le impostazioni, comunque non si connetteva nulla. Riguardando le proprietà della connessione ho notato che la chiave era magically cambiata.... [8)]

Ora, cercando in internet ho trovato questa guida piuttosto esauriente sull'installazione della chiavetta, peccato però sia per Ubuntu...immagino non sia lo stesso anche per OpenSuse, vero?

In un altro sito ho trovato questo paragrafetto, ma da bravo ignorantissimo in materia linux non ci ho capito un granchè....

**** OPENSUSE (testing in 10.2 and 10.3)


Use commands in terminal. Use the commands separated by | in different shots.

PRE-UP SCRIPT FILE:

# install rt73 driver (http://www.serialmonkey.com), create connection and configure this with traditional method option
# create a script file with this lines to rise device on boot and copy to: sudo cp <directory>/pre-up-wlan0 /etc/sysconfig/network/scripts/pre-up-wlan0
# change permission: sudo chmod 755 /etc/sysconfig/network/scripts/pre-up-wlan0
# edit file /etc/sysconfig/network/ifcfg-wlan0 and add the line PRE_UP_SCRIPT='pre-up-wlan0': su | gedit /etc/sysconfig/network/ifcfg-wlan0
# edit file /etc/sysconfig/network/config to deactivating rename interfaces network process with FORCE_PERSISTENT_NAMES=no (if line exists): su | gedit /etc/sysconfig/network/config

ifconfig wlan0 up


...ora....so che vi starete rotolando per terra dalle risate (lo farei anch'io [devil] ) ma non è che magari qualcuno ha la pazienza di darmi una manina? [grazie]
<<Come i boschi, segreta come brezza che, senza frasi, agita gli alberi più superbi>>
E. Dickinson
Avatar utente
Dam
Senior Member
Senior Member
 
Messaggi: 164
Iscritto il: dom mar 26, 2006 12:23 pm

Re: Installazione OpenSuse e partizionamento HD esterno USB

Messaggioda ninjabionico » gio giu 25, 2009 11:40 pm

Ciao.

Dam ha scritto:Ciao ragazzi!

Volevo ritentare l'approccio al mondo Linux per la seconda volta (dopo aver fatto litigare Ubuntu e il mio modem ADSL la prima volta... [acc2] ).Ho scelto così di provare con OpenSuse, dopo aver letto la guida di Zane.


Non ricordo di nessuna tua discussione su problemi con un modem ADSL con Ubuntu... [8D]
... è Usb oppure Ethernet?
Perché non secondo caso non ci sarebbe dovuto essere nessun problema. [fischio]

Dam ha scritto:Prima domandona:
-Avendo io un HD interno poco capiente (80 GB, 65 dei quali pieni) e un DH esterno con alimentazione separata da 500GB, vorrei sapere se fosse possibile installare OpenSuse sull'hard disk esterno anzichè in quello interno...è un pasticcio, o si può fare?


Certo che si può fare e non è un pasticcio, solo che sarebbe opportuno che tu conoscessi un po' la gestione delle partizioni con Linux e il funzionamento dei bootmanager come Grub...
... in parole povere basta installarlo sul disco esterno invece di quello interno, quindi quando vuoi avviare GNU/Linux fare il boot dal disco esterno, tutto qui.

Dam ha scritto:Seconda domandona:
-Siccome mi hanno installato da poco il nuovo modem Alice wi-fi, mi sono munito di una chiavetta D-Link DWL-G122 ver. C1 FW ver. 3.30, che con Windows XP SP3 funziona divinamente.


Mi sembra che la chiavetta sia supportata, al massimo utilizzi Ndiswrapper con i driver di Xp

Dam ha scritto:Ho scaricato e masterizzato il LiveCD di OpenSuse e l'ho provata, ma c'è però il problema della connessione: la rete veniva rilevata, ma una volta inserita la chiave Wpa e salvate le impostazioni, comunque non si connetteva nulla. Riguardando le proprietà della connessione ho notato che la chiave era magically cambiata.... [8)]


Scusa, come magicamente cambiata, nel senso che non te la vede come D-Link?
Se è così è abbastanza normale, Linux tende a riconoscere i chip utilizzati, che spesso non coincidono con marche e modelli delle schede acquistate (visto che i produttori spesso utilizzano anche chip diversi su pennette dello stesso modello cambiando solo la revisione, tanto l'utente non si accorge di niente perché tutto è gestito dai driver scritti dal costruttore per Windows).

Dam ha scritto:Ora, cercando in internet ho trovato questa guida piuttosto esauriente sull'installazione della chiavetta, peccato però sia per Ubuntu...immagino non sia lo stesso anche per OpenSuse, vero?


La guida è parecchio sorpassata... la 7.04 è dell'aprile del 2007, ovvero 2 anni fa, da allora sono uscite la 7.10, la 8.04, la 8.10 e la 9.04...
... ne è passata di acqua sotto i ponti e direi che probabilmente dalla 7.10 o al massimo dalla 8.04 quella scheda sarà riconosciuta automaticamente e utilizzabile con i driver liberi del kernel Linux.
Mi sembra dunque strano che la OpenSuse non te la riconosca... [uhm]
... che versione stai provando a installare? (l'ultima mi sembra sia la 11.1 scaricabile da http://software.opensuse.org/ )

Inoltre, in materia di guide, in teoria le guide Ubuntu/Debian potrebbero essere modificate per funzionare anche con OpenSuse, però nonostante siano tutte e tre distribuzioni GNU/Linux, Novell/Suse ha profondamente personalizzato il sistema e tutta la configurazione passa per Yast2, quel programmino che rende OpenSuse così simile a Windows e al suo Pannello di controllo, eventuali configurazioni fatte manualmente negli usuali file di configurazione usati nelle altre distribuzioni spesso vengono ignorate dal sistema.

Dam ha scritto:In un altro sito ho trovato questo paragrafetto, ma da bravo ignorantissimo in materia linux non ci ho capito un granchè....

**** OPENSUSE (testing in 10.2 and 10.3)


Use commands in terminal. Use the commands separated by | in different shots.

PRE-UP SCRIPT FILE:

# install rt73 driver (http://www.serialmonkey.com), create connection and configure this with traditional method option
# create a script file with this lines to rise device on boot and copy to: sudo cp <directory>/pre-up-wlan0 /etc/sysconfig/network/scripts/pre-up-wlan0
# change permission: sudo chmod 755 /etc/sysconfig/network/scripts/pre-up-wlan0
# edit file /etc/sysconfig/network/ifcfg-wlan0 and add the line PRE_UP_SCRIPT='pre-up-wlan0': su | gedit /etc/sysconfig/network/ifcfg-wlan0
# edit file /etc/sysconfig/network/config to deactivating rename interfaces network process with FORCE_PERSISTENT_NAMES=no (if line exists): su | gedit /etc/sysconfig/network/config

ifconfig wlan0 up


...ora....so che vi starete rotolando per terra dalle risate (lo farei anch'io [devil] ) ma non è che magari qualcuno ha la pazienza di darmi una manina? [grazie]


Per il momento ignora questo paragrafo, è per la vecchia versione di OpenSuse, la 10.


[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Installazione OpenSuse e partizionamento HD esterno USB

Messaggioda Dam » sab giu 27, 2009 9:50 am

ninjabionico ha scritto:Ciao.


Non ricordo di nessuna tua discussione su problemi con un modem ADSL con Ubuntu... [8D]
... è Usb oppure Ethernet?
Perché non secondo caso non ci sarebbe dovuto essere nessun problema. [fischio]


In effetti per il modem mi ero gettato nel forum ufficiale di ubuntu, ma purtroppo nessuno è riuscito a trovare una soluzione...siamo giunti alla conclusione che il mio modem usb non era compatibile... [acc2]

ninjabionico ha scritto:Certo che si può fare e non è un pasticcio, solo che sarebbe opportuno che tu conoscessi un po' la gestione delle partizioni con Linux e il funzionamento dei bootmanager come Grub...
... in parole povere basta installarlo sul disco esterno invece di quello interno, quindi quando vuoi avviare GNU/Linux fare il boot dal disco esterno, tutto qui.


Con le partizioni qualcosa ci so fare - il minimo indispensabile, eh! - però per l'uso di Grub invece non molto...disintallato Ubuntu infatti Windows non aveva più la sequenza di boot (detta con termini eretici) e, non ho idea come, in mezz'ora di tentativi sono riuscito a ripristinarlo. Ma mai più, mai più, mai più.
Un amico mi ha detto che però installandolo in un HD esterno la velocità sarebbe estremamente ridotta, vero? Uhmm...



ninjabionico ha scritto:Mi sembra che la chiavetta sia supportata, al massimo utilizzi Ndiswrapper con i driver di Xp


Ehmm...ehhh=? [uhm]


ninjabionico ha scritto:Scusa, come magicamente cambiata, nel senso che non te la vede come D-Link?
Se è così è abbastanza normale, Linux tende a riconoscere i chip utilizzati, che spesso non coincidono con marche e modelli delle schede acquistate (visto che i produttori spesso utilizzano anche chip diversi su pennette dello stesso modello cambiando solo la revisione, tanto l'utente non si accorge di niente perché tutto è gestito dai driver scritti dal costruttore per Windows).


Nel senso che la chiave wpa cambiava da sola...e penso potesse essere questo la causa del problema di connessione...penso [rolleyes]


ninjabionico ha scritto:La guida è parecchio sorpassata... la 7.04 è dell'aprile del 2007, ovvero 2 anni fa, da allora sono uscite la 7.10, la 8.04, la 8.10 e la 9.04...
... ne è passata di acqua sotto i ponti e direi che probabilmente dalla 7.10 o al massimo dalla 8.04 quella scheda sarà riconosciuta automaticamente e utilizzabile con i driver liberi del kernel Linux.
Mi sembra dunque strano che la OpenSuse non te la riconosca... [uhm]
... che versione stai provando a installare? (l'ultima mi sembra sia la 11.1 scaricabile da http://software.opensuse.org/ )


Si, stavo usando la 11.1, infatti :)


ninjabionico ha scritto:Inoltre, in materia di guide, in teoria le guide Ubuntu/Debian potrebbero essere modificate per funzionare anche con OpenSuse, però nonostante siano tutte e tre distribuzioni GNU/Linux, Novell/Suse ha profondamente personalizzato il sistema e tutta la configurazione passa per Yast2, quel programmino che rende OpenSuse così simile a Windows e al suo Pannello di controllo, eventuali configurazioni fatte manualmente negli usuali file di configurazione usati nelle altre distribuzioni spesso vengono ignorate dal sistema.



Per il momento ignora questo paragrafo, è per la vecchia versione di OpenSuse, la 10.


Ricevuto ^^

Tra l'altro, un mio amico mi ha fatto vedere il suo Kubuntu..e cavolo, devo dire che mi è piaciuto parecchio! ^^ E se mi dessi a questa distro? [std]


[ciao][/quote]
Ciao, e grazie mille [;)]
<<Come i boschi, segreta come brezza che, senza frasi, agita gli alberi più superbi>>
E. Dickinson
Avatar utente
Dam
Senior Member
Senior Member
 
Messaggi: 164
Iscritto il: dom mar 26, 2006 12:23 pm

Re: Installazione OpenSuse e partizionamento HD esterno USB

Messaggioda ninjabionico » sab giu 27, 2009 2:42 pm

Ciao.

Dam ha scritto:In effetti per il modem mi ero gettato nel forum ufficiale di ubuntu, ma purtroppo nessuno è riuscito a trovare una soluzione...siamo giunti alla conclusione che il mio modem usb non era compatibile... [acc2]


Ora i conti tornano... [:D]


Dam ha scritto:Con le partizioni qualcosa ci so fare - il minimo indispensabile, eh! - però per l'uso di Grub invece non molto...disintallato Ubuntu infatti Windows non aveva più la sequenza di boot (detta con termini eretici) e, non ho idea come, in mezz'ora di tentativi sono riuscito a ripristinarlo. Ma mai più, mai più, mai più.
Un amico mi ha detto che però installandolo in un HD esterno la velocità sarebbe estremamente ridotta, vero? Uhmm...


Questo perché Grub cerca i files di configurazione nella partizione di Ubuntu e non trovandoli va in errore, cosa risolvibile in 2 minuti col Super Grub Disk.

Dam ha scritto:
ninjabionico ha scritto:Mi sembra che la chiavetta sia supportata, al massimo utilizzi Ndiswrapper con i driver di Xp


Ehmm...ehhh=? [uhm]


http://it.wikipedia.org/wiki/Ndiswrapper
Il problema di Ndiswrapper sono le sue limitazioni (alcune funzionalità non sono supportate, mi sembra sia incluso il WPA per cui si è costretti ad utilizzare il WEP con un controllo sul MAC e tenere l'esseid nascosto per avere un minimo di sicurezza).

Dam ha scritto:Nel senso che la chiave wpa cambiava da sola...e penso potesse essere questo la causa del problema di connessione...penso [rolleyes]


Forse non hai specificato correttamente se la password era una stringa alfanumerica o un numero esadecimale (un classico, le due cose sono profondamente differenti nell'interpretazione fatta dal sistema) oppure qualche problema con la gestione delle password da parte di Yast2 il che mi sembra alquanto improbabile (ma pur sempre possibile) un così grossolano errore di programmazione.

Dam ha scritto:Tra l'altro, un mio amico mi ha fatto vedere il suo Kubuntu..e cavolo, devo dire che mi è piaciuto parecchio! ^^ E se mi dessi a questa distro? [std]


Kubuntu è una Ubuntu l'ambiente grafico KDE al posto di GNOME (volendo da Ubuntu installando il pacchetto kubuntu-desktop si ottiene un'installazione in cui è possibile usare il sistema sia come Ubuntu che Kubuntu con il pregio di avere tutti i programmi disponibili in entrambi gli ambienti), l'hardware supportato è il medesimo.

Dam ha scritto:Ciao, e grazie mille [;)]



[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd


Torna a NewBie

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising