Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Script js non funzionante

Il forum per tutti i developer. Leggere attentamente il regolamento di sezione prima di postare.

Script js non funzionante

Messaggioda ssjx » ven mar 16, 2007 8:37 pm

Ragazzi sto cominciando ad incacchiarmi... mi stavo dedicando un attimo al widget di MLI ma sto avendo diversi problemi nella personalizzazione e soprattutto nello script che dovrebbe gestire il passaggio dalla schermata principale al retro

mi dite dove cavolo è l'errore?

In teoria dovrebbe funzionare eppure quando lo carico il terminale degli errori di Opera mi dice che c'è un errore alla riga 32 (mentre il file finisce alla 31) ed in effetti poi non vuole saperne di funzionare

Spero che programmatori riusciate a dirmi dove cavolo sbaglio


Codice: Seleziona tutto
// Execute the script on load
window.addEventListener('load',function(ev){
 
  // add behavior to the flip button on the front side
  document.getElementById('flipfront').addEventListener('click',function(ev){
    flipWidget("back");
  }, false);

  // add behavior to the flip button on the front side
  document.getElementById('flipback').addEventListener('click',function(ev){
    flipWidget("front");
  }, false);



// Perform the flipping of the widget
function flipWidget(to){
  switch (to) {
    case "back":
      document.getElementById('front').style.display = "none";
      document.getElementById('back').style.display = "block";
      break;
    case "front":
      document.getElementById('back').style.display = "none";
      document.getElementById('front').style.display = "block";
      break;
    default:
      // do nothing
      break;
  }
}
Usavo IE e mi lamentavo... usavo Mozilla e mi lamentavo, decisamente meno ma mi lamentavo, ... poi ho trovato Opera e fu amore a prima vista
Avatar utente
ssjx
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5756
Iscritto il: ven nov 26, 2004 3:37 pm
Località: Barcellona

Messaggioda ssjx » sab mar 17, 2007 1:39 am

OK risolto da solo [:)]
Usavo IE e mi lamentavo... usavo Mozilla e mi lamentavo, decisamente meno ma mi lamentavo, ... poi ho trovato Opera e fu amore a prima vista
Avatar utente
ssjx
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5756
Iscritto il: ven nov 26, 2004 3:37 pm
Località: Barcellona


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising