Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Problema compilazione kernel

Il forum riservato agli amici del Pinguino e al software libero.

Problema compilazione kernel

Messaggioda Thx » dom set 12, 2004 11:32 pm

Stavo creando l'immagine per il kernel 2.6.8.1 per la mia slack quando è successo questo

drivers/block/elevator.c:393:28: warning: null character(s) ignored
drivers/block/elevator.c:393: error: parse error before "t"
drivers/block/elevator.c:393: warning: type defaults to `int' in declaration of `t'
drivers/block/elevator.c:393: error: invalid initializer
drivers/block/elevator.c:393: warning: data definition has no type or storage class
drivers/block/elevator.c:393: error: parse error before "t"
drivers/block/elevator.c:393: warning: type defaults to `int' in declaration of `t'
drivers/block/elevator.c:393: error: conflicting types for `t'
drivers/block/elevator.c:393: error: previous declaration of `t'
drivers/block/elevator.c:393: error: `elv_add_reque' undeclared here (not in a function)
drivers/block/elevator.c:393: error: initializer element is not constant
drivers/block/elevator.c:393: error: (near initialization for `t')
drivers/block/elevator.c:393: error: parse error before "t"
drivers/block/elevator.c:393: error: `__kstrtab_elv_add_reque' undeclared here (not in a function)
drivers/block/elevator.c:393: warning: excess elements in scalar initializer
drivers/block/elevator.c:393: warning: (near initialization for `t')
drivers/block/elevator.c:393: warning: data definition has no type or storage class
CC sound/core/seq/seq_timer.o
drivers/block/elevator.c:393: error: t causes a section type conflict
make[2]: *** [drivers/block/elevator.o] Error 1
make[1]: *** [drivers/block] Error 2
make: *** [drivers] Error 2
make: *** Waiting for unfinished jobs....
CC sound/core/seq/seq_syöööööö

Da che dipende?
Avatar utente
Thx
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: sab set 11, 2004 9:50 am

Messaggioda thomas » lun set 13, 2004 6:33 am

dalla riga 393 del file /usr/src/linux/drivers/block/elevator.c
Fa un po' vedere cosa c'è scritto
Avatar utente
thomas
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 6858
Iscritto il: mer lug 09, 2003 6:30 pm
Località: Parma

Messaggioda Thx » lun set 13, 2004 9:06 am

Quindi Thomas?
Avatar utente
Thx
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: sab set 11, 2004 9:50 am


Messaggioda thomas » lun set 13, 2004 10:20 am

Quindi che?

Fammi vedere un po' cosa c'è scritto in quel file attorno a quella riga (3 righe precedenti, rica 393 e 3 righe successive)
Avatar utente
thomas
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 6858
Iscritto il: mer lug 09, 2003 6:30 pm
Località: Parma

Messaggioda Thx » lun set 13, 2004 11:00 am

A ok Thomas!Grazie mille!Tento di ricompilarlo e appena mi ridà l'errore te lo posto subito!Grazie ancora!
Avatar utente
Thx
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: sab set 11, 2004 9:50 am

Messaggioda thomas » lun set 13, 2004 1:54 pm

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">citazione:<hr height="1" noshade id="quote"><i>Messaggio inserito da Thx</i>
<br />A ok Thomas!Grazie mille!Tento di ricompilarlo e appena mi ridà l'errore te lo posto subito!Grazie ancora!
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

No, non hai capito: cerca il file elevator.c e copia le 7 righe che ti ho chiesto...
Avatar utente
thomas
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 6858
Iscritto il: mer lug 09, 2003 6:30 pm
Località: Parma

Messaggioda Thx » mar set 14, 2004 10:41 am

Ciao Thomas,questa mattina ho compilato il kernel 2.6.8 scaricato da kernel.org per la slack 10.0. Ho caricato tuii i moduli uhci e ohci solamente che quando riavvio con il nuovo kernel e lancio il comando eci-doctor.sh per vedere tutti i requisiti mi dà questo messaggio di errore:

- Module usb_uhci not found
- Module uhci not found
- Module usb_ohci not found

No usb controller

Da che può dipendere? L'altro errore non me l'ha più dato!
Avatar utente
Thx
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: sab set 11, 2004 9:50 am


Torna a Distribuzioni, Kernel e Software Applicativo

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

cron
Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising