Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Driver nVidia su Kubuntu

Il forum riservato agli amici del Pinguino e al software libero.

Driver nVidia su Kubuntu

Messaggioda Ale2695 » mar ago 02, 2011 10:03 am

Non riesco ad abilitare i driver nVidia sul mio Kubuntu 11.04. Quando vado a vedere nel programma per l'installazione dei driver aggiuntivi, mi esce fuori che i driver nVidia sono installati ma non utilizzati:
Immagine
Come posso risolvere? [grazie]
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda farbix89 » mar ago 02, 2011 10:21 am

Hai per caso fatto modifiche strane al file xorg.conf?

Kubuntu è molto sensibile a riguardo e uno smanettamento di troppo porta a far saltare l'accelerazione hardware.

A questo si aggiunge un non perfetto meccanismo di arresto del sistema dovuto alle policy-KDE (gli ho bombardati di segnalazioni e mi hanno dato retta con gli ultimi aggiornamenti) che spesso impallano tutto in chiusura e al successivo avvio portano via l'accelerazione 3D.

Ci sono 2 rimedi da applicare per risolvere (si spera definitivamente) il problema:

- Cancella ogni eventuale file xorg.conf creato o presente nella cartella /etc/X11/ presente in Radice,disinstalla i driver,riavvii e reinstalli tutto.

- KDE è programmato di default per salvare l'ultima sessione utilizzata,quindi se nell'ultima sessione ci sono stati problemi con alcuni componenti (tipo policy o moduli che saltano all'improvviso) questi problemi vengono salvati nella sessione e te li porti dietro ad ogni avvio di Kubuntu.

Si risolve facilmente aprendo una sessione vuota ad ogni avvio di KDE

Immagine


Lo raggiungi da Avvio e Spegnimento,Gestione di sessione.

In questo modo se qualcosa crasha a livello di librerie o di moduli,al prossimo avvio partiranno senza problemi.

La modifica non incide sulle personalizzazioni dell'interfaccia o su i programmi settati in autoavvio [:)]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mar ago 02, 2011 10:24 am

Farb, Kubuntu l'ho installato ieri, ed è da quando l'ho avviato per la prima volta che i driver nVidia non vanno. Il file xorg.conf neppure l'ho toccato.
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara


Re: Driver nVidia su Kubuntu

Messaggioda farbix89 » mar ago 02, 2011 10:26 am

[uhm]

Qualche arresto anomalo di KDE?Qualche libreria che salta?

Il driver deve andare...prova a disinstallarlo,riavvii (dopo aver applicato le modifiche di sessione consigliate sopra) reinstalli e fai un ultimo riavvio.
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mar ago 02, 2011 1:52 pm

Non ha funzionato, allora ho provato ad installare singolarmente i driver da KPackageKit, li ho abilitati, ma niente. Ora la schermata che esce è questa:
Immagine
Faccio notare i caratteri totalmente sfalsati... [B)]
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda skizzzzo » mer ago 03, 2011 11:35 am

A me sia con Ubuntu che con Kubuntu, subito dopo averlo installato e quindi senza avere toccato nient'altro e subito dopo avere installato i driver nVidia e riavviato il Pc, dice sempre la stessa identica cosa che dice a te e cioè che è attivato ma non attualmente in uso, però gli effetti funzionano quindi secondo me è solo un bug. [ciao]
Avatar utente
skizzzzo
Silver Member
Silver Member
 
Messaggi: 1666
Iscritto il: lun nov 23, 2009 9:39 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mer ago 03, 2011 11:37 am

Può anche darsi eh... se non che prima dell'installazione dei driver da KPackageKit, la frequenza di aggiornamento dello schermo era impostata su 50 Hz, contro i normali 60 Hz...
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda skizzzzo » mer ago 03, 2011 11:41 am

Nel forum dell'istituto Maiorana ho trovato questo, io l'ho fatto e le rotelline girano però sono nella tua stessa situazione.

scrivi o copia nel terminale
glxgears
se ti appare una finestrina con delle rotelle che girano hai l'accelerazione 3D attiva, quindi sei a posto,
se il comando non viene preso , bisogna installare prima i mesa-utils, ma dovresti averlo, con il comando
sudo apt-get install mesa-utils
Avatar utente
skizzzzo
Silver Member
Silver Member
 
Messaggi: 1666
Iscritto il: lun nov 23, 2009 9:39 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mer ago 03, 2011 11:45 am

Girano pure a me... allora è molto probabilmente un bug. Beh, dai, a differenza delle rotelline, i miei co.....ni hanno smesso di girare [:D]
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda skizzzzo » mer ago 03, 2011 11:53 am

Ho dato questo comando che ho trovato in un altro forum:
sudo nvidia-xconfig
e poi ho riavviato e al riavvio i caratteri totalmente sfalsati sono tornati a posto però non ho idea di che cosa abbia fatto quindi per questo magari aspettiamo un esperto. [ciao]
Avatar utente
skizzzzo
Silver Member
Silver Member
 
Messaggi: 1666
Iscritto il: lun nov 23, 2009 9:39 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mer ago 03, 2011 3:52 pm

Ho aggiornato da poco KDE alla versione 4.7, e subito al riavvio KWin è crashato lamentando un bug nel driver video. Guardando nelle impostazioni, ho provato a cambiare la tipologia di composizione degli effetti da OpenGL a XRender, ed ora gli effetti funzionano senza crash. Sembra che il bug riguardi quindi l'identificazione OpenGL... [uhm]
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda skizzzzo » mer ago 03, 2011 4:49 pm

guarda Ale io in merito ai tuoi problemi purtroppo non sono abbastanza competente, ti dico però che secondo me forse hai fatto un po di casino, io per aggiornare i driver video all'ultima versione ho semplicemente aggiunto i repository e anche con KDE 4.7 funziona tutto. [boh] [ciao]
Avatar utente
skizzzzo
Silver Member
Silver Member
 
Messaggi: 1666
Iscritto il: lun nov 23, 2009 9:39 pm

Re: Driver nVidia su Kubuntu

Messaggioda farbix89 » mer ago 03, 2011 5:04 pm

Ale2695 ha scritto:Ho aggiornato da poco KDE alla versione 4.7, e subito al riavvio KWin è crashato lamentando un bug nel driver video. Guardando nelle impostazioni, ho provato a cambiare la tipologia di composizione degli effetti da OpenGL a XRender, ed ora gli effetti funzionano senza crash. Sembra che il bug riguardi quindi l'identificazione OpenGL..


Che non funzioni OpenGL è un chiarissimo sintomo di problemi con i Driver video (Xrender fa il rendering degli effetti via Xorg...il primo video a schermo intero e crasha tutto)

Certo un bel promemino [uhm]

Una bellissima disinstallazione TOTALE di qualsiasi cosa chiamata nvidia nel gestore pacchetti,unita all'installazione manuale dei driver nvidia dal sito ufficiale è consigliata come ultima spiaggia [:)]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mer ago 03, 2011 6:07 pm

Ok, quando provo ad avviare la compilazione del driver (naturalmente fuori dalla sessione di Xorg), mi dice di disattivare il driver di default di Linux Noveau. Come faccio?
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda farbix89 » mer ago 03, 2011 6:10 pm

Lo rimuovi sempre da shell [:)]

Codice: Seleziona tutto
sudo apt-get --purge remove xserver-xorg-video-nouveau


poi vai di installazione [8D]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » mer ago 03, 2011 6:20 pm

Stesso errore.
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » gio ago 04, 2011 10:47 am

Cosa posso fare? Farb?
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda farbix89 » gio ago 04, 2011 11:23 am

Non vorrei che ormai sia corrotto tutto l'OS [acc2]

Prima di fare ulteriori test:

- non avevi avuto altri problemi simili con distro Ubuntu?

- modello scheda grafica?


Penso che dovremo provare la procedura completamente manuale....oppure formattare [V]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: Driver nVidia su Kubuntu

Messaggioda Ale2695 » gio ago 04, 2011 11:34 am

Allora:
- Con Ubuntu (tutte le versioni fin dalla 9.10) i driver se provo ad installarli dal programma "Driver aggiuntivi" non riesce a completare l'installazione, ma se li installo dal Gestore Pacchetti e li abilito poi da Driver Aggiuntivi funzionano
- La scheda grafica è una nVidia GeForce 9500GT
http://www.chimerarevo.com/
Avatar utente
Ale2695
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5927
Iscritto il: dom gen 18, 2009 10:39 am
Località: Novara

Re: Driver nVidia su Kubuntu

Messaggioda farbix89 » gio ago 04, 2011 11:39 am

Posso dirlo: sei leggermente sfortunato Ale [V]

https://bugs.launchpad.net/ubuntu/+sour ... bug/763808

Un bug insidioso: riesci a caricare il driver una volta su 100 (questo spiega perché a volte lo carica su ubuntu)

[...]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Prossimo

Torna a Distribuzioni, Kernel e Software Applicativo

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising