Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

problemi con grub e ubuntu tweak

Per chi muove i primi passi nel mondo del pinguino

problemi con grub e ubuntu tweak

Messaggioda mary26 » sab lug 02, 2011 9:44 am

Iniziamo con questi due intanto: ho installato sul mio netbook ( originariamente Windows xp) ubuntu 10.10 versione netbook; a parte che non capisco come mai la grafica è identica a quella della versione 11.04 bo.
Il Grub fa il conto alla rovescia e se non seleziono nulla non parte nessun sistema operativo nemmeno il primo della lista che è linux e quando seleziono il sistema e do invio il sistema sembra che parta poi mi riporta alla maschera iniziale di grub e devo ripetre l'operazione a volte anche 3/4 volte sia se selezione linux sia xp; la versione è 1.98+20100804-5 ubuntu 3.3.
Volevo installare ubuntu tweak dopo averlo scaricato, ma ubuntu configuration tool mi dice: la dipendenza non può essere soddisfatta: python(>=2.7)...em dunque sarei in difficoltà, un aiutino per favore
Spero di essere stata chiara e di aver scritto giusto.
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » sab lug 02, 2011 10:06 am

mary26 ha scritto:Iniziamo con questi due intanto: ho installato sul mio netbook ( originariamente Windows xp) ubuntu 10.10 versione netbook; a parte che non capisco come mai la grafica è identica a quella della versione 11.04 bo


Entrambi utilizzano Unity come Ambiente desktop,solo che nella 11.04 è leggermente più moderna.


Il Grub fa il conto alla rovescia e se non seleziono nulla non parte nessun sistema operativo nemmeno il primo della lista che è linux e quando seleziono il sistema e do invio il sistema sembra che parta poi mi riporta alla maschera iniziale di grub e devo ripetre l'operazione a volte anche 3/4 volte sia se selezione linux sia xp; la versione è 1.98+20100804-5 ubuntu 3.3.


Forse c'è un problema nel file di configurazione.

Prova lanciando da terminale:

Codice: Seleziona tutto
sudo update-grub


Rigenera il file grub.cfg e forse risolve il problema.

Se ancora persiste puoi provare a modificare la voce d'avvio con questo programmino grafico

http://wiki.ubuntu-it.org/Amministrazio ... tUpManager


Vedi se risolvi...altrimenti passiamo alle maniere forti [:D]

Volevo installare ubuntu tweak dopo averlo scaricato, ma ubuntu configuration tool mi dice: la dipendenza non può essere soddisfatta: python(>=2.7)...em dunque sarei in difficoltà, un aiutino per favore


Devo verificare questa cosa,mi sembra strano che Ubuntu 10.10 non aggiorni le librerie python [uhm]

Hai aggiornato il sistema?
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » sab lug 02, 2011 3:26 pm

Grub fa ancora il matto nel senso che adesso al termine del conto alla rovescia parte il sistema operativo selezionato ma mi fa fare questo passaggio 2 volte sia per avviare linux sia xp, però è una fatica sopportabile.
Ubuntu tweak non ne vuol sapere di installarsi eppure il sistema è aggiornato : finestra applicazioni sulla sinistra -gestore aggiornamenti:" non ci sono aggiornamenti da installare" [cry]
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm


Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » sab lug 02, 2011 3:39 pm

mary26 ha scritto:Grub fa ancora il matto nel senso che adesso al termine del conto alla rovescia parte il sistema operativo selezionato ma mi fa fare questo passaggio 2 volte sia per avviare linux sia xp, però è una fatica sopportabile.


Due volte lo stesso passaggio [uhm]

Hai mica installato altri OS Windows?

Forse c'è un problema anche con il boot manager di Windows.

Appare questa finestra per caso?

Ubuntu tweak non ne vuol sapere di installarsi eppure il sistema è aggiornato : finestra applicazioni sulla sinistra -gestore aggiornamenti:" non ci sono aggiornamenti da installare" [cry]


Posta il risultato del comando

Codice: Seleziona tutto
sudo apt-get install -f
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » sab lug 02, 2011 4:04 pm

Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

ho windows xp e quando lo avvio mi esce una schermata nera simile a quella anzi 2 con scritto di confermare l'avvio di windows xp ...non so altro il netbook era di "ex amico"..... e sinceramente non so cosa abbia combinato.
Tra l'altro esce sempre il suo nome e mi piacerebbe tantissimo toglierlo dai piedi e metterci il mio ma questo è un altro discorso.
Ciao e grazie.
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » sab lug 02, 2011 4:17 pm

mary26 ha scritto:Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.


Per Ubuntu tweak ci pensiamo dopo,ora concentriamoci sul boot [;)]

ho windows xp e quando lo avvio mi esce una schermata nera simile a quella anzi 2 con scritto di confermare l'avvio di windows xp ...non so altro il netbook era di "ex amico"..... e sinceramente non so cosa abbia combinato



Puoi provare reinstallando grub2

Da terminale:

Codice: Seleziona tutto
sudo grub-install /dev/sda


Seguito da

Codice: Seleziona tutto
sudo update-grub2


Dovresti fare piazza pulita e avere solo GRUB all'avvio.

Prima di agire però,tutelati creando un CD di ripristino bootloader come Rescatux.

http://www.supergrubdisk.org/2011/06/25 ... -released/

Non si sa mai [;)]

In caso contrario se Windows mostra ancora il suo bootmanager,bisognerà agire da Windows con easyBCD.

http://www.MegaLab.it/2687/2/modificare ... -windows-7

Tra l'altro esce sempre il suo nome e mi piacerebbe tantissimo toglierlo dai piedi e metterci il mio ma questo è un altro discorso.
Ciao e grazie.


Puoi cancellare un vecchio account utente e crearne un'altro

Gestione account Windows XP
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » sab lug 02, 2011 4:46 pm

Tu sei troppo bravo e gentile, ma io sono troppo imbranata [cry] , ho dato i comandi da terminale che mi hai detto ma non è cambiato nulla ..uffa sono stanca e adesso devo dedicarmi ad altro.
Ciao grazie per la pazienza e scusa riproverò in un altro momento.
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » sab lug 02, 2011 8:01 pm

Sono riuscita ad installare ubuntu tweak [applauso+] ho seguito questa guida evviva..
Ora rimane di sistemare il grub che non ne vuole prorpio sapere....
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » dom lug 03, 2011 8:42 am

Ottimo per Ubuntu tweak [^]

Tornando al GRUB:

Problemi come il tuo sono stati risolti brillantemente lanciando il comando che ti ho citato

Codice: Seleziona tutto
sudo grub-install /dev/sda


Prova e posta il risultato del terminale.

In caso di ulteriori problemi,postami il risultato del comando

Codice: Seleziona tutto
sudo fdisk -l
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » lun lug 04, 2011 3:28 pm

Installation finished. No error reported.

Disco /dev/sda: 250.1 GB, 250059350016 byte
255 testine, 63 settori/tracce, 30401 cilindri
Unità = cilindri di 16065 * 512 = 8225280 byte
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Identificativo disco: 0x4c495296

Dispositivo Boot Start End Blocks Id System
/dev/sda1 * 1 24329 195419550 7 HPFS/NTFS
/dev/sda2 24329 30402 48778241 5 Esteso
/dev/sda5 24329 30147 46735360 83 Linux
/dev/sda6 30148 30402 2041856 82 Linux swap / Solaris

Non so se ho dato i comandi giusti : il secondo è -1 oppure -l (elle)?
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » lun lug 04, 2011 4:02 pm

mary26 ha scritto:
Non so se ho dato i comandi giusti : il secondo è -1 oppure -l (elle)?


elle...digitato bene comunque [^]

Lato Ubuntu hai provato tutto,ora non resta che avviare Windows e modificare qualcosa da lì.

Un articolo utile

http://www.MegaLab.it/2687/2/modificare ... -windows-7

Prima di fare qualsiasi cosa con questo programma (si rischia di impallare tutto),posta uno screenshot del menù Add/remove entries
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » lun lug 04, 2011 9:16 pm

Scusami Farbix ma mi sembra che non sia cambiato nulla, grub fa 2 volte la procedura per avviare il sistema operativo e riporta la stessa versione che avevo detto all'inizio.
Ho letto l'articolo ho installato il software su windows ma quando lo avvio mi esce un messaggio di errore....non so [boh]
Ciao buona serata.
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » mar lug 05, 2011 9:25 am

Ora dobbiamo ricapitolare,perché mi sono perso:

Escono due finestre di GRUB (quindi due finestre simili) o esce una finestra di GRUB e una del Windows Bootloader (quindi una così e dopo una così)?

Forse ho il sospetto che ci siano due GRUB installati rispettivamente nel MBR e nella partizione di Ubuntu (in sda2 o sda3,suppongo)

oppure ci sia il bootmanager di Windows in permanenza nel MBR(strano...non partirebbe Ubuntu) o nella specifica partizione (forse un esperimento mal riuscito di installazione con Wubi?)

In ogni caso,non mollo...risolveremo la questione [;)]
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » mar lug 05, 2011 1:34 pm

Vediamo se riesco a spiegarmi: esce una finestra di grub come la prima, poi sia che scelga linux sia windows xp il sistema sta per partire poi si ferma ritorna la schermata principale di Samsung grigia ( F2 set up F4 qualcos'altro) e poi riecco la finestra di grub uguale a prima.
Riseleziono il sistema operativo e se selezione linux parte, se selziono windows xp escono due schermate nere tipo quelle da te mostrate che mi chiedono la conferma e finalmente windows xp si avvia.
Se il problema non lo risolviamo, pazienza, invece di fare un passaggio ne farò due, non muore nessuno, sei stato gentilissimo lo stesso.
Mi piacerebbe invece cambiare il nome su Ubuntu che purtroppo , anche quando apro il terminale, compare ancora quello di "lui" [:p]
Grazie , ciao.
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda farbix89 » mar lug 05, 2011 2:32 pm

mary26 ha scritto:Vediamo se riesco a spiegarmi: esce una finestra di grub come la prima, poi sia che scelga linux sia windows xp il sistema sta per partire poi si ferma ritorna la schermata principale di Samsung grigia ( F2 set up F4 qualcos'altro) e poi riecco la finestra di grub uguale a prima.


Sembrerebbe un riavvio forzato [uhm]


Riseleziono il sistema operativo e se selezione linux parte, se selziono windows xp escono due schermate nere tipo quelle da te mostrate che mi chiedono la conferma e finalmente windows xp si avvia.


Non vorrei allertarti ma è possibile a questo punto che ci sia un problema nel settore d'avvio del PC,forse un malware o dell'altro preso sotto Windows.

Faccio qualche ricerca e poi vediamo come agire.

Se il problema non lo risolviamo, pazienza, invece di fare un passaggio ne farò due, non muore nessuno, sei stato gentilissimo lo stesso.


Scoprire la causa di ciò può servire,in caso qualcun'altro incappi nello stesso problema.

Ovviamente se vuoi lasciar perdere [brindisi]

Mi piacerebbe invece cambiare il nome su Ubuntu che purtroppo , anche quando apro il terminale, compare ancora quello di "lui" [:p]
Grazie , ciao.


Hai provato a cambiar nome aprendo il menù Utenti e gruppi?Lo trovi in Sistema->Amministrazione (o cercando utenti e gruppi nella barra)
Avatar utente
farbix89
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 14093
Iscritto il: ven feb 13, 2009 10:09 pm

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » mar lug 05, 2011 3:46 pm

Ho combinato un pasticcio..non chiedermi cosa ho fatto perché non lo so.
Nel creare un nuovo utente , cioè io, e nell'eliminare il suo, ho sbagliato qualche passaggio, di fatto ora non riesco più ad accedere in alcun modo.
Ciao linux, farò formattare a qualcuno che lo sa fare e magari me lo farò reinstallare.
Scusami per il tempo che ti ho fatto perdere e grazie per l'impegno e la pazienza. [cry] [cry]
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda Sabbb » mar lug 05, 2011 3:55 pm

Se hai seguito le istruzioni di farbix89 ,e ti hai masterizzato Rescatux non devi reinstallare niente. Lo si può "resuscitare" [;)]
Avatar utente
Sabbb
Utente inattivo
 
Messaggi: 4483
Iscritto il: sab set 04, 2010 11:19 am

Re: problemi con grub e ubuntu tweak

Messaggioda mary26 » mar lug 05, 2011 6:21 pm

Che paura che ho preso Sabbb [ehm] pensavo di aver perso linux, invece sono rientrata più tardi come se non fosse successo nulla cancellato, sparito il pasticcio che avevo fatto....strano questo elettrodomestico. [boh]
Ciao,a presto.
Grazie Zane..
Eugenio sono solidale con te.
Avatar utente
mary26
Utente inattivo
 
Messaggi: 276
Iscritto il: ven lug 01, 2011 2:00 pm

Re: problemi con grub e ubuntu tweak

Messaggioda Sabbb » mar lug 05, 2011 6:28 pm

mary26 ha scritto: ...strano questo elettrodomestico. [boh]
[:D]
Avatar utente
Sabbb
Utente inattivo
 
Messaggi: 4483
Iscritto il: sab set 04, 2010 11:19 am


Torna a NewBie

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising