Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

[Help][STORAGE]drivers sata per xp già installato.........

Devi acquistare un nuovo PC e devi scegliere la configurazione che più si adatta alle tue esigenze? Vuoi spremere il tuo Hardware fino all'estremo? Ti affascina il modo del Modding e del Tuning? Questo è il posto adatto per porre le tue domande!

[Help][STORAGE]drivers sata per xp già installato.........

Messaggioda mattpillon » mar dic 07, 2010 8:36 pm

dopo un bel po di tempo ho scoperto che nel bios del mio pc desktop il sata era impostato in modalità "ide" e non "ahci".
sul pc sono installati windows 7 ed xp in dual boot.
modificando l'impostazione del bios su "ahci", entrambi i sistemi non partono, perché installati in modalità ide.
per windows 7 ho risolto facilmente con una modifica del registro di sistema, che ha consentito l'istallazione automatica del driver sata al riavvio successivo.
per xp però non riesco a trovare un modo di caricare il driver per disco sata a sistema operativo già installato.
qualcuno conosce un modo per risolvere senza dover reinstallare xp?
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: drivers sata per xp già installato.........

Messaggioda Vincent Vega » mar dic 07, 2010 8:55 pm

Un minuto, ti ritrovo il Post con i miei moccoli [:D] ...
# Se non potete parlare bene di una persona, non parlatene.
Avatar utente
Vincent Vega
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2287
Iscritto il: mer nov 11, 2009 2:56 pm
Località: San GHz

Re: drivers sata per xp già installato.........

Messaggioda Vincent Vega » mar dic 07, 2010 9:16 pm

Va boh, non lo trovo, comunque, se ben ricordo, devi accedere a WinXP SP3 in modalità IDE, scaricare i Driver del tuo Controller SATA, andare in Gestione periferiche e forzare l'installazione dei Driver con la procedura manuale d'aggiornamento degli stessi. Lo fai per ogni Drive rilevato e collegato al Controller per poi trovarti una BSoD quando capiti sul Drive di Sistema che ti consiglio di lasciare per ultimo nell'ordine per l'Upgrade al nuovo Driver. Riavvii e entri nel Bios impostando la modalità AHCI e dovresti riuscire ad accedere al sistema operativo.

Ah, ecco il Thread:

viewtopic.php?p=498318

Santo sia fatto Google, con gli strumenti di ricerca di qualsiasi piattaforma mi ci son sempre trovato male Argh...
# Se non potete parlare bene di una persona, non parlatene.
Avatar utente
Vincent Vega
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2287
Iscritto il: mer nov 11, 2009 2:56 pm
Località: San GHz


Re: drivers sata per xp già installato.........

Messaggioda mattpillon » mar dic 07, 2010 10:16 pm

grazie vincent, provo e ti faccio sapere [ciao]
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: drivers sata per xp già installato.........

Messaggioda andy » mar dic 07, 2010 10:45 pm

mattpillon ha scritto:dopo un bel po di tempo ho scoperto che nel bios del mio pc desktop il sata era impostato in modalità "ide" e non "ahci".

Lo è anche nel mio!!
Quindi avendo Xp esso non sfrutta la velocità del sata ma lo sfrutta come ide?
Con MegaLab non si finisce mai di imparare!!
Avatar utente
andy
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1955
Iscritto il: mer mar 30, 2005 9:27 pm
Località: Rimini

Re: drivers sata per xp già installato.........

Messaggioda mattpillon » mar dic 07, 2010 11:15 pm

andy ha scritto:Quindi avendo Xp esso non sfrutta la velocità del sata ma lo sfrutta come ide?

direi di si, non sfrutti a pieno la velocità del disco.

io ho appena risolto, leggendo il topic postato da vincent, ho installato l'intel matrix storage manager, e poi aggiornato i drivers del controller con quelli ahci del mio chipset, ho riavviato, modificato nel bios in ahci, e xp è partito regolarmente, ha installato il nuovo hardware sata, disco fisso e lettore dvd, e chiesto per un riavvio. piu facile del previsto......
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: drivers sata per xp già installato.........

Messaggioda Vincent Vega » mer dic 08, 2010 12:25 am

La velocità di trasferimento, da quanto mi risulta da alcune prove fatte con HDTune, è lievemente superiore, nell'ordine del 1% in più rispetto alla modalità IDE; la differenza principale è da ritrovarsi nella possibilità di utilizzare l'NCQ per i dischi che lo supportano. E' una Feature fondamentale per chi sfrutta intensamente gli Hdds. Inoltre, in modalità AHCI è possibile montare un numero superiore di periferiche di memorizzazione rispetto a quanto concesso dalla IDE Mode che, se ben ricordo, non dovrebbe consentire di far funzionare più di 4 unità quali Hdds e Drive Ottici.
# Se non potete parlare bene di una persona, non parlatene.
Avatar utente
Vincent Vega
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2287
Iscritto il: mer nov 11, 2009 2:56 pm
Località: San GHz

Re: drivers sata per xp già installato.........

Messaggioda mattpillon » mer dic 08, 2010 9:06 am

a me, cosi ad occhio, sembra che ci sia un discreto aumento di velocità, specie nel navigare le directory del disco.
l'ncq, da quanto ho letto in quella pagina di wikipedia, è attivo quando si è in modalità ahci, se il disco fisso lo supporta.
oppure bisogna fare qualcos'altro?
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda Vincent Vega » mer dic 08, 2010 1:57 pm

Con l'abilitazione dell'AHCI si avvia anche il supporto all'NCQ.
# Se non potete parlare bene di una persona, non parlatene.
Avatar utente
Vincent Vega
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2287
Iscritto il: mer nov 11, 2009 2:56 pm
Località: San GHz

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda cippico » ven dic 10, 2010 11:43 pm

anche io avevo sbattuto non poco la testa tentando su installazione xp pro sp3 su disco SATA ma in modalita' IDE su bios...
le ho provate tutte ma in nessun modo xp e' riuscito a partire con bios impostato su ahci...

alla fine ho desistito...comunque i miglioramenti da quanto ho letto sono impercettibili...

ciaooo a tutti
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1282
Iscritto il: sab gen 25, 2003 1:57 am

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda Vincent Vega » sab dic 11, 2010 12:55 am

Io ho risolto con la procedura riportata sopra, per il Raid è fondamentale [std].
# Se non potete parlare bene di una persona, non parlatene.
Avatar utente
Vincent Vega
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2287
Iscritto il: mer nov 11, 2009 2:56 pm
Località: San GHz

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda mattpillon » sab dic 11, 2010 8:12 am

cippico ha scritto:anche io avevo sbattuto non poco la testa tentando su installazione xp pro sp3 su disco SATA ma in modalita' IDE su bios...
le ho provate tutte ma in nessun modo xp e' riuscito a partire con bios impostato su ahci...

alla fine ho desistito...comunque i miglioramenti da quanto ho letto sono impercettibili...

ciaooo a tutti


la procedura sopra descritta funziona, riguardo ai miglioramenti, su un pc attuale che usa xp in effetti non sono molti, ma per chi come me ha un dual boot con windows 7, conviene provare, perché sul secondo sistema hai un aumento delle prestazioni. [ciao]
...................
Avatar utente
mattpillon
MLI Expert
MLI Expert
 
Messaggi: 2362
Iscritto il: gio gen 21, 2010 4:09 pm
Località: marche

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda cippico » dom dic 12, 2010 1:05 pm

anche io ho w7 in dual boot...anzi...trial boot... [rolleyes]

pero' ho anche 2 xp pro in dual boot...

non posso pero' ogni volta che uso w7 cambiare impostazioni al bios...

x ora lascio cosi'...

ciaooo a tutti
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1282
Iscritto il: sab gen 25, 2003 1:57 am

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda Vincent Vega » dom dic 12, 2010 2:01 pm

cippico ha scritto:non posso pero' ogni volta che uso w7 cambiare impostazioni al bios...

Basta installare i Driver SATA della tua Mobo nei due XP e il gioco è fatto [;)] .
# Se non potete parlare bene di una persona, non parlatene.
Avatar utente
Vincent Vega
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 2287
Iscritto il: mer nov 11, 2009 2:56 pm
Località: San GHz

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda cippico » lun dic 13, 2010 6:55 pm

gia' provato...

praticamente uno dei 2 xp e' installato su un disco sata e uno su disco pata

installando i driver sul pata dopo riavvio e' stato riconosciuto il nuovo hardware...ed e' apparso il disco sata nelle periferiche...prima non appariva...

mentre sul disco sata dopo aver installato i driver alcuni dischi venivano visti come fossero stati in raid...
e comunque settando il bios in ahci il s.o. non partiva in nessun modo...

ho fatto un sacco di prove...niente da fare...

ciaooo a tutti
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1282
Iscritto il: sab gen 25, 2003 1:57 am

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda andy » mer feb 02, 2011 7:37 pm

Quando avrò tempo voglio provarci.
Nel frattempo vorrei sapere se ho trovato i driver giusti.

La mia MB è questa:
http://it.msi.com/index.php?func=prodde ... rod_no=173

I driver scovati sono:
http://driveragent.com/via/via_driver?o ... controller

http://www.bravofiles.com/driver-AMD-SA ... oller.html

http://www.bravofiles.com/driver-AMD-SA ... de_29.html

Quale dite possa andare bene?
Con MegaLab non si finisce mai di imparare!!
Avatar utente
andy
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1955
Iscritto il: mer mar 30, 2005 9:27 pm
Località: Rimini

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda andy » sab feb 05, 2011 7:04 pm

UP
Con MegaLab non si finisce mai di imparare!!
Avatar utente
andy
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 1955
Iscritto il: mer mar 30, 2005 9:27 pm
Località: Rimini

Re: [Help][STORAGE]drivers sata per xp già installato.......

Messaggioda TheSloth » sab feb 05, 2011 8:29 pm

il primo link che hai trovato dovrebbe essere quello giusto (riferito infatti al chipset via)
Avatar utente
TheSloth
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3285
Iscritto il: ven set 15, 2006 8:50 pm
Località: Marche


Torna a Hardware, Modding & Overclock

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising