Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

avast! Linux Home Edition: 400vps ed errore.

Il forum riservato agli amici del Pinguino e al software libero.

avast! Linux Home Edition: 400vps ed errore.

Messaggioda markinson » mar mag 04, 2010 10:44 am

Siccome sono in piena guerra (nel senso buono) con Linux [bangbang], ho avuto l'ennesimo problema, stavolta con avast! Linux Home Edition.
Se a qualcuno dovesse tornare utile, considerato che non ho trovato thread qui in MegaLab.it, vi descrivo problema e soluzione.
Ambiente Linux: Ubuntu 9.10 "Karmic Koala".

Problema.
Avevo avast! Linux Home Edition regolarmente installato. Dopo aver eseguito l'update, mi veniva restituito il seguente errore: AVAST, An error occured in avast! engine: Argomento non valido.
Dalle ricerche fatte (QUI), ciò è dovuto al passaggio del vps alla serie 400.

Soluzione (artigianale ma che è stata tale, per me).
    1) Raggiunta la posizione /home/utenteloggato;
    2) premuta la combinazione CTRL+H (per visualizzare i file nascosti; operazione possibile anche da "Visualizza --> Mostra file nascosti");
    3) individuata la cartella .avast e rimosso il file 400.vps contenuto al suo interno;
    4) aperta una shell da terminale (si dice così?);
    5) sudo gedit /etc/init.d/rcS (ATTENZIONE: rcS e non rcs!);
    6) inserita, prima della riga già esistente, la stringa echo 128000000 >/proc/sys/kernel/shmmax;
    7) salvato il file;
    8) con il gestore dei pacchetti, rimossa completamente l'installazione dell'antivirus e riavviata la macchina;
    9) installato nuovamente avast!, fatto l'update e tutto ok.

Spero di non aver lasciato indietro nulla.
Non volevo fare lo spocchioso. Sinceramente, ho approfittato di questo post (e del MegaForum), sia per condividere la soluzione e limare eventuali miei errori, sia perché così da qualche parte mi sono scritto la procedura completa in caso di re-installazione del mio Lilnux. [:D]

Consentitemi di ribadire un mio modesto pensiero: Linux è bello, affascinante, è libero, è la soluzione in tanti casi, ma quando si inchioda da qualche parte, rimpiango il vecchio DOS!
MegaLab.it (MLI) = Gianluigi "Zane" Zanettini - That's all Folks!
Avatar utente
markinson
Bronze Member
Bronze Member
 
Messaggi: 936
Iscritto il: sab mag 01, 2010 9:22 am
Località: Roma

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda The Doctor » mer mag 05, 2010 9:03 am

Consentitemi di ribadire un mio modesto pensiero: Linux è bello, affascinante, è libero, è la soluzione in tanti casi, ma quando si inchioda da qualche parte, rimpiango il vecchio DOS!


Esagerato [:D] Io fossi in te sarei orgoglioso. Hai messo mano nel "cuore" del tuo PC e del tuo Sistema Operativo e di aver risolto il problema. Se fosse successo con altro S.O. probabilmente saresti stato costretto a formattare [fischio]

Bravo! [applauso+]
Ciao Nonno
Avatar utente
The Doctor
MLI Hero
MLI Hero
 
Messaggi: 5553
Iscritto il: mer mar 24, 2010 9:10 am
Località: Fiumicino (Roma)

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda sexirutto » gio mag 06, 2010 11:25 pm

ho 2 curiosità: ma perché un antivirus su linux? cioè non c'è ne bisogno, volendo potevi scarica clam il front virus scanner,o no?
ma è in tempo reale??
They will not force us They will stop degrading us They will not control us We will be victorious...Uprising-Muse
Avatar utente
sexirutto
Bronze Member
Bronze Member
 
Messaggi: 690
Iscritto il: gio nov 05, 2009 2:47 pm
Località: Sardo sono!


Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda The Doctor » ven mag 07, 2010 8:37 am

sexirutto ha scritto:ho 2 curiosità: ma perché un antivirus su linux? cioè non c'è ne bisogno, volendo potevi scarica clam il front virus scanner,o no?
ma è in tempo reale??


I virus non infettano i sistemi GNU/Linux, ma se scarichi un file infetto e poi lo trasferisci su Windows? [:D]
Ciao Nonno
Avatar utente
The Doctor
MLI Hero
MLI Hero
 
Messaggi: 5553
Iscritto il: mer mar 24, 2010 9:10 am
Località: Fiumicino (Roma)

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda sexirutto » sab mag 08, 2010 12:18 am

vabbè è scontato,ma si presume che uno in windows abbia l'antivirus, e chi scarica scarichi da fonti pulite.vabbè la sicurezza non è mai troppa.
They will not force us They will stop degrading us They will not control us We will be victorious...Uprising-Muse
Avatar utente
sexirutto
Bronze Member
Bronze Member
 
Messaggi: 690
Iscritto il: gio nov 05, 2009 2:47 pm
Località: Sardo sono!

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda The Doctor » sab mag 08, 2010 9:29 am

sexirutto ha scritto:vabbè è scontato,ma si presume che uno in windows abbia l'antivirus, e chi scarica scarichi da fonti pulite.vabbè la sicurezza non è mai troppa.


Giusto [^]
Ciao Nonno
Avatar utente
The Doctor
MLI Hero
MLI Hero
 
Messaggi: 5553
Iscritto il: mer mar 24, 2010 9:10 am
Località: Fiumicino (Roma)

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda markinson » sab mag 08, 2010 3:52 pm

Ho due antivirus in ambiente Linux. Quando torno dal lavoro, passo chiavette e hd con questi.
Se ci fosse qualcosa di pericoloso, non potrebbe trasferirsi nel mio sistema operativo (spero!), in quanto provengo da ambiti Windows.
Controllo tutto con i programmi antivirus, poi salto su Windows, dove ho altri antivirus.
Paranoico, eh? [:D]
MegaLab.it (MLI) = Gianluigi "Zane" Zanettini - That's all Folks!
Avatar utente
markinson
Bronze Member
Bronze Member
 
Messaggi: 936
Iscritto il: sab mag 01, 2010 9:22 am
Località: Roma

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda The Doctor » sab mag 08, 2010 4:05 pm

markinson ha scritto:Ho due antivirus in ambiente Linux. Quando torno dal lavoro, passo chiavette e hd con questi.
Se ci fosse qualcosa di pericoloso, non potrebbe trasferirsi nel mio sistema operativo (spero!), in quanto provengo da ambiti Windows.
Controllo tutto con i programmi antivirus, poi salto su Windows, dove ho altri antivirus.
Paranoico, eh? [:D]


Abbastanza [:D] I virus per Windows non possono infettare un sistema GNU/Linux e... beh un sistema GNU/Linux non si può infettare a prescindere [;)]
Ciao Nonno
Avatar utente
The Doctor
MLI Hero
MLI Hero
 
Messaggi: 5553
Iscritto il: mer mar 24, 2010 9:10 am
Località: Fiumicino (Roma)

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda markinson » sab mag 08, 2010 4:37 pm

The Doctor ha scritto:... Abbastanza [:D] I virus per Windows non possono infettare un sistema GNU/Linux e... beh un sistema GNU/Linux non si può infettare a prescindere [;)]

[:D]
Benissimo! [^] Così il mio scopo è raggiunto: prima di arrivare con la penna eventualmente infetta sulla mia macchina Windows, faccio un controllo in un ambiente che, comunque, non può ricevere danni. Meglio di così? [;)]
Pensa: per aggiornare ClamAV Virus Scanner ho predisposto un lanciatore sulla mia scrivania che fa partire il comando sudo freshclam.
Mi sta appassionando questa cosa. [std]
MegaLab.it (MLI) = Gianluigi "Zane" Zanettini - That's all Folks!
Avatar utente
markinson
Bronze Member
Bronze Member
 
Messaggi: 936
Iscritto il: sab mag 01, 2010 9:22 am
Località: Roma

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda The Doctor » sab mag 08, 2010 5:31 pm

Pensa: per aggiornare ClamAV Virus Scanner ho predisposto un lanciatore sulla mia scrivania che fa partire il comando sudo freshclam.


Ottimo. Hai installato anche clamtk? E' una GUI per ClamAv [;)]
Ciao Nonno
Avatar utente
The Doctor
MLI Hero
MLI Hero
 
Messaggi: 5553
Iscritto il: mer mar 24, 2010 9:10 am
Località: Fiumicino (Roma)

Re: [RISOLTO] avast! Linux Home Edition: 400vps ed errore.

Messaggioda markinson » sab mag 08, 2010 6:42 pm

Immagine

Ti ho messo pure la screenshot (fatta con Gimp!!!) di come sono messo. [:D]
Ci sto proprio prendendo gusto. Grazie Doc per la tua assistenza! [brindisi]
Devo però risolvere la questione dell'avanzamento 9.10 --> 10.04 sulla macchina che uso per Linux (ma questa è un'altra faccenda). [uhm]
MegaLab.it (MLI) = Gianluigi "Zane" Zanettini - That's all Folks!
Avatar utente
markinson
Bronze Member
Bronze Member
 
Messaggi: 936
Iscritto il: sab mag 01, 2010 9:22 am
Località: Roma


Torna a Distribuzioni, Kernel e Software Applicativo

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising