Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

linux non avviabile

Il forum riservato agli amici del Pinguino e al software libero.

linux non avviabile

Messaggioda mciasco » ven apr 09, 2004 2:32 am

Salve,
vorrei porvi il seguente problema:
fin'ora ho avuto due sistemi opeartivi su un portatile: win2000 e Linux con la seguente configurazione.
1) E: partizione primaria NTFS con win2000
2) C: partizione estesa contenente una partizione logica FAT32 per scambio dati fra win e linux
3) partizione primaria EXT2 con linux
4) partizione primaria LINUX SWAP
-LILO al boot per la selezione dei sistemi operativi avviabili
Il tutto mi era stato preparato da un conoscente

Ora ho provato ad installare winXP al posto di win2000 sperando (male) che linux non venisse toccato.
Il cd di XP è bootabile quindi è stato semplice. Ho cancellato la partizione n. 1) poi ne ho ricreata un'altra sempre NTFS. Tuttavia winXP è stato installato sì sulla partizione giusta ma è cambiata l'etichetta in C:. A questo punto la situazione è la seguente:
1) C: partizione primaria NTFS con winXP
2) D: partizione esetsa contenente una partizione logica FAT32 per scambio dati fra win e linux
3) partizione primaria EXT2 con linux
4) partizione primaria LINUX SWAP

Con partition magic 8 è quello che ora riesco a vedere, ma il problema è che linux non è più avviabile. Prima c'era LILO al boot che permetteva la selezione dei SO avviabili ma ora non ho nullae non posso avviare linux per riconfigurare LILO. Come posso fare? Ho sbagliato da qualche parte? BootMagic serve a qualcosa in tal caso? Il fatto di essere cambiate le etichette comporta qualche problema?
PS:BootMagic è installato per forza (non posso cambiare path) sulla partizione di scambio dati FAT32 che ora è D: (mentre prima era C).Aiuto!
Grazie.
Marco
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

linux non avviabile

Messaggioda mciasco » ven apr 09, 2004 2:32 am

Salve,
vorrei porvi il seguente problema:
fin'ora ho avuto due sistemi opeartivi su un portatile: win2000 e Linux con la seguente configurazione.
1) E: partizione primaria NTFS con win2000
2) C: partizione estesa contenente una partizione logica FAT32 per scambio dati fra win e linux
3) partizione primaria EXT2 con linux
4) partizione primaria LINUX SWAP
-LILO al boot per la selezione dei sistemi operativi avviabili
Il tutto mi era stato preparato da un conoscente

Ora ho provato ad installare winXP al posto di win2000 sperando (male) che linux non venisse toccato.
Il cd di XP è bootabile quindi è stato semplice. Ho cancellato la partizione n. 1) poi ne ho ricreata un'altra sempre NTFS. Tuttavia winXP è stato installato sì sulla partizione giusta ma è cambiata l'etichetta in C:. A questo punto la situazione è la seguente:
1) C: partizione primaria NTFS con winXP
2) D: partizione esetsa contenente una partizione logica FAT32 per scambio dati fra win e linux
3) partizione primaria EXT2 con linux
4) partizione primaria LINUX SWAP

Con partition magic 8 è quello che ora riesco a vedere, ma il problema è che linux non è più avviabile. Prima c'era LILO al boot che permetteva la selezione dei SO avviabili ma ora non ho nullae non posso avviare linux per riconfigurare LILO. Come posso fare? Ho sbagliato da qualche parte? BootMagic serve a qualcosa in tal caso? Il fatto di essere cambiate le etichette comporta qualche problema?
PS:BootMagic è installato per forza (non posso cambiare path) sulla partizione di scambio dati FAT32 che ora è D: (mentre prima era C).Aiuto!
Grazie.
Marco
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

Messaggioda Ices_Eyes » ven apr 09, 2004 8:51 am

Per prima cosa ti consiglio di eliminare l'altra discussione uguale che hai creato, il cross-posting è vietato...

Poi, veniamo al tuo problema. BootMagic è il gestore di avvio del partition magic appunto, e non può essere installato su partizioni NTFS, esclusivamente su fat / fat32, per questo non puoi cambiare unità. Fallo avviare, e segui questi passi:
1. Vai su Opzioni e metti la V su operazione nascondi partizione avanzata
2. Cancella tutti i sistemi operativi presenti nella lista e clikka su aggiungi.
3. seleziona windows XP in partizione NTFS, non quella in FAT32.
4. Mettici il nome che vuoi venga visualizzato e vai alla scheda Partizioni visibili.
5. Metti la V su Sovrascrivi partizioni predefinite e poi su quella fat32 che ti visualizza (dovrebbe essere l'unica possibile...)
6. Ripeti i punti 3/4/5 selezionando linux al punto 3 (al punto 5 dovresti questa volta poterne scegliere due, metti la V solo sulla fat32,non sulla NTFS!)
7. Metti la V su BootMagic Abilitato, scegliti il ritardo di avvio che vuoi, salva esci e riavvia. Dovrebbe funzionare il tutto...

Ciao [^]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia


Messaggioda mciasco » ven apr 09, 2004 12:19 pm

ciao,
innannzitutto chiedo scusa, non avevo capito che c'era qeul divieto. comunque l'ho fatto perché non sapevo esattamente a quale forum fosse + adatto il mio post.
Ad ogni modo ho fatto come dici tu ma non funzia.
Con winXP quando devo mettere la V su Sovrascrivi partizioni predefinite e poi su quella fat32 che ti visualizza in realtà quello che vedo sono le solite 4 partizioni che ho elencato ma tutte inattive (e con la V settata).
Per Linux invece se metto la V si attiva la casella NTFS SENZA V mentre le altre 3 rimangono inattive ma con la V settata...
io ho lasciato così e ho riavviato...
al riavvio sembra volere il dischetto di BootMagic perché altrimenti sta lì a far ballare le scimmie (sachermoi nero fisso per minuti...).
Se inserisco il dischetto mi carica bootmagic. mi compare il solito schema delle 4 partizioni dicendomi quale voglio rendere avviabile. WinXP è già avviabile e linux no. Cambio e metto linux ma al riavvio si ferma sullo schermo nero e basta...
che faccio?
grazie
marco
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

Messaggioda Erik » ven apr 09, 2004 3:20 pm

Che distrubuzione hai? Comunque basta che fai partire il cd della distro al boot, ma invece di far partire la modalita' installazione fai partire la modalità rescue e da li' c'è l'opzione lilo su cui puoi cliccare. Questo per le mandrake, se mi dai qualche informazione cerco di essere piu' preciso [^]
Avatar utente
Erik
Bronze Member
Bronze Member
 
Messaggi: 707
Iscritto il: sab mar 29, 2003 4:42 pm
Località: Marche

Messaggioda mciasco » ven apr 09, 2004 3:40 pm

guarda è un bel problema,
il discorso è difficile proprio perché ora non ho i cd di insatllazione di linux e non riesco a procurarmeli entro breve. comunque avrei una debian.
ma non è possibile avere un altro boot loader invece di lilo?
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

Messaggioda Ices_Eyes » ven apr 09, 2004 6:09 pm

Allora...L'ultima spiaggia è fare esattamente questo. Disinstalla BootMagic. Avvia PartitionMagic, digli di rende avviabile la partizione Windows e disattiva quella linux. Riavvia. Dovrebbe partire Windows. Ora installa il bootMagic, ma quando ti dice di riavviare non farlo e fai quello che ti ho detto prima. Mi raccomando, non riavviare però...Finito di settare il Boot puoi riavviare e vedere se funzia, spero di si... Ciao [^]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia

Messaggioda mciasco » ven apr 09, 2004 6:38 pm

ok ho provato ma la situazione è identica.
ora il discorso è che comunque partitionmagic e bootmagic funzionano bene tanto quanto l'attacco e la difesa della'ancona quest'anno!!!!
BootMagic è una bella merdina insomma...
ho guardato un po' in giro è temo che quel bas***do di winXP abbia sovrascritto allegramente il MBR uccidendo il povero LILO. Se è così devo per forza ritrovare almeno il primo cd della debian. ma vale qualunque versione (io dovrei avere la debian 2.2.4). ora ho visto che l'ultima stable è la 3.0.2. se scarico il primo cd (600MB!!!) andrà bene? sarò in grado di riconfigurare LILO? sapreste guidarmi eventualmente? Ultimo dubbio: non è che poi riconfiguro LILO che sovrascrive il MBR e addio winXP? Il mio calvario avrà mai fine?
grazie di tutto intanto...
marco
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

Messaggioda Ices_Eyes » ven apr 09, 2004 6:49 pm

La cosa è strana. E' corretto che quando hai installato WinXP ha sovrasritto il MBR e quindi lilo, ma se hi reinstallato il boot magic avrebbe dovuto sovrascrivere quello di XP e partire lui, a meno che...E qui casca l'asino....Ora mi è venuto in mente il motivo, e me ne scuso... Il problema è che il boot magic l'hai installato in una partizione logica, vero? E' l'ultima colonna del partition... Se è così non è bootabile, e dovresti farne una,bastano 50Mb, primaria..., magari levando sti 50MB da quella di XP,e installare lì il boot. Poi ti assicuro che funzia...

Ciao, scusami per la defaince... [angel]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia

Messaggioda mciasco » ven apr 09, 2004 7:01 pm

cazz...pita,
sai che mi sa che hai ragione...potevo pensarci da solo (idiota che sono anche io). senti però ti chiedo di farmi una descrizione esatta dei passaggi perché non sono pratico (l'avrai capito) di partitionmagic & co. sopratutto ho notato che partition mantiene una lisat di cose da applicare e le fa di seguito al riavvio. in tal caso servono a qualcosa i dischi di emergenza che mi ha fatto fare (2 per partitionmagic e 1 per bootmagic). nel senso, io faccio tutte le pugnette (ridimensiono, faccio la partizione primaria..) applico, quello mi fa riavviare e poi...che succede??? devo riavviare con il disco di emergenza di aprtittion già inserito o carica tutto da solo? io penso che la cosa avvenga così, se sbaglio correggimi e dammi la procedura esatta ti prego:
1)disinstallo bootmagic
2)con partittion magic ridimensiono la primaria di winXP(dimmi tu come!!!)
3)a sto punto si dovrebbe creare una partizione non assegnata(?)
4)quella la faccio primaria
5)setto attiva sempre quella di winXP
6)applico le modifiche (raivvio)
7) fa tutto partition (SPERO)
8)riavvia winXP
9)installo bootmagic sulla nuova partiz primaria
10)setto le cose come mi avevi detto tu prima (win+linux in bootagic)
11)rendo avviabile la partizione con bootmagic
12)applico (riavvio)
13)dovrebbe entarre in gioco bootmagic(????)
è così...dimmi se va bene e se ci sono cose starne a cui vado incontro...
grazie mille, mi sei stao molto d'aiuto!!!
marco
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

Messaggioda iaio » ven apr 09, 2004 8:10 pm

metti il primo cd debian.

al prompt digita
rescue root=/dev/hdax dove x è il numero della partizione avviabile.

una volta loggato puoi rimediare al "danno" con
lilo -v

Al riavvio successivo troverai sia debian che Win.

Ciao!
Avatar utente
iaio
Aficionado
Aficionado
 
Messaggi: 49
Iscritto il: ven gen 30, 2004 10:55 pm
Località: Piemonte

Messaggioda Ices_Eyes » sab apr 10, 2004 8:55 am

<blockquote id="quote"><font size="1" face="Verdana, Arial, Helvetica" id="quote">citazione:<hr height="1" noshade id="quote"><i>Messaggio inserito da mciasco</i>
<br />cazz...pita,
sai che mi sa che hai ragione...potevo pensarci da solo (idiota che sono anche io). senti però ti chiedo di farmi una descrizione esatta dei passaggi perché non sono pratico (l'avrai capito) di partitionmagic & co. sopratutto ho notato che partition mantiene una lisat di cose da applicare e le fa di seguito al riavvio. in tal caso servono a qualcosa i dischi di emergenza che mi ha fatto fare (2 per partitionmagic e 1 per bootmagic). nel senso, io faccio tutte le pugnette (ridimensiono, faccio la partizione primaria..) applico, quello mi fa riavviare e poi...che succede??? devo riavviare con il disco di emergenza di aprtittion già inserito o carica tutto da solo? io penso che la cosa avvenga così, se sbaglio correggimi e dammi la procedura esatta ti prego:
1)disinstallo bootmagic
2)con partittion magic ridimensiono la primaria di winXP(dimmi tu come!!!)
3)a sto punto si dovrebbe creare una partizione non assegnata(?)
4)quella la faccio primaria
5)setto attiva sempre quella di winXP
6)applico le modifiche (raivvio)
7) fa tutto partition (SPERO)
8)riavvia winXP
9)installo bootmagic sulla nuova partiz primaria
10)setto le cose come mi avevi detto tu prima (win+linux in bootagic)
11)rendo avviabile la partizione con bootmagic
12)applico (riavvio)
13)dovrebbe entarre in gioco bootmagic(????)
è così...dimmi se va bene e se ci sono cose starne a cui vado incontro...
grazie mille, mi sei stao molto d'aiuto!!!
marco
<hr height="1" noshade id="quote"></blockquote id="quote"></font id="quote">

Allora...I dischetti, sia del boot che del partition, servono solo in caso di disastro, e spero non ti succeda mai, ma comunque per esperienza personale ti consiglio di tenerli aggiornati ad ogni nuova modifica delle partizioni...
Per tornare a noi devi:
1.Clikka in alto a sx su crea nuova partizione
2.Quando ti chiede dove, lascia quella consigliata,ma assicurati che sulla colonna "Crea come" ci sia Primaria o logica, alrimenti cambia posto in uno dove puoi farla primaria.
3.Recupera spazio un po' da dove vuoi, ma ti consiglio da WinXP, dato che è bella grande...(se ti dice che non è possibile, cambia unità da cui rubare...[:D])
4.Dimensioni:50B sono più che sufficienti.
5.Etichetta:scegli tu.
6.Tipo: primaria
7.Tipo di file system: FAT o FAT32 è uguale.
8.Clikka su applica sulla lista di operazioni da fare, e...tieni le dia incrociate...
Al riavvio rifai subito i dischetti di PartitionMagic, installa il BootMagic facendo di nuovo il dischetto quando te lo dice, e <u>senza riavviare</u> fai come ti avevo scritto per la configurazione...Ora al riavvio dovresti avere tutto a posto...
In alternativa a tutto questo,che si fa prima a fare che a dire, c'è quello che ha detto iaio per ripristinare lilo...(che personalmente non mi piace... [;)])

Ciao, facci sapere [^]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia

Messaggioda mciasco » sab apr 10, 2004 2:59 pm

ciao ragazzi,
ce l'ho fatta!!!!!!!!
grazie a tutti per i consigli. Alla fine ho scaricato il primo cd della debian da internet (1 oretta di tempo...+ che accettabile). con quello ho riconfigurato lilo e ora tutto è ok.
Vorrei chiedere comunque un paio di chiarimenti:
1)su debian.org si dice che per noi non amerciani bisogna scaricare l'immagine iso del primo cd debian non-US. io mi sono accorto dopo e ho scaricato la US, ma per quello che ho fatto ha funzionato lo stesso. chiedo: se scarico i seguenti iso poi mi darà problemi in caso di reinsatllazione di linux?

2)sempre su debian.org c'è un HOWTO su come masterizzare esattamente l'iso con vari programmi. anche qui l'ho notato dopo ma io con nero non ho avuto problemi a fare il rescue. ne potrà dare in fase di eventuale installazione?

Un ultima ocsa...il comando:
boot: rescue root=/dev/hdaX non funzionava
ho dovuto utilizzare:
boot: rescbf24 root=/dev/hdaX non funzionava (trovato nell'help F3)
questo perché forse io ho il kernel 2.4??

Ad ogni modo grazie infinite e a presto (perché entro la primavera proverò a reinstallare la debian!!!!)
ciao ciao,
marco
Avatar utente
mciasco
Senior Member
Senior Member
 
Messaggi: 151
Iscritto il: ven apr 09, 2004 2:15 am

Messaggioda iaio » sab apr 10, 2004 9:09 pm

<i>
Un ultima cosa...il comando:
boot: rescue root=/dev/hdaX non funzionava
ho dovuto utilizzare:
boot: rescbf24 root=/dev/hdaX
questo perché forse io ho il kernel 2.4??</i>

Esatto. :)
Avatar utente
iaio
Aficionado
Aficionado
 
Messaggi: 49
Iscritto il: ven gen 30, 2004 10:55 pm
Località: Piemonte


Torna a Distribuzioni, Kernel e Software Applicativo

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising