Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Problemi con comandi Dos append e mode con.

Problemi con i sistemi operativi di casa Microsoft? Questa è la sezione che fa per te!

Problemi con comandi Dos append e mode con.

Messaggioda _max_ » ven mar 05, 2004 12:07 pm

Ciao a tutti.
Ho un programma di installazione che girando su dos esegue dei comandi che vanno in errore, provo quindi a lanciarli a mano io ma stessi errori.
Questi i comandi:
c:>path c:;c: ealia;c:dos;....
Domanda 1: e'un errore iniziare la path con "c:;" o ha un senso?
Comunque questo comando di path non da errori.
c:>append c: ealia abelle;....
Il dos risponde comando o file non valido, le cartelle esistono in
quella root, da lo stesso errore anche se faccio un append alla volta
Domanda 2: Why???????????????
c:>mode con: delay = 1 rate = 32
comando non valido!
Domanda 3:Se non sbaglio questo comando serve solo ad aumentare la ram del dos? O sto dicendo una baggianata?[:D] Ho provato anche con il ; alla fine, senza :, con un comando alla volta...
Help pls.
Avatar utente
_max_
Aficionado
Aficionado
 
Messaggi: 37
Iscritto il: lun set 08, 2003 12:15 pm

Problemi con comandi Dos append e mode con.

Messaggioda _max_ » ven mar 05, 2004 12:07 pm

Ciao a tutti.
Ho un programma di installazione che girando su dos esegue dei comandi che vanno in errore, provo quindi a lanciarli a mano io ma stessi errori.
Questi i comandi:
c:>path c:;c: ealia;c:dos;....
Domanda 1: e'un errore iniziare la path con "c:;" o ha un senso?
Comunque questo comando di path non da errori.
c:>append c: ealia abelle;....
Il dos risponde comando o file non valido, le cartelle esistono in
quella root, da lo stesso errore anche se faccio un append alla volta
Domanda 2: Why???????????????
c:>mode con: delay = 1 rate = 32
comando non valido!
Domanda 3:Se non sbaglio questo comando serve solo ad aumentare la ram del dos? O sto dicendo una baggianata?[:D] Ho provato anche con il ; alla fine, senza :, con un comando alla volta...
Help pls.
Avatar utente
_max_
Aficionado
Aficionado
 
Messaggi: 37
Iscritto il: lun set 08, 2003 12:15 pm

Messaggioda crazy.cat » ven mar 05, 2004 4:49 pm

Il path scrivilo così, non sono sicuro ma credo che ci voglia un = dopo il path, per verificare se funziona scrivi dal dos semplicemente path e invio così vedi cosa ti ha preso.
path c:;c: ealia;c:dos;.... (metti la barra vicino al 1 dopo i c: me la cancella se tento di scriverla)
e questo ti risolve anche il comando append e forse anche il mode con perché non lo trovava non essendoci il c:dos attivo nel path.
Non ti aumenta la memoria, quando vado a casa ho un manuale di dos 5 e vedo di trovare a cosa serve.
Per aumentare la memoria devi usare himem.sys,emm386.exe dos=high,umb tutti nel config.sys e settati con i parametri giusti.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Messaggioda _max_ » ven mar 05, 2004 8:32 pm

path c:;c: ealia....
Scusa crazy.cat mi ero dimentico uno slash nel topic, ma c'era.
L'uguale dopo il path non e' obbligatorio(e comunque o provato).
La prova di scrivere path l'ho fatta e mi da la path corretta.
Anche l'append l'ho bypassato: ho scoperto che puoi scriverla lunga quanto vuoi la path, quindi non serve l'append(mi rimane il tarlo di perche' non me lo prende questo append pero'!!![nomi])
Il "mode con" non riesco a capire a cosa serva, se e' un fatto di prestazioni ne faccio a meno.
Avatar utente
_max_
Aficionado
Aficionado
 
Messaggi: 37
Iscritto il: lun set 08, 2003 12:15 pm

Messaggioda crazy.cat » ven mar 05, 2004 9:19 pm

Gli slash mi hanno ingannato perché me li mangiava anche a me.

mode con: delay = 1 rate = 32
Imposta la velocità=rate e il ritardo=delay di ripetizione dei tasti ma alcune tastiere non lo supportano.

append unita:percorso; /x /path:on
Questa è la sintassi completa di append, le opzioni dicono che il programma deve cercare i file nelle directory aggiunte nel path.

(tratto dal manuale del dos 5)
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre


Torna a Sistema Operativo

Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising