Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Problema visualizzazione MegaLab.it

Suggerimenti, commenti, segnalazione errori, critiche, lodi e quant'altro riguardi strettamente MegaLab.it e i suoi contenuti.

Problema visualizzazione MegaLab.it

Messaggioda developerwinme » lun lug 27, 2009 10:54 am

Ciao a tutti. Vorrei segnalare un problema di visualizzazione che riscontro utilizzando IE8 (per favore non siate prevenuti nei confronti del browser: non credo sia colpa sua [:)] ) e MegaLab.it e cioè:

Nella home page, cliccando sulla freccina presente accanto ad ognuno dei 6 pulsanti visualizzati in alto (Home, Canali, Download ecc...) compare il menu, ma è trasparente, cioò non ha lo sfondo bianco che dovrebbe (l'ho verificato con Chrome). Quindi mi risulta molto difficile cliccare su una delle voci del menu senza selezionare qualche elemento presente sotto.

Inizialmente credevo che la colpa fosse un mancato supporto degli standard da parte di Internet Explorer ma dopo, guardando nella finestra "strumenti di sviluppo" mi sono accorto che, di default, IE utilizza la modalità IE7 per renderizzare MegaLab e non la IE8 (che, se selezionata manualmente, elimina il problema descritto sopra). Cercando di scoprire il perché di questa scelta ho scoperto che nella pagina c'è il tag "<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>" che informa il browser di utilizzare la modalità IE7. Ora mi chiedo perché, se il sito funziona correttamente con la modalità IE 8 sia stato aggiunto il suddetto tag, impedendo agli utenti di IE8 di visualizzarlo al meglio.

Comunque c'è un modo per costringere Internet Explorer ad utilizzare la modalità IE8 per un sito specifico?
PC: ASUS X53S (Intel Core i7-2670QM 2.20 Ghz, RAM 8 GB, NVIDIA GeForce GT520MX, Windows 8 Pro)
Mobile: Nokia Lumia 710 (CPU 1,4 Ghz, RAM 512 MB, Windows Phone 7.8)
--
developerwinme.wordpress.com
Avatar utente
developerwinme
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5014
Iscritto il: mar dic 30, 2008 7:00 pm
Località: Como

Re: Problema visualizzazione MegaLab.it

Messaggioda Andy94 » lun lug 27, 2009 1:42 pm

developerwinme ha scritto:Nella home page, cliccando sulla freccina presente accanto ad ognuno dei 6 pulsanti visualizzati in alto (Home, Canali, Download ecc...) compare il menu, ma è trasparente, cioò non ha lo sfondo bianco che dovrebbe (l'ho verificato con Chrome). Quindi mi risulta molto difficile cliccare su una delle voci del menu senza selezionare qualche elemento presente sotto.

Appena accendo il notebook con 7 ci guardo.
developerwinme ha scritto:Ora mi chiedo perché, se il sito funziona correttamente con la modalità IE 8 sia stato aggiunto il suddetto tag, impedendo agli utenti di IE8 di visualizzarlo al meglio.

Mi pare che fosse perché ci sono alcuni problemi riscontrati con IE8 in altre aree, poi ci riguardo.
Ti farò sapere, casomai apro un bug chiedendo la rimozione di quel metatag o la risoluzione del problema.
developerwinme ha scritto:Comunque c'è un modo per costringere Internet Explorer ad utilizzare la modalità IE8 per un sito specifico?

Questo non lo so, ma non credo.
Avatar utente
Andy94
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 9998
Iscritto il: lun apr 09, 2007 8:39 pm

Re: Problema visualizzazione MegaLab.it

Messaggioda ste_95 » lun lug 27, 2009 4:07 pm

Sì, hai ragione, c'è effettivamente il problema che segnali. Giro la cosa ai piani alti e ti faccio sapere.
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am


Re: Problema visualizzazione MegaLab.it

Messaggioda developerwinme » mar lug 28, 2009 7:56 am

ste_95 ha scritto:Sì, hai ragione, c'è effettivamente il problema che segnali. Giro la cosa ai piani alti e ti faccio sapere.


Bene, spero che il problema venga risolto presto [^] , anche perché quel tag è interpretato solo da IE 8 e quindi eliminarlo non dovrebbe creare problemi agli altri browser, ammesso che il sito rispetti gli standard W3C (credo di si perché firefox, chrome e opera lo visualizzano correttamente).

Grazie, ciao [;)]
PC: ASUS X53S (Intel Core i7-2670QM 2.20 Ghz, RAM 8 GB, NVIDIA GeForce GT520MX, Windows 8 Pro)
Mobile: Nokia Lumia 710 (CPU 1,4 Ghz, RAM 512 MB, Windows Phone 7.8)
--
developerwinme.wordpress.com
Avatar utente
developerwinme
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5014
Iscritto il: mar dic 30, 2008 7:00 pm
Località: Como

Re: Problema visualizzazione MegaLab.it

Messaggioda developerwinme » ven ago 07, 2009 10:00 am

ste_95 ha scritto:Sì, hai ragione, c'è effettivamente il problema che segnali. Giro la cosa ai piani alti e ti faccio sapere.


Ci sono novità? Anche perché mi sembre che ora il sito abbia qualche altro problema con IE 8, infatti la colonna presente nel lato sinistro della pagina non è delle dimensioni giuste e l'editor degli articoli non funziona correttamente (non è possibile aggiungere le foto). Mi sa che sarò costretto ad usare Chrome...
PC: ASUS X53S (Intel Core i7-2670QM 2.20 Ghz, RAM 8 GB, NVIDIA GeForce GT520MX, Windows 8 Pro)
Mobile: Nokia Lumia 710 (CPU 1,4 Ghz, RAM 512 MB, Windows Phone 7.8)
--
developerwinme.wordpress.com
Avatar utente
developerwinme
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5014
Iscritto il: mar dic 30, 2008 7:00 pm
Località: Como

Re: Problema visualizzazione MegaLab.it

Messaggioda ste_95 » ven ago 07, 2009 10:07 am

Inizio subito con il dire che il sito è ottimizzato per Firefox.

developerwinme ha scritto:infatti la colonna presente nel lato sinistro della pagina non è delle dimensioni giuste e l'editor degli articoli non funziona correttamente (non è possibile aggiungere le foto). Mi sa che sarò costretto ad usare Chrome...

La colonna di sinistra è stata volutamente rimpicciolita per dare più spazio a quella di destra, e anche il problema della galleria immagini è noto. [;)]

Per conto mio, ti consiglio quando devi scrivere un articolo, di usare browser alternativi. [;)]
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am


Torna a Benvenuto in MegaLab.it

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron
Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising