Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

I buut dal quale lancio il so non lo identifica come disco C

Problemi con i sistemi operativi di casa Microsoft? Questa è la sezione che fa per te!

I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » mer ott 15, 2008 12:13 am

Su di un PC con su due hd sul quale uno con il so Win 98 se, e l'altro
con su XP Professional con su il dual boot residente su l'hd win 98 se,
indipendentemente dalla scelta fatta al momento di richiesta con quale
so si vuol partire, il PC riconosce sempre quale disco C il disco con su
win 98, mentre l'altro hd con su XP Professional viene riconosciuto come
disco D.
Premetto che tutti e due i so funzionano benissimo.
L'inconveniente si propone quando viene lanciato il so XP Professional
il proprio hd viene riconosciuto quale disco D e non C come per rito
doveva riconoscere; infatti quando si devono istallare dei programmi che
richiedono quale unità il disco C e non richiedono la possibilità di
"scelta disco", questi ultimi vengono istallati sul disco C dove risiede
win 98se.
Il tutto succede dopo che per ragioni varie, si è dovuto riistallare il
so XP Professional.
potete darmi una mano indicandomi qualche utility o "trucchetto" con il
quale posso risolvere il tutto senza dover istallare nuovamente XP?
perché penso sia stato quando ho installato XP che per una mia svista
non ho risposto a qualche domanda utile a questo caso?
Ringrazio fiducioso e nell'occasione saluto tutti.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Lo Re » mer ott 15, 2008 4:01 pm

Ciao,
il messaggio non è dei più chiari; provo a riepilogare tu correggimi se sbaglio.

Allora tu hai 2 hdd (fisici) e non un disco solo partizionato in due.
Su C: hai installato win98 e su D: hai installato winXP giusto?

Per quanto riguarda l'installazione dei programmi mi sembra strano che il percorso non sia modificabile, magari non c'è il tasto browse (sfoglia) però a mano si può modificare il percorso.

Attendiamo tue notizie.
Chi fa ciò che ama, vive come un [re]
Avatar utente
Lo Re
Senior Member
Senior Member
 
Messaggi: 178
Iscritto il: dom dic 11, 2005 3:46 pm
Località: .: Roma :.

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » mer ott 15, 2008 8:32 pm

Grazie per aver letto il mio post. E' proprio così ho due dischi fissi sui quali in uno c'e istallato win 98 e l'alto xp.
il disco C è quello dove è installato il so win 98 mentre il disco D è quello dove è istallato xp.
Quando lancio il boot di win 98 in base alla scelta propostami dal dual boot, il sistema riconosce quale disco C il disco con su win 98 e il disco D il disco con su xp.
Quando invece lancio il boot da xp sempre in base alla scelta propostami dal dual boot, il sistema riconosce sempre il disco C dove vi è installato win 98 e il disco D dove risiede xp.

Prima dell'istallazione di xp, mi riconosceva sempre quale disco C il disco con il quale avevo lanciato il so.

Spero di essermi spiegato meglio, qualora avessi bisogno di altre delucidazioni sono pronto a mandartele.

Ciao e a presto.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am


Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » mer ott 22, 2008 12:16 pm

E' tutto normale.

Se hai installato Windows 98 in C: e Windows XP in D:, è normale che all'interno dei SO C: sia assegnato a Windows 98 e D: a Windows XP.

Se il problema riguarda le installazione che copiano in automatico alcuni file di sistema in C:, ahimé non c'è modo di risolvere.
Non è un problema di Windows ma è un problema dei vari setup.

Alcuni sono configurati usando percorsi standard già scritti (esempio copia file.dll in C:\windows\system32).
Altri invece sono configurati in modo più intelligente ossia invece di usare percorsi già pronti, usano invece di C: la parola %SystemDrive% che permette al setup di rilevare in modo automatico dove si trova il SO e quindi installa i file correttamente in D:
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » gio ott 23, 2008 9:07 am

Grazie per la risposta Angelus88.
Condivido la tua precisazione, ma prima dell'istallazione di xp sul disco D, al lancio del boot mi riconosceva sempre quale disco C il disco con il quale avevo lanciato il SO. Pertanto chiedo come posso fare per risolvere questo problema? Grazie ancora e aspetto notizie.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » gio ott 23, 2008 9:50 am

Kleopatra scusa ma allora io (e forse anche gli altri) non ho ancora capito esattamente il problema... [V]
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » gio ott 23, 2008 1:29 pm

Allora cercherò di spiegarmi meglio:
Prima vi era isatallato su di un disco il so win 98, e su l'altro disco il so Xp Pro,
quando lanciavo il boot dal disco con su win98, il sistema riconosceva il disco C questo disco come disco C, mentre l'alto disco con su win xp lo riconosceva come disco D.
Mentre se io lanciavo il boot dal disco con su xp , il sistema riconosceva il disco C questo disco come disco C, mentre l'altro disco con su win 98 lo riconosceva come disco D.

Tutto questo accade dopo aver reinstallato il SO xp, (perché era incasinato) il sistema riconosce sepre quale disco C il disco dove vi è installato win 98, e laltro disco con su xp lo riconosce sempre quale disco D, indipendentemente da dove lancio il boot.

Spero di essere stato chiaro, aspetto notizie grazie.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » gio ott 23, 2008 1:41 pm

Ok... ragazzi vi lascio il topic che io ci rinuncio [boh]
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » gio ott 23, 2008 2:32 pm

Angelus88 hai rinunciato perché non sono stato chiaro oppure non conosci una soluzione al problema?
Qualcuno mi sa rispondere grazie.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » gio ott 23, 2008 2:51 pm

Perché ancora non ho capito il problema... [rolleyes]
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » gio ott 23, 2008 5:29 pm

Il problema è che quando parto con SO xp il disco dove risiede xp lo riconosce come disco D e non C come dovrebbe essere.
Ti ringrazio della pazienza.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » gio ott 23, 2008 9:21 pm

Scusa Windows 98 c'è ancora in C: ?
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » gio ott 23, 2008 9:41 pm

Si, win 98 risiede in C e xp in D
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » gio ott 23, 2008 11:33 pm

E allora se Windows 98 funziona ed è in C: e Windows XP funziona ed è in D: , perché quando avvii con XP dovrebbe rilevarlo come se fosse C: quando invece è giusto che sia D: ?!?! E' questo che non capisco!! Mi stai facendo impazzire...
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » ven ott 24, 2008 10:18 am

Ma perché prima il pc si comportava diversamente?
al pc prima di riinstallare xp ho montato un disco nuovo, e il vecchio l'ho staccato fisicamente dal pc e messo da parte per eventuali dati da recuperare in un secondo momento.
Adesso faccio un esempio di come si comporta il pc.

Se sul pc installo il disco Nuovo il pc si comporta come sotto descritto:

Esempio con nuovo disco: Boot da win 98 - in risorse del pc trovo: disco C con su Win 98, e disco D con xp. OK
Boot da xp - in risorse del pc trovo : disco C con su win 98, e disco D con xp. No OK

Se sul pc installo il disco Vecchio il pc si comporta come sotto descritto:


Esempio con disco vecchio: Boot da win 98 - in risorse del pc trovo: disco C con su win 98, e disco D con xp. OK
Boot da xp - in risorse del pc trovo: disco C con su xp, e disco D con Win 98. OK

Ora mi chiedo perché tutto questo??

Copisco che c'è da impazzire ma spiegare il tutto per iscritto a me rende difficile, ci saremmo capiti se la discussione sarebbe stata di persona oppure telefonicamente, e poi comunque, fornire al forum la soluzione di come è stata risolta.
Ringrazio comunque per la tua ammirabile pazienza.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Amantide » ven ott 24, 2008 11:13 am

Scusa, ma inserendo il secondo hard disk, sposti lo jumper su slave o lasci entrambi hard disk come master? [uhm]
...per volare alto, bisogna saper cadere...
Avatar utente
Amantide
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 8126
Iscritto il: lun feb 06, 2006 4:13 pm
Località: Abruzzo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda Angelus88 » ven ott 24, 2008 12:18 pm

Forse ho capito e te lo spiego...

Il problema risiede nei file di boot.

Inizialmente vi erano 2 hard disk: nel primo C: c'era Windows 98 e nel secondo c'era Windows XP con la lettera D:
Boot da Windows 98, in C: c'è Windows 98, boot da Windows XP, in D: c'è Windows XP.
Fin qui tutto normale.

Quando hai reinstallato XP, hai fatto una cosa che non dovevi fare ossia scollegare l'hard disk con Windows 98.
Se lo avessi lasciato, il setup di XP avrebbe copiato i file di boot nel disco di Windows 98, creato in automatico
il dual boot e mantenuto le lettere ossia C: Window 98 e D: Windows XP.

Ma avendo scollegato il disco di Windows 98, il disco di Windows XP è diventato C: poiché Windows 98 non c'era più!
Ecco perché adesso se avvii Windows 98, la lettera è C: ma se avvii Windows XP la lettera è sempre C: !

E' come se avessi installato i SO in modo separato e quindi il collegamento tra di loro non c'è più.
Probabilmente se invece di Windows 98 c'era un altro SO tipo un altro Windows XP o Vista, il pc avrebbe fatto il boot solo
con XP o non sarebbe partito nulla.
Avatar utente
Angelus88
Aficionado
Aficionado
 
Messaggi: 54
Iscritto il: mar ott 21, 2008 11:23 pm
Località: Palermo

Re: I buut dal quale lancio il so non lo identifica come disco C

Messaggioda kleopatra » ven ott 24, 2008 4:37 pm

Angelus88 Tu dici (Inizialmente vi erano 2 Hard disk: nel primo C: c'era Windows 98 e nel secondo c'era Windows xp con la lettera D: Boot da windows 98, in C: c'è Windows 98, boot da Windows xp, in D: c'è xp. non era così, se guardi il mio esempio, but da xp in C trovvavo xp e non in D.

Poi dici quando hai istallato xp, hai fatto una cosa che non dovevi fare ecc.
Io non ho mai staccato il disco con su Windows 98 perche quello funziona benissimo ma ho staccato e sostituito il disco con su xp perché era quel SO da sostituire.

Se il problema risiede nel file di boot, non posso apportare modifiche e risolvere il problema? cosa devo modificare in questo file?
dove lo devo cercare?


Rispondo anche ad Amantide che gentilmente è intervenuta alla discussione:
gli jumper sono settati su CS Enabled in entrambi i dischi, mentre quello con su win 98 e settato come master.

a presto.
Avatar utente
kleopatra
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: dom ott 12, 2008 11:31 am


Torna a Sistema Operativo

Chi c’è in linea

Visitano il forum: Nessuno e 2 ospiti

cron
Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising