Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Blocco sistema operativo

Il forum riservato agli amici del Pinguino e al software libero.

Blocco sistema operativo

Messaggioda jordan air » ven set 05, 2008 4:55 pm

E' già la terza volta che mi capita un blocco sospetto del s.o. Questo accade dopo che il sistema inizia a swappare senza motivo. Questa mattina preoccupato della faccenda, ho effettuato un controllo del disco ma senza trovare errori di alcun genere.
Dato che l'ultima volta che ho fatto un controllo del file system con Linux il sistema non è più partito, mi chiedevo se ci fosse un'altra strada dato che non esiste un comando come chkdsk/f.

Il problema è serio, dato che mi è toccato spegnere il pc dal tasto centrale.

Cosa suggerite? [grazie]
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda KeyroEvolution » ven set 05, 2008 5:13 pm

Beh, in teoria non serve fare scandisk o defrag, perche` Linux, prima di avviare il server grafico lo fa gia`.
Io credo che sia un problema hardware o come hai installato e gestito i vari sistemi operativi.
Potresti dirci come hai formattato la partizione che ospita Linux? Del tipo : una per lo swap, una per la home ecc...
Avatar utente
KeyroEvolution
Senior Member
Senior Member
 
Messaggi: 311
Iscritto il: dom gen 20, 2008 3:12 pm
Località: Padova!

Re: Blocco sistema operativo

Messaggioda jordan air » ven set 05, 2008 7:43 pm

Sapevo che prima o poi il problema sarebbe saltato fuori. Sinceramente ho utilizzato l'intero disco per la formattazione selezionando "usa tutto il disco da 200gb" prima dell'installazione. Questo perché se impostavo manualmente le partizioni di swap, home ecc. ad ogni riavvio il s.o non veniva rilevato. Non ho idea del perché accadesse questo (non mi sono interessato più di tanto). A questo punto credo che il problema sia questo. Che ne pensate?
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano


Re: Blocco sistema operativo

Messaggioda KeyroEvolution » ven set 05, 2008 8:14 pm

Questo perché se impostavo manualmente le partizioni di swap, home ecc. ad ogni riavvio il s.o non veniva rilevato. Non ho idea del perché accadesse questo (non mi sono interessato più di tanto)


Bisogna impostare anche l' MBR, per quello non lo rilevava.

Siamo certi della piena funzionalita` dei BIOS ... ?
Perche` a me viene in mente solo questo.
Pensati che anche a me succedeva che Linux si bloccasse, smontando il pc, ho trovato dietro la scheda madre un bel pezzo di ferro che faceva contatto con i circuiti ; tolto il pezzo tolti i problemi.
Per cui non credo che siamo di fronte ad un problema di Software.
Avatar utente
KeyroEvolution
Senior Member
Senior Member
 
Messaggi: 311
Iscritto il: dom gen 20, 2008 3:12 pm
Località: Padova!

Re: Blocco sistema operativo

Messaggioda jordan air » ven set 05, 2008 10:08 pm

Per l'mbr darò un'occhiata, ma per quanto riguarda i componenti, non c'è nulla che faccia contatto se non il case. Farò delle prove. Vi farà sapere.
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » dom set 07, 2008 2:42 pm

Per il controllo delle partizioni, ricordati che non devono essere montate, altrimenti rischi di perdere i dati in esse contenuti, al massimo si può fare il check di una partizione montata in sola lettura ... spero di essere stato chiaro, per questo spesso si utilizzano i LiveCd per effettuare il controllo della partizione di root, ovvero /, perché è più comodo che non avviare il sistema in single user con la partizione in sola lettura.

Il comando da usare è fsck, specificando il tipo di filesystem, oppure uno dei suoi derivati fsck.ext2, fsck.ext3, fsck.vfat, ecc...

... per saperne di più ti consiglio la lettura del manuale con il comando:

Codice: Seleziona tutto
man fsck


Nel manuale ti sposti con i tasti freccia, esci con il tasto q (quit=esci).

[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » dom set 07, 2008 10:09 pm

Grazie ninja. Un altro tassello che si va ad aggiungere alle mie conoscenze linuxuniane. [grazie]
Dunque, ho aperto il case per effettuare un controllo generale ma nulla. Niente che faccia contatto con qualche cosa. Ora sto aspettando dei componenti per il case. Per ora mi sono limitato a convertire il file system che utilizzo per aMule da ntfs a ext3. Vediamo come va. [ciao]
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda jordan air » lun set 08, 2008 11:11 am

Non credo di aver capito come effettuare il controllo del file system. Ho provato ad utilizzare diversi comandi, ma sinceramente non so se l'operazione sia andata a termine.

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ man fsck
ubuntu@ubuntu:~$ fsck.ext3
Usage: fsck.ext3 [-panyrcdfvstDFSV] [-b superblock] [-B blocksize]
[-I inode_buffer_blocks] [-P process_inode_size]
[-l|-L bad_blocks_file] [-C fd] [-j external_journal]
[-E extended-options] device

Emergency help:
-p Automatic repair (no questions)
-n Make no changes to the filesystem
-y Assume "yes" to all questions
-c Check for bad blocks and add them to the badblock list
-f Force checking even if filesystem is marked clean
-v Be verbose
-b superblock Use alternative superblock
-B blocksize Force blocksize when looking for superblock
-j external_journal Set location of the external journal
-l bad_blocks_file Add to badblocks list
-L bad_blocks_file Set badblocks list
ubuntu@ubuntu:~$ p
bash: p: command not found
ubuntu@ubuntu:~$ -p
bash: -p: command not found
ubuntu@ubuntu:~$ -A
bash: -A: command not found
ubuntu@ubuntu:~$ fsck.ext3 -c /dev/hda
e2fsck 1.40.8 (13-Mar-2008)
fsck.ext3: No such file or directory while trying to open /dev/hda

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ fsck.ext3 -c /dev/hda1
e2fsck 1.40.8 (13-Mar-2008)
fsck.ext3: No such file or directory while trying to open /dev/hda1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ e2fsck -b 8193 hda1
e2fsck 1.40.8 (13-Mar-2008)
e2fsck: No such file or directory while trying to open hda1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ e2fsck -b 8193 hda
e2fsck 1.40.8 (13-Mar-2008)
e2fsck: No such file or directory while trying to open hda

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ sudo fsck /dev/hda1
fsck 1.40.8 (13-Mar-2008)
e2fsck 1.40.8 (13-Mar-2008)
fsck.ext2: No such file or directory while trying to open /dev/hda1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ sudo fsck /dev/hda1
fsck 1.40.8 (13-Mar-2008)
e2fsck 1.40.8 (13-Mar-2008)
fsck.ext2: No such file or directory while trying to open /dev/hda1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » lun set 08, 2008 5:51 pm

Ciao.

Prova con:

Codice: Seleziona tutto
fsck.ext3  -vfp /dev/hda1


anche se penso che utilizzando una versione recente di Kubuntu dovrebbe essere:

Codice: Seleziona tutto
fsck.ext3  -vfp /dev/sda1


[ciao]

P.S.: ricordati di farlo da LiveCD... [^]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » mar set 09, 2008 4:58 pm

Nulla il risultato è uguale. Non riesco a capire cosa c'è di sbagliato.

Queste sono le risposte del terminale dopo averlo interrogato con i comandi citati nel post precedente.

ubuntu@ubuntu:~$ fsck.ext3 -vfp /dev/hda1
fsck.ext3: No such file or directory while trying to open /dev/hda1
/dev/hda1:
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

ubuntu@ubuntu:~$ fsck.ext3 -vfp /dev/sda1
fsck.ext3: Permission denied while trying to open /dev/sda1
You must have r/w access to the filesystem or be root
ubuntu@ubuntu:~$
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » mar set 09, 2008 6:06 pm

jordan air ha scritto:...

....

ubuntu@ubuntu:~$ fsck.ext3 -vfp /dev/sda1
fsck.ext3: Permission denied while trying to open /dev/sda1
You must have r/w access to the filesystem or be root
ubuntu@ubuntu:~$


Traduzione messaggio:

Permesso negato finché vovavi ad aprire /dev/sda1
devi avere l'accesso in lettura/scrittura al filesystem oppure devi essere root

Soluzione:

Codice: Seleziona tutto
sudo fsck.ext3  -vfp /dev/sda1


[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » mar set 09, 2008 8:21 pm

Bene questa volta il terminale ha risposto. In precedenza, mi sono fatto ingannare dal tempo d'attesa derivato dall'inserimento del comando sudo fsck.ext3 -vfp /dev/sda1.

I rusultati sono i seguenti:
To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

ubuntu@ubuntu:~$ sudo fsck.ext3 -vfp /dev/sda1


157 inodes used (0.00%)
18 non-contiguous inodes (11.5%)
# of inodes with ind/dind/tind blocks: 57/45/3
15216511 blocks used (31.16%)
0 bad blocks
7 large files

133 regular files
15 directories
0 character device files
0 block device files
0 fifos
0 links
0 symbolic links (0 fast symbolic links)
0 sockets
--------
148 files


Da quanto ho capito, il sistema riconosce i blocchi difettosi identificandoli come bad blocks. In questo caso i b.b. sono pari a zero quindi il filesystem è intatto.

A questo punto mi chiedo...

Da cos'altro può dipendere il blocco del sistema?

Può essere frutto di una cattiva gestione delle partizioni contenenti boot, swap ecc. Però l'installazione di Ubuntu l'ho eseguita selezionando l'opzione "utilizza tutto il disco da 200gb", quindi le partizioni dovrebbero essersi create in modo automatico.

Sinceramente non mi viene in mente nessuna altra cosa. [boh]
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » mer set 10, 2008 11:35 pm

Ciao.

0 bad blocks

Dovrebbe consolarti, ma in realtà quando incominci a vedere i bad block ormai è tardi, perché il controller interno del disco fisso gestisce una porzione di disco utilizzata per la sostituzione dei settori difettosi prima che i dati vadano persi...

... questo è trasparente al S.O. (Sistema Operativo), che può controllare questi dati solo mediante l'uso del protocollo SMART, quindi quando i programmi di controllo dei filesystem trovano i settori danneggiati è perché il controller ha finito i settori disponibili per lo scambio, ovvero in realtà ne ha già sostituiti parecchi.

Ti consiglio quindi l'installazione del pacchetto smartmontools, quindi con il comando:

Codice: Seleziona tutto
sudo smartctl -ia /dev/sda


Tra le varie informazioni, troverai una tabella contenente Reallocated_Sector_Ct il contatore dei settori riallocati, Reallocated_Event_Count gli eventi di riallocazione contati, Temperature_Celsius la temperatura in °C del disco nel momento in cui è stato eseguito il comando, Current_Pending_Sector i settori che si stanno danneggiando (pendenti) ovvero contengono errori ma sono ancora recuperabili con l'aiuto dei codici di correzione degli errori, UDMA_CRC_Error_Count gli errori riscontrati dal protocollo di comunicazione dei dati (le possibili cause potrebbero esser il cavo difettoso, possibili interferenze, incompatibilità fra controller-periferiche-driver, ecc...).

Subito sotto la tabella se c'è l'ATA Error Count sono stati rilevati errori nella connessione ATA/IDE.


[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » gio set 11, 2008 10:04 am

[grazie] Ninja sei il migliore in campo Linux e non solo... [;)]

Molto interessante questo comando. Secondo il protocollo Smart l'hdd non è messo benissimo, questo a dimostrazione di quanti danni può provocare un arresto improvviso del sistema.

Probabilmente non ne sei a conoscenza, ma all'incirca un anno fa un braccetto dell'hdd con relativa testina sbatte senza motivo (nel senso che non c'erano stati preavvisi di rottura) contro le pareti dell'hdd. Stranamente e per fortuna il controller del disco rigido riuscì a recuperare il s.o senza provocare una possibile perdita di dati.

L'hdd funziona tutt'ora, ma come puoi vedere, le conseguenze di quell'incidente iniziano a saltare fuori.

Posto i risultati dell'hdd Western Digital C 186gb:

jonny@jonny-desktop:~$ sudo smartctl -ia /dev/sdb
smartctl version 5.37 [i686-pc-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Model Family: Western Digital Caviar SE family
Device Model: WDC WD2000JB-00REA0
Serial Number: WD-WMANK4672687
Firmware Version: 20.00K20
User Capacity: 200,049,647,616 bytes
Device is: In smartctl database [for details use: -P show]
ATA Version is: 7
ATA Standard is: Exact ATA specification draft version not indicated
Local Time is: Thu Sep 11 10:41:08 2008 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x84) Offline data collection activity
was suspended by an interrupting command from host.
Auto Offline Data Collection: Enabled.
Self-test execution status: ( 0) The previous self-test routine completed
without error or no self-test has ever
been run.
Total time to complete Offline
data collection: (6300) seconds.
Offline data collection
capabilities: (0x7b) SMART execute Offline immediate.
Auto Offline data collection on/off support.
Suspend Offline collection upon new
command.
Offline surface scan supported.
Self-test supported.
Conveyance Self-test supported.
Selective Self-test supported.
SMART capabilities: (0x0003) Saves SMART data before entering
power-saving mode.
Supports SMART auto save timer.
Error logging capability: (0x01) Error logging supported.
General Purpose Logging supported.
Short self-test routine
recommended polling time: ( 2) minutes.
Extended self-test routine
recommended polling time: ( 74) minutes.
Conveyance self-test routine
recommended polling time: ( 6) minutes.

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x000f 200 200 051 Pre-fail Always - 0
3 Spin_Up_Time 0x0003 187 183 021 Pre-fail Always - 5616
4 Start_Stop_Count 0x0032 099 099 000 Old_age Always - 1199
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
7 Seek_Error_Rate 0x000f 200 200 051 Pre-fail Always - 0
9 Power_On_Hours 0x0032 095 095 000 Old_age Always - 4021
10 Spin_Retry_Count 0x0013 100 100 051 Pre-fail Always - 0
11 Calibration_Retry_Count 0x0012 100 100 051 Old_age Always - 0
12 Power_Cycle_Count 0x0032 099 099 000 Old_age Always - 1192
194 Temperature_Celsius 0x0022 110 082 000 Old_age Always - 40
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0012 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0010 200 200 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x003e 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0009 200 200 051 Pre-fail Offline - 0

SMART Error Log Version: 1
No Errors Logged

SMART Self-test log structure revision number 1
Num Test_Description Status Remaining LifeTime(hours) LBA_of_first_error
# 1 Extended offline Aborted by host 90% 3362 -
# 2 Short offline Completed without error 00% 2724 -
# 3 Short offline Completed without error 00% 2022 -
# 4 Short offline Completed without error 00% 237 -

SMART Selective self-test log data structure revision number 1
SPAN MIN_LBA MAX_LBA CURRENT_TEST_STATUS
1 0 0 Not_testing
2 0 0 Not_testing
3 0 0 Not_testing
4 0 0 Not_testing
5 0 0 Not_testing
Selective self-test flags (0x0):
After scanning selected spans, do NOT read-scan remainder of disk.
If Selective self-test is pending on power-up, resume after 0 minute delay.
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » gio set 11, 2008 10:07 pm

Ciao.

jordan air ha scritto:...
Molto interessante questo comando. Secondo il protocollo Smart l'hdd non è messo benissimo, questo a dimostrazione di quanti danni può provocare un arresto improvviso del sistema.
...

jonny@jonny-desktop:~$ sudo smartctl -ia /dev/sdb
smartctl version 5.37 [i686-pc-linux-gnu] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Model Family: Western Digital Caviar SE family
Device Model: WDC WD2000JB-00REA0
Serial Number: WD-WMANK4672687
Firmware Version: 20.00K20
User Capacity: 200,049,647,616 bytes
Device is: In smartctl database [for details use: -P show]
ATA Version is: 7
ATA Standard is: Exact ATA specification draft version not indicated
Local Time is: Thu Sep 11 10:41:08 2008 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

.......

=== START OF READ SMART DATA SECTION ===

SMART Attributes Data Structure revision number: 16
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME FLAG VALUE WORST THRESH TYPE UPDATED WHEN_FAILED RAW_VALUE
1 Raw_Read_Error_Rate 0x000f 200 200 051 Pre-fail Always - 0
3 Spin_Up_Time 0x0003 187 183 021 Pre-fail Always - 5616
4 Start_Stop_Count 0x0032 099 099 000 Old_age Always - 1199
5 Reallocated_Sector_Ct 0x0033 200 200 140 Pre-fail Always - 0
7 Seek_Error_Rate 0x000f 200 200 051 Pre-fail Always - 0
9 Power_On_Hours 0x0032 095 095 000 Old_age Always - 4021
10 Spin_Retry_Count 0x0013 100 100 051 Pre-fail Always - 0
11 Calibration_Retry_Count 0x0012 100 100 051 Old_age Always - 0
12 Power_Cycle_Count 0x0032 099 099 000 Old_age Always - 1192
194 Temperature_Celsius 0x0022 110 082 000 Old_age Always - 40
196 Reallocated_Event_Count 0x0032 200 200 000 Old_age Always - 0
197 Current_Pending_Sector 0x0012 200 200 000 Old_age Always - 0
198 Offline_Uncorrectable 0x0010 200 200 000 Old_age Offline - 0
199 UDMA_CRC_Error_Count 0x003e 200 200 000 Old_age Always - 0
200 Multi_Zone_Error_Rate 0x0009 200 200 051 Pre-fail Offline - 0

SMART Error Log Version: 1
No Errors Logged
...


Questo disco, il 2° visto che è sdb, non è messo poi così male, anzi non sono stati riscontrati errori e la temperatura è di 40°C, non male....
... penso che i rallentamenti potrebbero essere causati da qualcos'altro, apri un terminale e digita:

Codice: Seleziona tutto
tail  -f /var/log/messages


Ti verranno visualizzati tutti i messaggi di sistema, dai messaggi di un'eventuale connessione ppp al riconoscimento di un disco esterno Usb o della stampante, eventuali errori riscontrati, inclusi quelli di lettura/scrittura sui dispositivi quali unità cd/dvd-rom o dischi fissi...
...chissà, magari potresti accorgerti che è sda a provocarti problemi e non sdb

[ciao]

P.S.: per uscire dal comando tail premi Ctrl+C oppure chiudi il terminale.
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » gio set 11, 2008 10:26 pm

ninjabionico ha scritto:Ciao.
Questo disco, il 2° visto che è sdb, non è messo poi così male, anzi non sono stati riscontrati errori e la temperatura è di 40°C, non male....


La temperatura è perfetta, ne troppo alta ne troppo bassa.

Ecco i risultati del comando:
Codice: Seleziona tutto
 tal   -f /var/log/messages


jonny@jonny-desktop:~$ tail -f /var/log/messages
Sep 11 21:47:30 jonny-desktop kernel: [ 58.161731] agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
Sep 11 21:47:30 jonny-desktop kernel: [ 58.162720] agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
Sep 11 21:47:34 jonny-desktop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_domain
Sep 11 21:47:34 jonny-desktop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_servers
Sep 11 21:47:34 jonny-desktop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.interface_mtu
Sep 11 22:07:22 jonny-desktop -- MARK --
Sep 11 22:27:22 jonny-desktop -- MARK --
Sep 11 22:46:14 jonny-desktop pulseaudio[6844]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 11 22:46:14 jonny-desktop pulseaudio[6844]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 11 23:07:22 jonny-desktop -- MARK --


Dai risultati emessi, non sembra esserci nessun errore riconducibile ad un supporto magnetico.

Ora che ci penso, il primo hdd (sda) è collegato alla scheda madre tramite una scheda pci sato/ide. L'hdd è collegato tramite connessione sata. Secondo te potrebbe essere la causa del problema?
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » sab set 13, 2008 3:35 am

Ciao.

jordan air ha scritto:Ecco i risultati del comando:
Codice: Seleziona tutto
 tal   -f /var/log/messages


jonny@jonny-desktop:~$ tail -f /var/log/messages
Sep 11 21:47:30 jonny-desktop kernel: [ 58.161731] agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
Sep 11 21:47:30 jonny-desktop kernel: [ 58.162720] agpgart: Putting AGP V3 device at 0000:01:00.0 into 8x mode
Sep 11 21:47:34 jonny-desktop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_domain
Sep 11 21:47:34 jonny-desktop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.nis_servers
Sep 11 21:47:34 jonny-desktop dhcdbd: message_handler: message handler not found under /com/redhat/dhcp/eth0 for sub-path eth0.dbus.get.interface_mtu
Sep 11 22:07:22 jonny-desktop -- MARK --
Sep 11 22:27:22 jonny-desktop -- MARK --
Sep 11 22:46:14 jonny-desktop pulseaudio[6844]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 11 22:46:14 jonny-desktop pulseaudio[6844]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Sep 11 23:07:22 jonny-desktop -- MARK --


Dai risultati emessi, non sembra esserci nessun errore riconducibile ad un supporto magnetico.

Ora che ci penso, il primo hdd (sda) è collegato alla scheda madre tramite una scheda pci sato/ide. L'hdd è collegato tramite connessione sata. Secondo te potrebbe essere la causa del problema?


Questi messaggi sono quelli che sono presenti quando il sistema rallenta?

A parte dei messaggi di errore che si riferiscono alla scheda di rete (eth0) e il mancato supporto alla frequenza di 44,1 KHz della scheda audio (che utilizzerà quindi 48 KHz), non vedo nient'altro di anomalo...

... prova semmai a impostare manualmente o disabilitare (nel caso in cui non la usi) la scheda di rete.

Da quello che so sul Sata, se il disco è Sata 2 e il controller è Sata 1, potrebbero esserci dei conflitti (a volte capita), controlla e nel caso in cui sia così puoi forzare il disco al funzionamento Sata 1 con un ponticello dedicato (lo trovi nella documentazione del produttore se non lo vedi segnalato sulle etichette del disco).


[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » sab set 13, 2008 9:57 pm

ninjabionico ha scritto:Questi messaggi sono quelli che sono presenti quando il sistema rallenta?

Da quello che so sul Sata, se il disco è Sata 2 e il controller è Sata 1, potrebbero esserci dei conflitti (a volte capita), controlla e nel caso in cui sia così puoi forzare il disco al funzionamento Sata 1 con un ponticello dedicato (lo trovi nella documentazione del produttore se non lo vedi segnalato sulle etichette del disco).
[ciao]


No, questi messaggi sono venuti fuori con il sistema perfettamente funzionante.

Ora che ci penso, credo che tu abbia ragione. Il controller che utilizzo ha un'interfaccia sata, mentre l'hdd(sda) è sata 2. Cercherò di documentarmi sulla storia del ponticello.

P.s: Pochi minuti fa il s.o è andato in totale crash senza che stessi facendo nulla. Anzi per l'esattezza stavo scorrendo questa pagina per visualizzare il nuovo messaggio. [ciao]
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Re: Blocco sistema operativo

Messaggioda ninjabionico » dom set 14, 2008 6:19 pm

Altre possibili cause dei freeze del sistema, potrebbero ricercarsi nelle temperature del processore o della gpu (scheda video)....
... hai tenuto sotto controllato le temperature ultimamente...

... http://wiki.ubuntu-it.org/LmSensors potrebbe tornarti utile.

[ciao]
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Re: Blocco sistema operativo

Messaggioda jordan air » dom set 14, 2008 6:43 pm

ninjabionico ha scritto:Altre possibili cause dei freeze del sistema, potrebbero ricercarsi nelle temperature del processore o della gpu (scheda video)....
... hai tenuto sotto controllato le temperature ultimamente...
[ciao]


Le temperature sono assolutamente normali. Anzi, presto presenterò il mio case adeguatamente moddato... [;)]

Per tornare in tema, le temperature e gli rpm delle fan le tengo sotto controllo con la procedura segnalata da te,
My pc: Intel core i5 750; Corsair 2gb DDR3 pc-12600; Ati 6790 (1gb); Asus P7H55 - V; Antec True Power 650W; WD 465gb 16mb-Samsung 186gb; CM 690
Avatar utente
jordan air
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3155
Iscritto il: sab feb 03, 2007 1:26 pm
Località: Milano

Prossimo

Torna a Distribuzioni, Kernel e Software Applicativo

Chi c’è in linea

Visitano il forum: Bing [Bot] e 1 ospite

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising