Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

EeePCLinuxOS --- Mandriva 2008.1 spring --- Huawei E220 WIND

Non trovi il driver per il tuo modem? Non riesci ad installare la nuova scheda video? Ti aiutiamo noi, questo è il posto giusto!
Per problemi legati strettamente all'Hardware utilizzate "Hardware, Modding & Overclock"

EeePCLinuxOS --- Mandriva 2008.1 spring --- Huawei E220 WIND

Messaggioda silvioslim » mer mag 21, 2008 11:36 am

Buongiorno ragazzi...intabnto mi presento sono silvio e sono nuovo del forum. Chiedo il vostro aiuto per un grande problema.
Ho installato il PCLinuxOS ottimizzato per EeePC dell'asus...ho installato tutti i driver del MODEM Huawei E220...le impostazioni del Provider e del MODEM sono esatte e le ho configurate con KPPP.
Provo la connessione..."Avvio del Modem" "Composizione *99#"...fa i suoi passaggi preliminari sino ad arrivare all'ultimo passaggio "Loggon Internet" (o qualcosa del genere...praticamente la proiezione del computer sulla rete) e mi da il messaggio di errore EXIT STATUS:16 (che a quanto ho capito sarebbe il modem che chiude la chiamata "HangUp").
Ho visto che una ragazza ha avuto lo stesso problema però con Kubuntu usando unm cellulare NOKIA.
Assodato che i miei driver siano OK e che le impostazioni siano corrette....cosa mi consigliate di fare???
Cosa controllereste???
Quali sono i parametri che inserireste voi???
Qualche comando di Shell particolare???
Grazie in anticipo ragazzi
Ultima modifica di silvioslim il ven mag 23, 2008 12:14 pm, modificato 1 volta in totale.
Avatar utente
silvioslim
Neo Iscritto
Neo Iscritto
 
Messaggi: 6
Iscritto il: mer mag 21, 2008 11:25 am

Messaggioda ninjabionico » mer mag 21, 2008 10:04 pm

Ciao.

I parametri da inserire dipendono anche dal gestore telefonico con cui ti connetti.

Controlla che l'APN sia quello corretto, così come eventuali username e password.

Ciao.
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Messaggioda silvioslim » mer mag 21, 2008 11:43 pm

ninjabionico ha scritto:Ciao.

I parametri da inserire dipendono anche dal gestore telefonico con cui ti connetti.

Controlla che l'APN sia quello corretto, così come eventuali username e password.

Ciao.



Lavoro in wind [:)] e prima ancora alla tim [std] e di connessioni ne facevo tante...in Windows [crylol]
bhe premessa a parte ti assicuro che i parametri sono corretti...non è un problema di configurazione...secodno me c'è qualche problema con i driver...oppure qualche comando di console che possa risolvere...perché alla fine di tutta la connessione (ti ricordo che si blocca alla fine quando deve proiettare il computer in rete...quindi passa la chiamata al *99# e tutto il resto...e poi l'errore che da exit status:16 risulta come "hang up" das parte del modem)
Avatar utente
silvioslim
Neo Iscritto
Neo Iscritto
 
Messaggi: 6
Iscritto il: mer mag 21, 2008 11:25 am


Messaggioda ninjabionico » gio mag 22, 2008 5:03 pm

Con cosa hai configurato la connessione, con che comando/tool?
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Messaggioda silvioslim » gio mag 22, 2008 6:01 pm

ninjabionico ha scritto:Con cosa hai configurato la connessione, con che comando/tool?


Se non sbaglio si chiama KPPP il programma
Avatar utente
silvioslim
Neo Iscritto
Neo Iscritto
 
Messaggi: 6
Iscritto il: mer mag 21, 2008 11:25 am

Messaggioda ninjabionico » gio mag 22, 2008 7:51 pm

Prova a editare il file /etc/wvdial.conf con i permessi di amministrazione e inserirci:

Codice: Seleziona tutto
[Dialer Default]
Modem = /dev/ttyUSB0
ISDN = off
Modem Type = Analog
Baud = 460800
Init2 = ATZ
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init4 = AT+CGDCONT=1,”IP”,"{APN fornito dal gestore}"
Phone = *99#
Dial Command = ATDT
Dial Attempts = 1
Ask Password = off
Username = {nome_gestore}
Password = {nome_gestore}
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = on
Idle Seconds = 0
Auto DNS = on


I numeri per la chiamata da inserire sono:
- Tre e TIM: Phone = *99#
- Vodafone e Wind: Phone = *99***1#

Il comando AT per specificare l'APN è:

- Tre: AT+CGDCONT=1,"IP"," apn.tre.it"
- TIM: AT+CGDCONT=1,"IP","ibox.tim.it","",0,0
- Vodafone: AT+CGDCONT=1,"IP","web.omnitel.it"
- Wind: AT+CGDCONT=1,"IP","internet.wind"

Salva il file e poi da terminale digita:

Codice: Seleziona tutto
wvdial


Fammi sapere.

[ciao]

P.S.: Dò per scontato che il kernel abbia caricato il modulo del modem e che lo abbia riconosciuto correttamente...
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd

Messaggioda silvioslim » ven mag 23, 2008 8:04 am

ninjabionico ha scritto:Prova a editare il file /etc/wvdial.conf con i permessi di amministrazione.........

Fammi sapere.

[ciao]

P.S.: Dò per scontato che il kernel abbia caricato il modulo del modem e che lo abbia riconosciuto correttamente...


Si ho installato i driver e riconosce tranquillamente il modem .... e finora è stata una delle poche distro.
Comunque adesso provo e ti faccio sapere.
Il wdial.conf non esiste su PCLinuxOS e nemmeno su Mandriva 2008.1

P.S. Visto che ci siamo ti pongo un quesito (non credo sia il caso di aprire un altro topic).
Ho installato anche il Mandriva 2008 one spring che già monta i driver della Huawei.
Succede questo che in fase di installazione del sistema operativo, riconosce il modem dopo qualche minuto e mi fa creare la connessione per testare la connettività per internet.
Mi autoconfigura lui i parametri per WIND (APN internet.wind.it ....bho) e mi da l'esito positivo...insomma funziona.
Sarei felicissimo se non fosse che all'avvio del sistema operativo...il modem passa da uno status all'altro...ovvero da CD-Drive (Led Verde che lampeggia) a Modem (Led Blu che lampeggia) e contnua così fino allo spegnimento automatico...come per errore.
Pertanto il sistema rileva a momenti il modem...io credo che il problema risieda nell'auto boot come drive cd.
Ovviamente se provo la connessione NON funziona perché il tempo che il modem lampeggia BLU è poco e non riesce a fare il dialing per la connessione e subita diventa verde...sto impazzendoooooooooooooooo
[crylol]


EDIT2 Ho trovato questo topin in inglese che parla di un pacchetto di installlazione (ove guarda caso all'interno è presente il file wvdial.conf) per la huawei E220 sia per mandriva che per PCLinuxOS LINK=> http://forum.eeeuser.com/viewtopic.php?id=24809
Mentre il pacchetto lo si può trovare da questo sempre in inglese LINK=> http://mustakim.blogster.com/huawei-e22 ... -for-linux ......che spiega anche come installarlo...ed è quello il problema non ci riescoooooo....potete dargli un'occhiata raga???? grazie mille
Avatar utente
silvioslim
Neo Iscritto
Neo Iscritto
 
Messaggi: 6
Iscritto il: mer mag 21, 2008 11:25 am

Messaggioda ninjabionico » ven mag 23, 2008 6:46 pm

silvioslim ha scritto:...
Il wdial.conf non esiste su PCLinuxOS e nemmeno su Mandriva 2008.1
...


Se manca wvdial semplicemente installalo.

Su Ubuntu c'è di default, provala.

[ciao]

P.S.: http://en.wikipedia.org/wiki/Huawei_E220
Io dico le cose così come stanno! Questo è il mio credo ninja - by Naruto Uzumaki
Expert-Advanced User Powered by Gnu/Linux
Avatar utente
ninjabionico
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5207
Iscritto il: lun mar 20, 2006 10:51 pm
Località: Prov. Pd


Torna a Driver, Riconoscimento e Gestione Periferiche

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising