Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Problema con xampp

Cerchi consigli per migliorare il tuo sito? Vuoi aprire un sito in poco tempo?
Discuti con altri webmaster, chiedi chiarimenti ed opinioni in tutta libertà.
Lo spam verrà cancellato.

Problema con xampp

Messaggioda artimo » dom dic 30, 2007 3:19 pm

Ho formattato dopo aver fatto il salvataggio fotocopia dei dati, ma ho recuperato solo alcuni programmi . Con altri programmi nessun problema ma con xampp il disastro. Il semaforo del Mysql rimane rosso e xampp si conntte a volte sì a volte no con Apache ma Mysql non si connette mai. Provando ad andare su phpmyadmin mi dice Problemi di connessione errore 2003. Forse non tutti i dati che usa xampp sono nella sua cartella? E se no quali altri dati o collegamenti devo reinstallare ?
Avatar utente
artimo
Neo Iscritto
Neo Iscritto
 
Messaggi: 13
Iscritto il: gio giu 07, 2007 12:01 am

Messaggioda eDog » dom dic 30, 2007 4:00 pm

Sarà sicuramente cambiato qualcosa nelle impostazioni. Riconfigura tutto avviando il file setup_xampp.bat che si trova nella cartella di xampp.


E' successo anche a me, ed ho fatto così
eDog,
"È meglio essere temuti o rispettati? Io dico: è troppo chiedere entrambe le cose?" - Tony Stark
Avatar utente
eDog
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3679
Iscritto il: sab dic 30, 2006 7:58 pm
Località: Vescovana (Padova)

Messaggioda artimo » dom dic 30, 2007 7:33 pm

Ho provato con il file setup_xampp.batch MS-DOS ma mi risponde Sorry but...nothing to do. Ho provato con il file mysql_start. batch MS-DOS e si connette normalmente. Ma il semaforo rimane sempre rosso. Se installo nuovamente il programma da zero perdo i dati nella cartella htdocs ? Altrimenti cosa devo fare ?
Avatar utente
artimo
Neo Iscritto
Neo Iscritto
 
Messaggi: 13
Iscritto il: gio giu 07, 2007 12:01 am


Non parte Apache

Messaggioda artimo » dom dic 30, 2007 11:33 pm

Ho reinstallato il programma e aesso il semaforo è verde ma non parte Apache. eseguendo da apache_installservice file batch in MS_DOS mi dice :
errore di sistema 3 impossibile trovare il percorso specificato. Che fare ?
Avatar utente
artimo
Neo Iscritto
Neo Iscritto
 
Messaggi: 13
Iscritto il: gio giu 07, 2007 12:01 am

Messaggioda eDog » mar gen 01, 2008 10:33 am

Scusami per il ritardo, ma da un po' di giorni perdo la notifica dei nuovi messaggi qui, sul forum.


Dunque, nel sistema che avevi prima di formattare, xampp era in una cartella diversa da dove è ora?
eDog,
"È meglio essere temuti o rispettati? Io dico: è troppo chiedere entrambe le cose?" - Tony Stark
Avatar utente
eDog
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3679
Iscritto il: sab dic 30, 2006 7:58 pm
Località: Vescovana (Padova)

Risolto parzialmente

Messaggioda artimo » mar gen 01, 2008 11:39 am

Grazie. Ho risolto parzialmente. Cioè ho reinstallato il programma vergine su C (mentre prima era in C/programmi) e poi ho sovrascritto la cartella htdocs. Sembra funzionare tutto e vedo anche i miei lavori. Ora però se cerco di eliminare la cartella in C/programmi non me la fa eliminare perché dice che è in uso. Non riesco a capire se sono solo dei collegamenti oppure è quella in C/programmi che è in uso. Dici di lasciarli tutti e due e non pensarci ? Buon anno!
Avatar utente
artimo
Neo Iscritto
Neo Iscritto
 
Messaggi: 13
Iscritto il: gio giu 07, 2007 12:01 am

Messaggioda eDog » mar gen 01, 2008 11:46 am

Guarda, bastava modificare il percorso dov'era installato xampp su un file, ovvero il php.ini in apache/bin inserendo la nuova cartella...

Se non ti lascia cancellare la cartella, "stoppa" Apache e MySQL di C:\Programmi e poi cancella...
eDog,
"È meglio essere temuti o rispettati? Io dico: è troppo chiedere entrambe le cose?" - Tony Stark
Avatar utente
eDog
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3679
Iscritto il: sab dic 30, 2006 7:58 pm
Località: Vescovana (Padova)


Torna a Sviluppo Web

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising