Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Boot con Vista

Problemi con i sistemi operativi di casa Microsoft? Questa è la sezione che fa per te!

Boot con Vista

Messaggioda andrea677 » lun dic 03, 2007 3:30 pm

Ho un problema da sottoporvi, uscito dopo l'installazione di Vista in una nuova partizione del disco.

La situazione di partenza era:
C: partizione di 10 GB con XP aziendale
D: partizione di 30 GB con XP privato
E: partizione di 40 GB libera,formattata

Il file Boot.ini era così strutturato:

default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional"
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional Azienda"

Quindi all'accensione partiva il boot di sistema con la possibilità di scegliere di partire con Xp aziendale oppure Xp privato.

A questo punto sulla partizione libera E: ho installato windows Vista.
Dopo i vari riavvii dovuti all'installazione, ora mi ritrovo una prima pagina di boot dove chiede se partire con Vista (se seleziono questa ovviamente parte Vista) oppure partire con la vecchia configurazione windows:se seleziono questa si presenta una seconda pagina di boot, quella che avevo originariamente, cioè scelta tra Xp aziendale o Xp privato.

Vorrei avere un'unica pagina di boot iniziale dove scegliere tra i 3 sistemi operativi, ma anche strutturando così il Boot.ini, non va:

default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional"
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional Azienda"
multi(0)disk(0)rdisk(0)partition(3)\WINDOWS="Microsoft Windows Vista"

Qualcuna ha una soluzione ?



Seconda domanda.
Partendo con Windows Vista e andando nella gestione dischi, noto che Vista risulta sulla partizione C: da 40 GB anzichè come partizione E: (la terza) su cui avevo fatto l'installazione.
Stranamente avviando da Xp invece, la partizione da 40 GB risulta chiamata correttamente E: Vorrei se possibile, per congruenza, che si mantenessero gli stessi riferimenti e che quindi anche accedendo con Vista al PC questo risultasse sulla partizione E:

Ho provato a cambiare lettera all'unità, ma non me lo permette.
Avete qualche idea ?




Grazie, Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda crazy.cat » lun dic 03, 2007 4:17 pm

Prova con easybcd se riesci a sistemare il boot loader.

(mi sembra tanto un installazione non andata correttamente)
Quando i molti governano, pensano solo a contentar sé stessi, si ha allora la tirannia più balorda e più odiosa: la tirannia mascherata da libertà.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Messaggioda ste_95 » lun dic 03, 2007 5:02 pm

Purtroppo è normale, quando installi Vista, comanda il suo bootloader, e quello di Xp diventa inutile, quindi come hai sperimentato anche modificandolo la struttura del bootloader non cambia in presenza di Vista. dunque devi usare software come Vista Boot Pro 3.3 per aggiungere delle voci all'avvio o modificarle...

Per la seconda domanda, ti sconsiglio vivamente di cambiare la lettera alla partizione, poiché tutti i riferimenti ai programmi e del sistema operativo si perderebbero e quindi saresti quasi impossibilitato ad accendere il computer...(Ne so qualcosa) [:D] Comunque, si vedono le letetre diverse perché ogni sistema ha la sua configurazione e solitamente viene configurato come unità primaria (C:\) l'installazione del sistema, a meno di rari casi specifici all'installazione...

Spero di essere stato esauriente nella spiegazione, se hai dubbi, chiedi [^]
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am


Messaggioda andrea677 » mar dic 04, 2007 9:22 am

Grazie a tutti per le risposte.
Ho trovato anche un programmino chiamato "Easybcd" : esegue le stesse operazioni sul bootloader ? Suppongo di si. Meglio questo o il citato Vista Boot Pro ?
Va installato sotto Vista o sotto Xp aziendale che è la partizione primaria ?

Ciao, Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda ste_95 » mar dic 04, 2007 3:14 pm

Sono analoghi, consigliavo Vista Boot rpo, perché possiede un'interfacci più intuitiva...ma li puoi usare entrambi...

Lo devi installare o in XP o in vista [^]
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am

Messaggioda andrea677 » gio dic 06, 2007 6:20 pm

Ho installato sia Vista Boot Pro, sia Easybcd per provare.
Chiedevo solo una conferma: nella situazione iniziale in cui erano installati solo i 2 sistemi XP, il file Boot.ini è unico per entrambi e si trova sotto C:

Ora installando Vista e gestendo il Bootloader con i programmi sopra citati, in ogni caso mi compaiono 2 finestre di Boot per scegliere con quale sistema partire: la prima scelta è tra Vista o i vecchi sistemi esistenti, la seconda scelta tra Xp aziendale o Xp privato (come era in precedenza).

Non credo che si riesca a creare una sola finestra di Boot con le 3 voci: Vista, Xp aziendale, Xp privato perché esiste il boot.ini sotto C: ma non esiste un'altro boot.ini sotto D:

Confermate ?

Grazie, Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda ste_95 » gio dic 06, 2007 6:25 pm

Con Vista Boot Pro si riesce sicuramente nel tuo intento...Spiegheresti dove ti blocchi?
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am

Messaggioda andrea677 » sab dic 08, 2007 11:49 am

Praticamente vado a compilare il bootloader associando Xp aziendale alla partizione C: , Xp privato alla partizione D: , Vista alla partizione E:

Il risultato è che nella prima finestra di boot mi appaiono le 3 voci:
Vista parte regolarmente,
se lancio Xp aziendale (legge il boot.ini sotto C:) e mi appare la seconda finestra di boot,
se lancio Xp privato non trova alcun sistema operativo da far partire e non trova alcun file boot.ini

Non capisco come possa ovviare.

Ciao, Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda ste_95 » lun dic 10, 2007 3:24 pm

Domanda banale: Ovviamente salvi le modifiche...?

Puoi postare il codice del bootloader che trovi nella prima pagina di Vista Boot Pro?
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am

Messaggioda andrea677 » lun dic 10, 2007 5:52 pm

Ecco la videata sintetica, in effetti in corrispondenza di BCD ID della partizione D: manca il file ntldr, ed infatti facendo partire il boot da D: dice "file ntldr non trovato"






There is currently 3 OS(s) installed on your system.
The current boot timeout is: 3

Default OS: Microsoft Windows XP Pro Azienda

Entry 1
----------------------------------------------------------------------------
Name: Microsoft Windows Vista
BCD ID: {965fc9dc-a0cb-11dc-9874-db16a4528215}
Boot Drive: E:
Windows Drive: E:
System Bootloader: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry 2
----------------------------------------------------------------------------
Name: Microsoft Windows XP Pro Azienda
BCD ID: {ntldr}
Boot Drive: C:
System Bootloader: \ntldr

Entry 3
----------------------------------------------------------------------------
Name: Microsoft Windows XP Pro Privato
BCD ID: {89bf0f3b-a35a-11dc-a2d5-0014381b5bbe}
Boot Drive: D:
System Bootloader: \ntldr
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda andrea677 » mer dic 12, 2007 3:28 pm

Per Ste_95, ti ho postato la pagina riassuntiva di Vista Boot Pro

Ciao, Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda ste_95 » mer dic 12, 2007 3:45 pm

Scusa il ritardo nella rirposta, mi era sfuggito il thread [acc2]

Non avendo sottomano VistaBootPro nno ti posso dire nulla di preciso, ma non c'è modo di impostare un diverso ID?
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am

Messaggioda andrea677 » mer dic 12, 2007 6:10 pm

Ho provato a riguardare, ma non sembra esserci modo di cambiare questo ID, anche su EasyBcd non trovo alcun menu dove andare a variarlo.

Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda ste_95 » mer dic 12, 2007 6:39 pm

Hai provato a eliminare la voce e poi a ricrearla?
«A volte è meglio tacere e sembrare stupidi che aprir bocca e togliere ogni dubbio.» Oscar Wilde
Avatar utente
ste_95
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 17271
Iscritto il: lun ago 06, 2007 11:19 am

Messaggioda andrea677 » sab dic 15, 2007 10:05 am

Provato anche quello, senza risultati.
E copiando i file:
- boot.ini
- ntldr
- ntdetect.com
da C: a D: può servire a qualcosa ?
Il disco era strutturato in modo che la partizione primaria è C: e qui sono presenti tutti i file suddetti. Poi è stata creata la partizione logica D: e non so se qui ci sono quei file che servono per l'avvio.

Ciao, Andrea
Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm

Messaggioda andrea677 » mar dic 18, 2007 9:47 am

Avatar utente
andrea677
Senior Member
Senior Member
 
Messaggi: 386
Iscritto il: ven lug 06, 2007 6:59 pm


Torna a Sistema Operativo

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising