Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Parse error: syntax error, unexpected T_STRING

Il forum per tutti i developer. Leggere attentamente il regolamento di sezione prima di postare.

Parse error: syntax error, unexpected T_STRING

Messaggioda Flanagan77 » mer ott 31, 2007 11:32 am

Salve a tutti. Sono un super novellino che sta cercando di mettere su un minuscolo sito internet e che dopo aver uploadato tutto si ritrova con questo messaggio:

Parse error: syntax error, unexpected T_STRING in ***************/index.html on line 1

il codice è il seguente:

Codice: Seleziona tutto
<?xml version="1.0" encoding="UTF-8" ?>
  <!DOCTYPE html (View Source for full doctype...)>
- <html xmlns="http://www.w3.org/1999/xhtml">
- <head>
  <title />
  <meta http-equiv="refresh" content="0;url= Sito/principale.html" />
  </head>
  <body />
  </html>


dove sto sbagliando?

Vi ringrazio per l'attenzione e mi scuso se non ho postato nella sezione giusta.
Avatar utente
Flanagan77
Neo Iscritto
Neo Iscritto
 
Messaggi: 3
Iscritto il: mer ott 31, 2007 11:22 am

Messaggioda manu187 » ven nov 02, 2007 8:17 pm

hai messo <title\> se non sbaglio dovevi chiudere <title> questo non c'è <body/> che cosa chiude forse anche il fatto degli spazii es <head / >, però sono poco pratico nell'HTML so solo il C++ e un po' di java e di javascipt
Avatar utente
manu187
Senior Member
Senior Member
 
Messaggi: 181
Iscritto il: dom ott 28, 2007 8:06 pm

Messaggioda Flanagan77 » sab nov 03, 2007 2:44 am

ho postato male, il codice del mio index.html è il seguente:

Codice: Seleziona tutto
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<title></title>
<meta http-equiv="refresh" content="0;url= Sito/principale.html" />
</head>
<body>
</body>
</html>


scusate e vi prego aiutatemi perché non capisco dove sbaglio e perché l'errore sta sulla prima linea??? boh...
Avatar utente
Flanagan77
Neo Iscritto
Neo Iscritto
 
Messaggi: 3
Iscritto il: mer ott 31, 2007 11:22 am

Messaggioda eDog » sab nov 03, 2007 10:40 am

Scusa, ma perché mettere una istruzione xml (del quale capisco poco... [bleh] ) per codificare una pagina in utf-8 dato che poi quella pagina è un semplice redirect?

Puoi fare a meno di quella linea di codice...
eDog,
"È meglio essere temuti o rispettati? Io dico: è troppo chiedere entrambe le cose?" - Tony Stark
Avatar utente
eDog
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3679
Iscritto il: sab dic 30, 2006 7:58 pm
Località: Vescovana (Padova)

Messaggioda Flanagan77 » sab nov 03, 2007 9:23 pm

se tolgo quella linea di codice comunque non va... ma perché mi dice errore se è scritta correttamente?
Avatar utente
Flanagan77
Neo Iscritto
Neo Iscritto
 
Messaggi: 3
Iscritto il: mer ott 31, 2007 11:22 am


Torna a Programmazione

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

cron
Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising