Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

eciadsl su ubuntu 7.04

Non trovi il driver per il tuo modem? Non riesci ad installare la nuova scheda video? Ti aiutiamo noi, questo è il posto giusto!
Per problemi legati strettamente all'Hardware utilizzate "Hardware, Modding & Overclock"

eciadsl su ubuntu 7.04

Messaggioda ...Simo... » ven lug 13, 2007 1:57 pm

Mi piacerebbe avere una connessione ad internet su ubuntu, purtroppo il modem di alice l'ho connesso al computer via usb perché ho perso il cavo di rete.

Seguendo le istruzioni su MegaLab.it ho provato a mettere i driver eciadsl con esito negativo.. fatta una ricerchina ho visto che i driver che avevo scaricato non erano compatibili con il kernel di ubuntu 7.04...

Altra ricerchina e sono finito su questo sito:

h__p://maipaura.wordpress.com/2007/03/06/feisty-ed-eciadsl/

scaricati i nuovi driver, passato a ubuntu, da terminale dentro la cartella dei driver, ho scritto:

./configure

e mi è venuto questo errore:
checking for c compiler default output file name... configure:error: C compiler cannot create executable
See `config.log' for more details

questo è quello che riporta config.log:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by eciadsl-usermode configure 0.11, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure

## --------- ##
## Platform. ##
## --------- ##

hostname = simo-desktop
uname -m = i686
uname -r = 2.6.20-15-generic
uname -s = Linux
uname -v = #2 SMP Sun Apr 15 07:36:31 UTC 2007

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/sbin
PATH: /usr/local/bin
PATH: /usr/sbin
PATH: /usr/bin
PATH: /sbin
PATH: /bin
PATH: /usr/games


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1352: checking for a BSD-compatible install
configure:1407: result: /usr/bin/install -c
configure:1418: checking whether build environment is sane
configure:1461: result: yes
configure:1526: checking for gawk
configure:1555: result: no
configure:1526: checking for mawk
configure:1542: found /usr/bin/mawk
configure:1552: result: mawk
configure:1562: checking whether make sets $(MAKE)
configure:1582: result: yes
configure:1803: checking for gcc
configure:1819: found /usr/bin/gcc
configure:1829: result: gcc
configure:2073: checking for C compiler version
configure:2076: gcc --version </dev/null >&5
gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
Copyright (C) 2006 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2079: $? = 0
configure:2081: gcc -v </dev/null >&5
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
configure:2084: $? = 0
configure:2086: gcc -V </dev/null >&5
gcc: '-V' option must have argument
configure:2089: $? = 1
configure:2112: checking for C compiler default output file name
configure:2115: gcc conftest.c >&5
/usr/bin/ld: crt1.o: No such file: No such file or directory
collect2: ld returned 1 exit status
configure:2118: $? = 1
configure: failed program was:
| /* confdefs.h. */
|
| #define PACKAGE_NAME "eciadsl-usermode"
| #define PACKAGE_TARNAME "eciadsl-usermode"
| #define PACKAGE_VERSION "0.11"
| #define PACKAGE_STRING "eciadsl-usermode 0.11"
| #define PACKAGE_BUGREPORT "eci@ml.free.fr"
| #define PACKAGE "eciadsl-usermode"
| #define VERSION "0.11"
| /* end confdefs.h. */
|
| int
| main ()
| {
|
| ;
| return 0;
| }
configure:2157: error: C compiler cannot create executables
See `config.log' for more details.

## ---------------- ##
## Cache variables. ##
## ---------------- ##

ac_cv_env_CC_set=
ac_cv_env_CC_value=
ac_cv_env_CFLAGS_set=
ac_cv_env_CFLAGS_value=
ac_cv_env_CPPFLAGS_set=
ac_cv_env_CPPFLAGS_value=
ac_cv_env_CPP_set=
ac_cv_env_CPP_value=
ac_cv_env_LDFLAGS_set=
ac_cv_env_LDFLAGS_value=
ac_cv_env_build_alias_set=
ac_cv_env_build_alias_value=
ac_cv_env_host_alias_set=
ac_cv_env_host_alias_value=
ac_cv_env_target_alias_set=
ac_cv_env_target_alias_value=
ac_cv_path_install='/usr/bin/install -c'
ac_cv_prog_AWK=mawk
ac_cv_prog_ac_ct_CC=gcc
ac_cv_prog_make_make_set=yes

## ----------------- ##
## Output variables. ##
## ----------------- ##

ACLOCAL='${SHELL} /home/simo/Desktop/eciadsl-usermode-0.11/missing --run aclocal-1.9'
AMDEPBACKSLASH=''
AMDEP_FALSE=''
AMDEP_TRUE=''
AMTAR='${SHELL} /home/simo/Desktop/eciadsl-usermode-0.11/missing --run tar'
AUTOCONF='${SHELL} /home/simo/Desktop/eciadsl-usermode-0.11/missing --run autoconf'
AUTOHEADER='${SHELL} /home/simo/Desktop/eciadsl-usermode-0.11/missing --run autoheader'
AUTOMAKE='${SHELL} /home/simo/Desktop/eciadsl-usermode-0.11/missing --run automake-1.9'
AWK='mawk'
CC='gcc'
CCDEPMODE=''
CFLAGS=''
CPP=''
CPPFLAGS=''
CYGPATH_W='echo'
DEFS=''
DEPDIR=''
ECHO_C=''
ECHO_N='-n'
ECHO_T=''
EGREP=''
EXEEXT=''
INSTALL_DATA='${INSTALL} -m 644'
INSTALL_PROGRAM='${INSTALL}'
INSTALL_SCRIPT='${INSTALL}'
INSTALL_STRIP_PROGRAM='${SHELL} $(install_sh) -c -s'
LDFLAGS=''
LIBOBJS=''
LIBS=''
LN_S=''
LTLIBOBJS=''
MAKEINFO='${SHELL} /home/simo/Desktop/eciadsl-usermode-0.11/missing --run makeinfo'
OBJEXT=''
PACKAGE='eciadsl-usermode'
PACKAGE_BUGREPORT='eci@ml.free.fr'
PACKAGE_NAME='eciadsl-usermode'
PACKAGE_STRING='eciadsl-usermode 0.11'
PACKAGE_TARNAME='eciadsl-usermode'
PACKAGE_VERSION='0.11'
PATH_SEPARATOR=':'
RANLIB=''
SET_MAKE=''
SHELL='/bin/sh'
STRIP=''
VERSION='0.11'
ac_ct_CC='gcc'
ac_ct_RANLIB=''
ac_ct_STRIP=''
am__fastdepCC_FALSE=''
am__fastdepCC_TRUE=''
am__include=''
am__leading_dot='.'
am__quote=''
am__tar='${AMTAR} chof - "$$tardir"'
am__untar='${AMTAR} xf -'
bindir='${exec_prefix}/bin'
build_alias=''
datadir='${prefix}/share'
exec_prefix='NONE'
host_alias=''
includedir='${prefix}/include'
infodir='${prefix}/info'
install_sh='/home/simo/Desktop/eciadsl-usermode-0.11/install-sh'
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='${prefix}/var'
mandir='${prefix}/man'
mkdir_p='mkdir -p --'
oldincludedir='/usr/include'
pppdpath=''
prefix='NONE'
program_transform_name='s,x,x,'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
target_alias=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define PACKAGE "eciadsl-usermode"
#define PACKAGE_BUGREPORT "eci@ml.free.fr"
#define PACKAGE_NAME "eciadsl-usermode"
#define PACKAGE_STRING "eciadsl-usermode 0.11"
#define PACKAGE_TARNAME "eciadsl-usermode"
#define PACKAGE_VERSION "0.11"
#define VERSION "0.11"

configure: exit 77



Ho riprovato con i file scaricati da MegaLab...
Quanedo faccio

./configure

tutto ok

quando faccio

make
make install

mi da errorre dicendo che mancano tutti gli header (stdio.h, ...)...

Consigli?
Avatar utente
...Simo...
Aficionado
Aficionado
 
Messaggi: 127
Iscritto il: lun lug 09, 2007 6:43 pm
Località: Pistoia

Messaggioda eDog » ven lug 13, 2007 3:16 pm

Si. Vai in un negozio d'elettronica e comprati un cavo ethernet
eDog,
"È meglio essere temuti o rispettati? Io dico: è troppo chiedere entrambe le cose?" - Tony Stark
Avatar utente
eDog
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3679
Iscritto il: sab dic 30, 2006 7:58 pm
Località: Vescovana (Padova)

Messaggioda ...Simo... » ven lug 13, 2007 3:20 pm

cio pensato e alla fine lo farò, ma mi piacerebbe capire cosè che non va....
Avatar utente
...Simo...
Aficionado
Aficionado
 
Messaggi: 127
Iscritto il: lun lug 09, 2007 6:43 pm
Località: Pistoia

Messaggioda ...Simo... » sab lug 14, 2007 1:49 am

risolto, dovevo solamente installare il pacchetto Build-Essential....
Avatar utente
...Simo...
Aficionado
Aficionado
 
Messaggi: 127
Iscritto il: lun lug 09, 2007 6:43 pm
Località: Pistoia

Messaggioda M@ttia » sab lug 14, 2007 12:34 pm

Al di là del risolto o meno, consiglio anch'io la connessione al modem/router tramite ethernet (sia su linux che su Win): la comodità di un "Plug and Surf" come la ethernet non ha davvero rivali: niente driver, niente di niente e sei connesso dal primo istante... Se la ethernet non è già occupata da altro (cavo LAN, stampante ethernet, ecc.), meglio mettere il router in ethernet [^]
</IE><FIREFOX>
Avatar utente
M@ttia
Moderatore
Moderatore
 
Messaggi: 8363
Iscritto il: lun giu 09, 2003 2:18 pm
Località: Ticino - Estero


Torna a Driver, Riconoscimento e Gestione Periferiche

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising