Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Live Messenger dà errore 800401f3

Malfunzionamenti della LAN, suggerimenti sulla condivisione e altro legato alle reti.

Live Messenger dà errore 800401f3

Messaggioda BlueGene » mer mar 14, 2007 1:59 pm

Ciao a tutti, ho un problemino con il Live Messenger di Bill che stà facendo impazzire un mio amico (per via della figlia che gli fa due p@lle così). Il SO è Win XP pro sp2, fino ad un mese fa aveva un unico account, poi ha deciso di crearne un altro come user per limitare l'accesso della pargoletta ( [devil] ), ma si è accorto che Live Messenger non funzionava più. Cioè quando tenta di farlo partire da user gli dà errore 800401f3. Come si risolve il problema ?
Avatar utente
BlueGene
Aficionado
Aficionado
 
Messaggi: 99
Iscritto il: mer nov 29, 2006 10:21 pm

Messaggioda Fred » mer mar 14, 2007 3:47 pm

se provasse a non memorizzare uno dei 2 account?
Asus M3N78SE;AMD Athlon 64X2 5200+@5400;2 GB DDR2;NVIDIA GeForce 9500GT;Windows 7 Pro 64bit;
AcerASPIRE5230;Windows 7 Pro 64bit
Skype: nellopc90
Avatar utente
Fred
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 3623
Iscritto il: mer apr 27, 2005 4:13 pm
Località: Urbe

Messaggioda BlueGene » mer mar 14, 2007 7:05 pm

Mi sono espresso male penso, il login a Windows viene fatto tramite due account, uno con privilegi di amministratore con il quale MSN live Messenger funziona regolarmente e l'altro account con accesso limitato come user. E' con quest'ultimo account che si hanno problemi sia con vari programmi che nell'accesso a Messenger. Il messaggio di errore dice "servizio temporaneamente non disponibile. Codice errore 800401f3".
Help pls !
Avatar utente
BlueGene
Aficionado
Aficionado
 
Messaggi: 99
Iscritto il: mer nov 29, 2006 10:21 pm


Messaggioda BlueGene » ven mar 16, 2007 1:14 am

Ma come, nessuno sà dirmi qualcosa ?! [cry] Non ditemi che è un problema difficile ! [cry+]
Avatar utente
BlueGene
Aficionado
Aficionado
 
Messaggi: 99
Iscritto il: mer nov 29, 2006 10:21 pm

Messaggioda Ices_Eyes » ven mar 16, 2007 10:34 am

Il problema pare, ma potrei sbagliarmi, sia legato a qualche dll mal registrata... Nel tuo caso spero non sia dovuto a dll che non si avviano a causa dell'utente con pochi permessi. Dall'utente non admin, prova, da prompt o da start -> esegui a digitare questi comandi:
Codice: Seleziona tutto
regsvr32 Dssenh.dll /s
regsvr32 Gpkcsp.dll /s
regsvr32 Slbcsp.dll /s
regsvr32 Sccbase.dll /s
regsvr32 Softpub.dll /s
regsvr32 Wintrust.dll /s
regsvr32 Initpki.dll /s
regsvr32 Rsaenh.dll /s
regsvr32 Mssip32.dll /s
regsvr32 Cryptdlg.dll /s
regsvr32 Msxml3.dll /s


Per gli altri programmi invece...bisognerebbe vedere quali errori ti da, ma sono abbastanza convinto che in quel caso sia proprio un problema di permessi, soprattutto se hai installato i programmi prima di creare il secondo account [:)]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia

Messaggioda BlueGene » ven mar 16, 2007 6:41 pm

Grazie per la tua risposta Ices, ti dico cosa ho fatto:
A)Ho eseguito la procedura di registrazione delle dll, andata a buon fine ma il problema rimane.
B)Ho innalzato il livello dell'account windows da utente ad amministratore.
C)Reinstallato MSN Live Messenger nel secondo account.
D)Disattivato firewall ed antivirus per vedere se cambiava qualcosa.

Che altro posso fare ? [boh]
Avatar utente
BlueGene
Aficionado
Aficionado
 
Messaggi: 99
Iscritto il: mer nov 29, 2006 10:21 pm

Messaggioda Ices_Eyes » ven mar 16, 2007 8:19 pm

Girando in internet ho trovato questa soluzione:
http://forum.msgshit.com/index.php?s=&s ... st&p=76302

Forse potrebbe andare, la prima parte della discussione suggeriva la parte che ti avevo segnalato prima [:)]

(il file di cui parlano, reset, è linkato un paio di post più sotto) [:)]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia

Messaggioda crazy.cat » dom mar 18, 2007 7:51 pm

Prova anche questo programmino se combina qualcosa
http://www.MegaLab.it/forum/viewtopic.p ... 383#240383
Quando i molti governano, pensano solo a contentar sé stessi, si ha allora la tirannia più balorda e più odiosa: la tirannia mascherata da libertà.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Risolto !

Messaggioda BlueGene » mar mar 20, 2007 1:58 am

Finalmente sono riuscito a risolvere il problema ! Ringrazio Ices_Eyes e Crazy.cat che mi hanno dato una mano nella faccenda, grazie ragazzi, questo forum è grande anche perché ci sono persone come voi ! [^]
Devo aggiungere che i link che mi avete segnalato purtroppo non mi hanno aiutato ma valeva la pena di provarli comunque. Se volete poi posso anche scrivere come ho risolto, ditemi voi.

@Ices_eyes: avevi ragione era un problema di permessi [acc2] . Comunque quel tool (SubInAcl), a cui fa riferimento il messaggio che hai linkato, è molto utile per velocizzare le cose ed eseguire tante belle operazioncine... non lo conoscevo [boh]
Avatar utente
BlueGene
Aficionado
Aficionado
 
Messaggi: 99
Iscritto il: mer nov 29, 2006 10:21 pm

Re: Risolto !

Messaggioda Ices_Eyes » mar mar 20, 2007 7:41 pm

BlueGene ha scritto:Se volete poi posso anche scrivere come ho risolto, ditemi voi

Eccerto che si, può sempre tornare utile a qualcuno un giorno [:)]

BlueGene ha scritto:è molto utile per velocizzare le cose ed eseguire tante belle operazioncine... non lo conoscevo [boh]

Poteri di casa Microsoft [bleh]
Avatar utente
Ices_Eyes
Membro Ufficiale (Gold)
Membro Ufficiale (Gold)
 
Messaggi: 5543
Iscritto il: ven ott 24, 2003 10:37 am
Località: Prov. di Venezia

Messaggioda BlueGene » ven mar 30, 2007 5:30 pm

Da quanto ho potuto vedere ultimamente gli errori più comuni di Windows Live Messenger (WLM) derivano da Firewall, Antispyware con HIPS ed accesso a WLM da account secondario di Windows anche con privilegi di amministratore. In alcuni casi si può verificare un errore se alcune librerie dinamiche non sono correttamente registrate o c'è una sorta di incompatibilità fra quelle usate da Windows e quelle richieste da WLM.
Gli errori restituiti hanno svariati codici:
80004005
800401f3
80040154
80040111
80048883
80048820
80048848
80072ee7
80072efd
80070190
80070193
800701f7
80072745

In giro per la rete ci sono alcune applicazioni che tentano di riparare i problemi e magari si possono provare prima di mettere le mani sul registro di configurazione, più sotto riporto i vari links dovete le potete trovare.
Per venire invece ai due casi che mi sono capitati devo dire che questi programmini non mi sono serviti a molto (se non SubInAcl di casa Microsoft), questo perché il problema era dato proprio dal tentativo di accedere a WLM da accounts con privilegi da amministratore ma incompleti. Mi spiego meglio: ad un pc si poteva accedere al sistema tramite due accounts entrambi di livello amministratore ma mentre nel primo WLM funzionava regolarmente, nel secondo non ne voleva sapere e dava codice errore 800401f3 (il secondo della lista precedente). Bene, Ices_Eyes mi consiglia di ri-registrare alcune dll e quindi mi metto al lavoro, creo un file batch (per fare prima) contentente le seguenti righe:
REGSVR32 %windir%\system32\dssenh.dll /s
REGSVR32 %windir%\system32\gpkcsp.dll /s
REGSVR32 %windir%\system32\slbcsp.dll /s
REGSVR32 %windir%\system32\sccbase.dll /s
REGSVR32 %windir%\system32\softpub.dll /s
REGSVR32 %windir%\system32\wintrust.dll /s
REGSVR32 %windir%\system32\initpki.dll /s
REGSVR32 %windir%\system32\rsaenh.dll /s
REGSVR32 %windir%\system32\mssip32.dll /s
REGSVR32 %windir%\system32\cryptdlg.dll /s
REGSVR32 %windir%\system32\msxml3.dll /s
e lo faccio partire dal prompt dei comandi, dopo quasi due minuti (ci vuole circa un minuto per registrare initpki.dll) il processo finisce e quindi riavvio il pc... niente da fare l'errore spunta sempre. L'altra soluzione consigliata è quella di usare il Windows Resouce Kits (SubInAcl.exe) tramite un file batch (reset.bat) che in pratica resetta i privilegi nel registro di configurazione dando pieno accesso al gruppo Administrators e System alle chiavi HKEY_LOCAL_MACHINE, HKEY_CURRENT_USER e HKEY_CLASSES_ROOT oltre che alle subdirectories %SystemDrive%. Se provate questa soluzione andatevi a prendere un bel caffè perché impiega un bel po' di tempo, sul pc del mio amico più di 15 minuti ! Comunque anche questa operazione non risolve nulla anzi è probabile che non possiate più accedere al Windows installer (msiexec.exe) come è successo in quel caso ! [cry+]
Crazy.cat mi suggerisce di usare MSNrepair di Valentino Marangi che in pratica fa un po' tutto quello che ho descritto finora e che in teoria dovrebbe veramente risolvere le cose, ma purtroppo nel mio caso stranamente non ha funzionato.
A questo punto preso da ira funesta minaccio il pc di formattarlo per bene [devil] e in un ultimo tentativo comincio a cambiare le autorizzazioni di tutte le chiavi del registro in questo modo:
ES. 1° Account PIPPO (primo amministratore) =
HKEY_CLASSE_ROOT -> Gruppo PIPPO -> controllo completo; avanzate -> Proprietario = PIPPO e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_CURRENT_USER -> Gruppo PIPPO -> controllo completo; avanzate -> Proprietario = PIPPO e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_LOCAL_MACHINE -> Gruppo Amministratori -> controllo completo; avanzate -> Proprietario = Amministratori e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_USERS -> Gruppo Amministratori -> controllo completo; avanzate -> Proprietario = Amministratori e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_CURRENT_CONFIG -> Gruppo PIPPO -> controllo completo; avanzate -> Proprietario = PIPPO e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
2° Account MARIA (secondo amministratore)=
HKEY_CLASSE_ROOT -> Gruppo PIPPO -> controllo completo; avanzate -> Proprietario = PIPPO e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_CURRENT_USER -> Gruppo Amministratori -> controllo completo; avanzate -> Proprietario = Amministratori e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_LOCAL_MACHINE -> Gruppo Amministratori -> controllo completo; avanzate -> Proprietario = Amministratori e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_USERS -> Gruppo Amministratori -> controllo completo; avanzate -> Proprietario = Amministratori e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica
HKEY_CURRENT_CONFIG -> Gruppo Amministratori -> controllo completo; avanzate -> Proprietario = Amministratori e spunta su "sostituisci proprietario in sottocontenitori ed oggetti" poi applica.
In questo modo ho potuto installare ed usare tutti i programmi nel secondo account, incluso quel maled#** [B)] Live Messenger.

N.B. probabilmente si può fare meglio ma questo lo lascio dire agli esperti del forum ! [MLI] [applauso+]
p.s. scusate la lunghezza del post ! [zip]
Avatar utente
BlueGene
Aficionado
Aficionado
 
Messaggi: 99
Iscritto il: mer nov 29, 2006 10:21 pm

Messaggioda mirko86 » gio apr 19, 2007 12:45 am

Scusa, ma non ho capito nulla di quello che è da fare.

Sono andato nell'editor del registro, ma non sò da che iniziare.

Potresti spiegarti meglio?

O comunque qualcuno riesce a spiegarmi passo passo cosa fare?
Il mondo non è pericoloso a causa di quelli che fanno del male ma a causa di quelli che guardano e lasciano fare. Einstein
Avatar utente
mirko86
Neo Iscritto
Neo Iscritto
 
Messaggi: 1
Iscritto il: gio apr 19, 2007 12:40 am


Torna a Reti e Internet

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron
Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising