Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

Il sottosistema non ha potuto avviare modalità protetta

Problemi con i sistemi operativi di casa Microsoft? Questa è la sezione che fa per te!

Il sottosistema non ha potuto avviare modalità protetta

Messaggioda diubeck » mar feb 21, 2006 5:36 pm

Ciao raga,un problemino.
Ho provato ad installare alcuni programmi e quando lancio il setup mi da il seguente errore: IL SOTTOSISTEMA NON HA POTUTO AVVIARE LA MODALIT....PROTETTA,DOSX.EXE DEVE ESSERE IN AUTOEXEC.NT E PRESENTE IN PATH.
Grazie x avermi letto e gentilmente datemi una mano.
Avatar utente
diubeck
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: mar feb 21, 2006 5:30 pm

Messaggioda Boo » mar feb 21, 2006 6:30 pm

Servirebbe sapere che versione di windows utilizzi, dal problema che proponi direi che si tratta di Windows XP, probabilmente l'account che usi per avviare il programma non ha permessi di amministratore.
Avatar utente
Boo
Silver Member
Silver Member
 
Messaggi: 1276
Iscritto il: sab dic 04, 2004 3:41 pm

Re: Mi aiutate..grazie

Messaggioda crazy.cat » mar feb 21, 2006 7:30 pm

Ti ho cambiato il titolo.

diubeck ha scritto:Ho provato ad installare alcuni programmi e quando lancio il setup mi da il seguente errore: IL SOTTOSISTEMA NON HA POTUTO AVVIARE LA MODALIT....PROTETTA,DOSX.EXE DEVE ESSERE IN AUTOEXEC.NT E PRESENTE IN PATH.


Controlla che il file dosx.exe sia presente nel tuo pc in c:\windows\system32

E controlla che il file autoexec.nt sia nella stessa cartella e sia scritto come qui sotto, lo apri con notepad

Codice: Seleziona tutto
@echo off

REM AUTOEXEC.BAT non viene utilizzato per inizializzare l'ambiente MS-DOS.
REM AUTOEXEC.NT viene utilizzato per inizializzare l'ambiente MS-DOS a meno che
REM non sia specificato un file di avvio differente in un PIF di applicazione.

REM Installazione di estensioni CD ROM
lh %SystemRoot%\system32\mscdexnt.exe

REM Installazione di redirector di rete (caricare prima di dosx.exe)
lh %SystemRoot%\system32\redir

REM Installazione del supporto DPMI
lh %SystemRoot%\system32\dosx

REM La riga seguente abilita il supporto Sound Blaster 2.0 su NTVDM.
REM Il comando per l'impostazione dell'ambiente BLASTER è il seguente:
REM    SET BLASTER=A220 I5 D1 P330
REM    dove:
REM        A    specifica la porta I/O di base del Sound Blaster
REM        I    specifica la riga del livello di interrupt
REM        D    specifica il canale DMA a 8 bit
REM        P    specifica la porta I/O di base MPU-401
REM        T    specifica il tipo di scheda Sound Blaster
REM                 1 - Sound Blaster 1.5
REM                 2 - Sound Blaster Pro I
REM                 3 - Sound Blaster 2.0
REM                 4 - Sound Blaster Pro II
REM                 6 - SOund Blaster 16/AWE 32/32/64
REM
REM    Il valore predefinito è A220 I5 D1 e P330. Se le opzioni non vengono
REM    specificate, verrà utilizzato il valore predefinito. (NOTA: poiché tutte
REM    le porte sono virtuali, non occorre che le informazioni qui fornite corrispondano
REM    alle reali impostazioni dell'hardware.) NTVDM supporta soltanto Sound Blaster 2.0.
REM    L'opzione T deve essere impostata a 3, se specificata.
SET BLASTER=A220 I5 D1 P330 T3

REM Per disabilitare il supporto Sound Blaster 2.0 su NTVDM, specificare un indirizzo
REM di porta I/O di base del Sound Blaster non valido. Ad esempio:
REM    SET BLASTER=A0
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre


Messaggioda diubeck » mer feb 22, 2006 5:40 pm

Ciao ragazzi,grazie x la risposta.
Ho window xp sp2,il file dosx.exe e autoexec.nt non sono presenti nella cartella di windows/system32.
Come posso fare ?
Grazie
Avatar utente
diubeck
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: mar feb 21, 2006 5:30 pm

Messaggioda crazy.cat » mer feb 22, 2006 6:33 pm

Dimmi quando li hai scaricati che poi cancello l'allegato.
Estrai i due file in quella cartella.
Ultima modifica di crazy.cat il mer feb 22, 2006 7:58 pm, modificato 1 volta in totale.
Quando i molti governano, pensano solo a contentar sé stessi, si ha allora la tirannia più balorda e più odiosa: la tirannia mascherata da libertà.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Messaggioda diubeck » mer feb 22, 2006 7:49 pm

Ciao Crazy,ho scaricato il file,l'ho messo nella cartella c:/windows/system32,ho riavviato ma il problema non e' risolto continua come prima.
Comunque ti ringrazio di cuore x la gentilezza dimmi se posso fare qualcos'altro.
Un caro saluto.
Avatar utente
diubeck
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: mar feb 21, 2006 5:30 pm

Messaggioda crazy.cat » mer feb 22, 2006 8:00 pm

diubeck ha scritto:ho scaricato il file,l'ho messo nella cartella

Devi estrarre il contenuto del zip in quella cartella.

Che programmi stavi provando ad installare?
Quando i molti governano, pensano solo a contentar sé stessi, si ha allora la tirannia più balorda e più odiosa: la tirannia mascherata da libertà.
Avatar utente
crazy.cat
MLI Hero
MLI Hero
 
Messaggi: 30959
Iscritto il: lun gen 12, 2004 1:38 pm
Località: Mestre

Messaggioda diubeck » gio feb 23, 2006 6:23 pm

Ciao Crazy, ho fatto cosi ho estratto il file e l'ho messo nella dir che mi avevi detto.
Stavo installando " HOME DESIGNER 3D"
Grazie
Avatar utente
diubeck
Neo Iscritto
Neo Iscritto
 
Messaggi: 9
Iscritto il: mar feb 21, 2006 5:30 pm


Torna a Sistema Operativo

Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising