Punto informatico Network
Login Esegui login | Non sei registrato? Iscriviti ora (è gratuito!)
Username: Password:
  • Annuncio Pubblicitario

problema ad installare dx 9.0 c su win 98 se

Office fa le bizze? Photoshop non funziona più? Forse possiamo darti una mano...

problema ad installare dx 9.0 c su win 98 se

Messaggioda cippico » gio dic 30, 2004 2:46 pm

in uso dx 9.0b senza problemi
duron 1800
512 ram pc 2700 (333)
mobo msi kt2 combo
chipset via vt 8366a apollo kt 266a
scheda video nvidia gforce 2 mx/mx 400 (64mb)
driver video vecchiotti ma ok (detonator 12.41)i piu' recenti che non mi impediscono di usare il dos...
...tutti i successivi impediscono di usare dos...schermo nero...
scheda audio creative sb live

credo possa bastare...

il problema e' questo...
i giochi li uso su win 98 e non su xp(dual boot)
finora sempre ok...mi hanno dato the sims 2 e installandolo vuole le direct x 9.0 c...ma non le installa...

ho provato anche a scaricarle dal sito microsoft e dopo aver decompresso e inizierebbe ad estrarre i file appare una
finestra di errore che dice"impossibile copiare un file"...ma non dice quale...e l'installazione termina senza successo...
comunque senza far danni e lasciando tutto inalterato...

qualcuno sa come posso risolvere ed installarle?
so che potrei installare il gioco in xp...ma vorrei continuare ad usare il 98 solo x le cose meno importanti...
e se riuscissi ad installare queste benedette direct x 9.0 c...

grazie a tutti e ciaooo
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

modalita' provvisoria...

Messaggioda cippico » gio dic 30, 2004 2:48 pm

mi hanno detto anche di provare in modaslita' provvisoria...e comunque vedere se viene creato un file log con elenco eventuali errori x trovare il nome del file che non si copia...ma non trovo nessun file log...

praticamente durante l'estrazione dei file dopo aver cliccato il setup e accettato le condizioni comincia l'estrazione dei file...circa a 3/4 della procedura appare il messaggio di errore e termina tutto il processo...ma senza alcun file log...
oltretutto questo succede sia con la versione dx 9.0 c presente nel gioco che volevo instalalre,sia copiata la cartella dx 9.0 c da altri giochi...sia dalla versione scaricata da microsoft...come se tutte le versioni avessero i file .cab danneggiati...il che mi sembra strano...pero' l'impossibilita' di copiare penso derivi da un problema non del mio pc...almeno credo...
potrei capire i problemi a dx installate...ma non che non si installano x altri motivi(sconosciuti)...oltretutto in xp(dual boot)si sono installate con il sop 2 senza problemi e tutto funziona a dovere...usato il dxdiag x i soliti controlli...e anche in win 98...

qualcun'altro ne sa qualcosa?

grazie a tutti e ciaooo
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

Messaggioda Kgiulio » gio dic 30, 2004 3:14 pm

potresti risolvere disinstallando completamente le DirectX e reinstallandole ma secondo me non vale la pena...

ma the Sims 2 non parte senza le 9c? (puoi sempre usare XP SP2 per i giochi difficili...)
Avatar utente
Kgiulio
Silver Member
Silver Member
 
Messaggi: 1663
Iscritto il: gio set 09, 2004 8:08 pm
Località: Italia


non parte...

Messaggioda cippico » gio dic 30, 2004 3:33 pm

si e' installato regolarmente...anche senza aver installato le sue dx 9.0 c...(stesso errore chiaramente)...se voglio giocare appare il msg che avvisa che le dx 9.0 c non sono installate e quindi non si puo' giocare...

se non riusciro' proprio a venirne fuori...provero' su xp...pero' volevo evitare di usare xp x giochi o amenita' varie...visto che finora il 98 si comporta + o - egregiamente...

grazie e ciaooo
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

Messaggioda simone.west » gio dic 30, 2004 5:11 pm

non vorrei dire una cavolata, ma la tua scheda grafica non supporta le dx 9.x
non è che sia quello il motivo ?
Più donne è poligamia,due è bigamia,una sola donna è monotonia...
Avatar utente
simone.west
Senior Member
Senior Member
 
Messaggi: 392
Iscritto il: mer set 01, 2004 5:56 pm
Località: lago lombardo

Messaggioda simone.west » gio dic 30, 2004 5:14 pm

a dimenticavo ,
hai provato a decomprimere i .Cab con per esempio win rar e poi eseguire l installazione dx...
Più donne è poligamia,due è bigamia,una sola donna è monotonia...
Avatar utente
simone.west
Senior Member
Senior Member
 
Messaggi: 392
Iscritto il: mer set 01, 2004 5:56 pm
Località: lago lombardo

pero'...

Messaggioda cippico » ven dic 31, 2004 1:44 am

potrebbe essere la scheda...ma in xp pro sp 2 le dx 9.0c si sono installate con il sp 2...la procedura e' senz'altro diversa...pero' tutto funziona ok...quindi non dovrebbero esserci incompatibilita'...non capisco perche' durante l'installazione non riesce ad essere copiato un file(quando la barretta e' quasi alla fine)...e tutti gli altri file invece sono stati copiati...

ho provato a decomprimere i cab...ma ci sono problemi con nomi uguali...e sovrascritture...poi non so se riuscirebbe a trovare i file necessari fuori dai file .cab...

ho anche provato a usare direct x eradicator(dopo aver fatto un ghost)ma il problema rimane...ho usato dx 9.0 c prese anche da altri cd di giochi...oltre ad averle scaricate dal sito microsoft...ma l'errore e' sempre lo stesso...durante l'installazione componenti...con la scritta:completamento in corso...appare il solito msg che dice:impossibile copiare file

non posso credere che tutte le versioni siano danneggiate allo stesso modo...pero' mi e' difficile credere che la causa della mancata copia di un file dipenda dal pc...o meglio da win 98...che senso ha?

scusate la mia insistenza...ma ormai e' diventata una lotta...lo so...posso installarlo su xp...ma perche' far vincere...senza combattere?

dimenticavo...mi e' stato suggerito di provare in modalita' provvisoria...non mi e' mai capitato di dover avviare il pc in questa maniera(parlo di qullo di casa)...ma non riesco a farlo...ho win 98 e xp pro sp 2 in dual boot...durante l'avvio premo F8 e appare la scelta tra varie voci...io scelgo modalita' provvisoria...ma poi ritorna la scelta tra win 98...xp...e consolle di ripristino...come faccio a far partire il 98 in modalita' provvisoria?
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

Messaggioda robot » ven dic 31, 2004 5:14 pm

prova a fare una 2carograta 2 al pc se non ricordo male il gioco della (guarda caso ) microsoft rise of nations espanzione, per la precisione nella versione demo verifica in automatico se hai o no le direc , in quanto quel gioco funziona sia con la versione 8.1 che con la 9.0 ,non ricordo se a , b , c comunque tu istalla il gioco e fai istallare sempre a lui pure le direct potrebbe anche funzionare e sempre mamma bill.
ciao

Immagine Robot
Avatar utente
robot
Silver Member
Silver Member
 
Messaggi: 1388
Iscritto il: ven set 17, 2004 10:44 am
Località: italia

il gioco e' installato...

Messaggioda cippico » sab gen 01, 2005 6:53 pm

pero' alla fine se voglio giocare...non parte e un msg avvisa che servono le dx 9.0c

su alcuni pc vecchi con il 98 che ho sul lavoro...facendo un winupd mi dice se voglio instalalre al massimo le dx 8.1 se non ricordo male...le 9.0 non le nomina nemmeno...forse io installandole dopo averle scaricate dal sito microsoft...ho fatto una forzatura...nel senso che non era necessario...indipendentemente dalla scheda video che ho8anche se su xp non ho problemi)

approfitto x fare auguri di buon anno a tutti...

grazie e ciaooo
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

Messaggioda robot » lun gen 03, 2005 12:55 pm

pero ce una cosa che non quadra se le direct 9.0 sono istallate sul xp prova a condivisidere , oppure solo per i giochi che le richiedono crea un utente esempio pippo e usi solo lui per i giochi che vogliono le direct 9.0 , comunque guarda che l'aggiornamente delle librerie non e vincolato al sistema operativo , se hai in win 95 e vuoi istalare le 9.0 si puo fare la ha fatto uno che conosco , va lento come una lumaca comunque ma funziona.
ciao
Avatar utente
robot
Silver Member
Silver Member
 
Messaggi: 1388
Iscritto il: ven set 17, 2004 10:44 am
Località: italia

ieri ho provato l'impossibile...

Messaggioda cippico » lun gen 03, 2005 2:01 pm

vi faccio il resoconto...
comunque x ora ho fatto un ghost di xp e il gioco l'ho installato li...quando mia moglie lo finira'... [sedia] ...ripristino con il ghost...non voglio usare xp per giochi e altro...se possibile continuero' ad usare il 98...come ho sempre fatto finora...

dopo ghost di win 98...

ho usato dx eradicator
poi ho installato le dx 8.1...tutto ok e poi le solite 9.0c...solito errore

di nuovo eradicator e ho installato le 9.0a...tutto oh...poi le solite 9.0c...solito errore

di nuovo eradicator
(chiaramente ogni volta ripulivo il possibile prima di installare nuove versioni di dx...)e poi ho installato direttamente le 9.0c...questa volta ho notato subito che la barretta dell'installazione...che ormai sapevo a che punto si bloccava...e' andata piu' avanti del solito...pero' l'errore lo ha dato ugualmente...

infatti bloccata l'installazione ho cercato i file .tmp lasciati...e di solito ne trovavo nelle cartelle windows e system...questa volta ne ho trovati anche nella cartelle inf...

poi ho voluto provare l'avvio in modalita' provvisoria...impossibile con 98 e xp in dual boot...poiche' premendo F8 all'avvio...compare la possibilita' di selezionare la mod. provv. ...poi pero' torna la scelta tra xp o 98 o consolle di ripristino...e c'e' una scritta sotto in blu che dice mod. provv. ...ma x proseguire devo x forza selezionare il s.o. che voglio avviare...pero' si avvia normalmante...

allora ho cercato di ingannare il s.o ...ho fatto un backup del file di registro(preso poi dalla cartella sysbackup)e l'ho salvato sul desktop...e poi ho svuotato la cartella sysbackup...ho eliminato il file system.dat e ho riavviato...chiaramente ci sono stati problemi...e FINALMENTE il 98 si e' avviato in modalita' provvisoria...pero' al termine dell'avvio explorer dava un errore e veniva chiuso...e rimaneva solo il desktop caricato...senza poter fare nulla...

allora ho ripristinato il backup e ho riavviato e stavolta ho tolto il file user.dat ...purtroppo stessa cosa di prima...quindi modalita' provvisoria...azzoppata...perche' non si carica altro se non lo sfondo del desktop...

qualcuno sa come posso risolvere questa SFIDA?

installare queste maledette dx 9.0c...
qualcuno di voi le ha installate in win 98?
qualcuno sa come accedere in modalita' provvisoria con dual boot?
...forse in quella modalita' riesco ad installarle...anche se dubito...

attendo fiducioso altri consigli...

grazie e ciaooo a tutti
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

resoconto su ultimi tentativi...

Messaggioda cippico » ven gen 07, 2005 3:12 pm

ho provato con il pc di mio fratello ad eseguire un winupd e ho scaricato l'aggiornamento x dx 9.0c...scaricato(con adsl)installato...riavviato...tutto ok...ho fatto i soliti test lanciando dxdiag...

allora mi sono armato di pazienza...e ho fatto la stessa cosa sul mio pc(pero' con modem)dopo 45 minuti circa le dx sono state scaricate ed installate...riavvio...e con sorpresa :mad: non c'era piu' la cartella che conteneva il dxdiag x fare i test...praticamente non c'erano piu' neanche le dx9.0b(che erano correttamente installate)

allora mi sono proprio incazzato :mad: ...e ho iniziato a devastare l'installazione(il ghost lo avevo fatto prima di fare winupd)...

eradicato con dx eradicator...ho iniziato ad installare le dx 8 e poi ho provato a installare le 9.0c...solito errore
poi ho provato con le 9.0a...e popi ho installato le solite 9.0c...solito errore...

ho provato da dos...chiaramente non e' stato possibile...

ho provato a mischiare vari file di installazione di 9.0a e 9.0c...x provare a fregarle...niente da fare...

ho anche salvato i vari cab che sono stati scaricati durante wuinupd e ho provato ad installarle con quelli...niente da fare...

le ho sradicate di nuovo e ho provato a reinstallare the sims 2 e quando ha chiesto di installare le 9.0c gli ho detto si...anche li solito errore...quindi ho installato il gioco senza far installare le dx...riavvio...lanciato gioco e naturalmente chiedeva un file relativo a dx 9.0c...allora lo ho estratto dai vari .cab e li copiavo man mano che li chiedeva...poi il gioco e' partito(solo schermata di presentazione)ma poi dava un errore l'eseguibile del gioco stesso...

poi mi sono definitivamente arreso...

basta...questa volta ha vinto lui...

se qualcuno ha suggerimenti...ben vengano...

grazie e ciaooo
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

Messaggioda Kgiulio » ven gen 07, 2005 4:00 pm

prova ad eseguire questa procedura:
http://www.zanezane.net/articoli.asp?id=70
dovrai farlo da DOS

Zane's DirectX uninstaller credo non sia più reperibile

dopo aver disinstallato le dx installa direttamente le DirectX 9c

io l'ho fatto su un computer con win98 con un problema praticamente uguale al tuo e ha funzionato

poi con le idee ho finito
Avatar utente
Kgiulio
Silver Member
Silver Member
 
Messaggi: 1663
Iscritto il: gio set 09, 2004 8:08 pm
Località: Italia

tentare anche questo...non nuoce...

Messaggioda cippico » ven gen 07, 2005 5:04 pm

tanto ho sempre il ghost...ti ringrazio...lo provero'...

ti faro ' sapere...

grazie e ciaooo
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

niente da fare...

Messaggioda cippico » mar gen 11, 2005 8:15 am

Kgiulio ha scritto:prova ad eseguire questa procedura:
http://www.zanezane.net/articoli.asp?id=70
dovrai farlo da DOS

Zane's DirectX uninstaller credo non sia più reperibile

dopo aver disinstallato le dx installa direttamente le DirectX 9c

io l'ho fatto su un computer con win98 con un problema praticamente uguale al tuo e ha funzionato

poi con le idee ho finito


usando dx eradicator tutte le voci della procedura citata vengono gia´ eliminate...

finalmente pero´ sono riuscito a far partire il win 98 in modalita´ provvisoria(non chiedete
come ho fatto...ho pasticciato un po´ con floppy di avvio vari...e dopo vari tentativi,
e una schermata blu´ il pc e´ finalmente partito in modalita´ provvisoria)e solo alla fine
ho provato a togliere le righe che riguardavano xp dal fileboot.ini e anche in quel caso
non avevo piu´ il dual boot di xp e quindi con F8 potevo partire in modalita´ provvisoria...
pero´ l´ho fatto solo alla fine...quando non serviva piu´...visto che neanche li sono
riuscito ad installare le dx 9.0c...solito errore...quindi ho rinunciato...questa volta
definitivamente...credo...salvo dritte particolari...ammesso che esistano...
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am

incredibile...si sono installate...

Messaggioda cippico » sab mar 26, 2005 12:47 am

spero possa essere utile a qualcuno...

ecco i cambiamenti effettuati al s.o. da quando...dopo le infinite prove...mi ero rassegnato...

maxthon 1.1.120 standard 14 01 05
4 in 1 4.55 73 14 01 05
patch sicur ie 6 sp 1 98 kb 890175 11 01 05 21 01 05
98 vsapi-vxd-7.500-1001 18 01 05 21 001 05
prova in system.ini su voce [386enh] MinSPs=16 07 02 05
patch kb 867282 98 11 02 05
patch kb 891178 98 11 02 05
98 vsapi-kd-7.510-1002 98 24 02 05 25 02 05
maxthon 1.2.000
iso buster (1.6 build 1.6.0.19) 06 03 05
driver video nvidia forceware 71.84 25 03 05 (dopo il primo tentativo di installazione,mi e' apparso un msg che diceva che non era stato possibile scrivere nel file c:/windows/system.ini ...quindi ho guardato le proprieta' ed era nascosto e in sola lettura...ho tolto i flag e ho provato a reinstallare i driver...con successo...
...l'ho tenuto cosi' fino a quando non ho provato a reinstallare le dx 9.0c...(che sia stato questo il problema?)
patch kb 888113 25 03 05
patch kb 891711 25 03 05 via eseguibile da avvio con startupcpl

E FINALMENTE...

direct x 9.0c multilanguage 26 03 05

ciaooo a tutti e buona pasqua
Salutone a Zane...padre putativo di MegaLab... :-)
Mio sito... http://www.cippico.altervista.org
Miei articoli sul sito MegaLab.it... http://www.MegaLab.it/staff.php?cippico
Avatar utente
cippico
Silver Member
Silver Member
 
Messaggi: 1284
Iscritto il: sab gen 25, 2003 1:57 am


Torna a Software

Chi c’è in linea

Visitano il forum: Nessuno e 0 ospiti

Powered by phpBB © 2002, 2005, 2007, 2008 phpBB Group
Traduzione Italiana phpBB.it

megalab.it: testata telematica quotidiana registrata al Tribunale di Cosenza n. 22/09 del 13.08.2009, editore Master New Media S.r.l.; © Copyright 2008 Master New Media S.r.l. a socio unico - P.I. 02947530784. GRUPPO EDIZIONI MASTER Spa Tutti i diritti sono riservati. Per la pubblicità: Master Advertising