Pagina 1 di 2

Piccoli problemi dopo installazione Linux Mint Debian-based

MessaggioInviato: dom set 11, 2011 6:55 pm
da developerwinme
Buona sera! Questo è il mio primo post in questa sezione, ed è legato all'installazione di Linux Mint Debian Edition sul mio computer desktop principale. (Chi segue la discussione sui computer in Chiacchiere e libertà sa già qualcosa della vicenda [;)] ).

Dopo questa piccola introduzione, passo ai problemi; in seguito all'installazione mi sono accorto di:

1) Linux Mint non monta alcune unità del disco (in particolare quelle relative all'HDD su cui è installata): non sapendo quali dettagli aggiuntivi fornire, aspetto che mi venga richiesto per darli.
2) Impostando l'orario correttamente su Windows 7, su Mint viene rilevato come 2 ore dopo (es. imposto le 20:00 su Win7, riavvio, vado su Mint e mi dice che sono le 22:00) e se lo imposto correttamente su Mint, su Windows 7 viene rilevato come 2 ore prima (es. imposto le 20:00 su Mint, riavvio, vado su Windows e mi dice che sono le 18:00).
3) La versione preinstallata di Firefox è la 5, e non viene notificato come disponibile alcun aggiornamento.
4) Ci sono alcuni repository aggiuntivi che può tornare utile aggiungere?

Devo dire che questa esperienza con Linux non sta andando male e, a parte questi problemini, per ora mi ritengo abbastanza soddisfatto. In caso di nuovi problemi domanda, provvedo a postare in questa sezione.

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: dom set 11, 2011 7:05 pm
da Ale2695
developerwinme ha scritto:3) La versione preinstallata di Firefox è la 5, e non viene notificato come disponibile alcun aggiornamento.

Per ora ti rispondo a questo che sono di fretta, poi domani mi rileggo con calma il resto. Dai questi comandi da terminale:
Codice: Seleziona tutto
sudo add-apt-repository ppa:mozillateam/firefox-stable
sudo apt-get update
sudo apt-get upgrade

E Firefox si aggiornerà [^]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: dom set 11, 2011 7:14 pm
da developerwinme
Ale2695 ha scritto:E Firefox si aggiornerà

Grazie per la risposta, ma (suppongo che) qualcosa non deve andare bene nei file di sistema, perché ricevo questo errore. [uhm]

Codice: Seleziona tutto
Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 65, in <module>
    if not sp.add_source_from_line(line):
  File "/usr/lib/python2.6/dist-packages/softwareproperties/SoftwareProperties.py", line 630, in add_source_from_line
    (deb_line, file) = expand_ppa_line(line.strip(), self.distro.codename)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/ppa.py", line 47, in expand_ppa_line
    sourceslistd = apt_pkg.Config.find_dir("Dir::Etc::sourceparts")
AttributeError: 'module' object has no attribute 'Config'

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: dom set 11, 2011 8:03 pm
da Ale2695
Quest'errore ti esce fuori dopo che passaggio? Dopo aver lanciato l'add-apt-repository?
Se si, prova a seguire questa guida, che servirebbe per abilitare add-apt-repository nei sistemi dove non è presente, ma eseguendo questa guida almeno proviamo a riparare il programma reinstallandolo [:)]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 9:35 am
da developerwinme
L'errore veniva restituito, come immaginavi, dopo il primo comando. Seguendo la guida che hai postato il comando viene eseguito senza problemi, ed aggiunge il repository nell'elenco dei sorgenti software, ma in ogni caso non viene segnalato nessun update disponibile né da FF né da MintUpdate. [uhm]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 9:51 am
da farbix89
Hai aggiornato?

Codice: Seleziona tutto
sudo apt-get update
sudo apt-get upgrade


questi comandi sono da lanciare dopo aver aggiunto un qualsiasi repository [^]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 10:08 am
da farbix89
tornando agli altri problemi:

2) Impostando l'orario correttamente su Windows 7, su Mint viene rilevato come 2 ore dopo (es. imposto le 20:00 su Win7, riavvio, vado su Mint e mi dice che sono le 22:00) e se lo imposto correttamente su Mint, su Windows 7 viene rilevato come 2 ore prima (es. imposto le 20:00 su Mint, riavvio, vado su Windows e mi dice che sono le 18:00).


questo puoi risolverlo velocemente inserendo la località nell'applet dell'orologio/data (cliccaci sopra).

Oppure utilizzando questo comando da terminale

Codice: Seleziona tutto
sudo gedit /etc/default/rcS


cambia l'UTC da "yes" a "no"

Codice: Seleziona tutto
UTC=yes in UTC=no

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 10:09 am
da farbix89
1) Linux Mint non monta alcune unità del disco (in particolare quelle relative all'HDD su cui è installata): non sapendo quali dettagli aggiuntivi fornire, aspetto che mi venga richiesto per darli.


file system delle unità?

per il momento non mi viene in mente altro

4) Ci sono alcuni repository aggiuntivi che può tornare utile aggiungere?


Se non hai esigenze di software particolari,vanno benissimo quelli già segnalati nell'articolo mio e di Doc [^]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 10:23 am
da developerwinme
farbix89 ha scritto:Hai aggiornato?

Sia da terminale che da Gestore aggiornamenti, ma continua a non darmi aggiornamenti disponibili, o meglio, dal gestore pacchetti, nell'elenco delle versioni, ci sono sia la 5.0 (dal repository di Mint), che la 6.0.2 (dal repository che ho aggiunto grazie ad Ale): forzo di installare dal repository di Mozilla?

farbix89 ha scritto:questi comandi sono da lanciare dopo aver aggiunto un qualsiasi repository

[^]

farbix89 ha scritto:questo puoi risolverlo velocemente inserendo la località nell'applet dell'orologio/data (cliccaci sopra).

Il problema si verifica proprio inserendo correttamente la località (o non inserendola): per il momento ho risolto mettendo come località una sperduta isoletta dell'atlantico che ha fuso orario GMT-1. [acc2]

farbix89 ha scritto:file system delle unità?

Le unità sono NTFS, ma ho appena visto che forse mi sono espresso male: il problema non è che Mint non le monta, ma che Nautilus non le visualizza neanche (a differenza delle altre due sull'altro disco, che vengono viste e montate, su richiesta, senza problemi): l'unico modo per vedere che esistono è usare GParted o il gestore dei dischi (che comunque non riesce a montarle).

farbix89 ha scritto:Se non hai esigenze di software particolari,vanno benissimo quelli già segnalati nell'articolo mio e di Doc

[^]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 10:30 am
da farbix89
developerwinme ha scritto:Sia da terminale che da Gestore aggiornamenti, ma continua a non darmi aggiornamenti disponibili, o meglio, dal gestore pacchetti, nell'elenco delle versioni, ci sono sia la 5.0 (dal repository di Mint), che la 6.0.2 (dal repository che ho aggiunto grazie ad Ale): forzo di installare dal repository di Mozilla?


Si,puoi forzare.

Puoi forzare la versione da Gestore Pacchetti selezionando il pacchetto Firefox e cliccando nel menù "Pacchetto" sulla voce "Forza versione".

Nel menù a tendina dovrebbe mostrare anche la versione aggiornata [^]

Il problema si verifica proprio inserendo correttamente la località (o non inserendola): per il momento ho risolto mettendo come località una sperduta isoletta dell'atlantico che ha fuso orario GMT-1.


Provato disattivando l'UTC?

Le unità sono NTFS, ma ho appena visto che forse mi sono espresso male: il problema non è che Mint non le monta, ma che Nautilus non le visualizza neanche (a differenza delle altre due sull'altro disco, che vengono viste e montate, su richiesta, senza problemi): l'unico modo per vedere che esistono è usare GParted o il gestore dei dischi (che comunque non riesce a montarle).


Molto strano [uhm]

Faccio una piccola indagine e vedo cosa scopro [^]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 10:41 am
da Ale2695
Te lo dico sinceramente: con Mint Debian ti sei preso una bella gatta da pelare, dopo i primi tempi anche a me ha iniziato a dare i numeri (Gestore Aggiornamenti e Gestore Applicazioni fuori uso, Banshee inutilizzabile, montaggio periferiche USB non sempre funzionante, ecc.). Ti dico la verità: con Debian, che teoricamente dovrebbe essere molto più ostica, non ho avuto tutti questi problemi [:)]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 10:55 am
da developerwinme
Ale2695 ha scritto:Te lo dico sinceramente: con Mint Debian ti sei preso una bella gatta da pelare, dopo i primi tempi anche a me ha iniziato a dare i numeri (Gestore Aggiornamenti e Gestore Applicazioni fuori uso, Banshee inutilizzabile, montaggio periferiche USB non sempre funzionante, ecc.). Ti dico la verità: con Debian, che teoricamente dovrebbe essere molto più ostica, non ho avuto tutti questi problemi

Grazie per l'incoraggiamento [:D] A parte lo scherzo: l'ho scelta anche per questo (oltre che per l'interfaccia grafica che mi piace e per il fatto di essere Rolling), così posso passarmi un po' di tempo smanettando per bene con Linux. In ogni caso, finora si sta comportando egregiamente, sicuramente meglio di quanto hanno fatto Ubuntu 8.04 e 8.10 nella mia ultima esperienza Linux. [;)]

farbix89 ha scritto:Si,puoi forzare.

Appena aggiornato alla 6.0.2 senza problemi (anche se non la utilizzerò molto, perché, come sapete già, preferisco Opera). [^]

Ho applicato la stessa procedura anche per Thunderbird (era fermo al ramo 3.x) ed una simile (senza il repository PPA, però) per Opera 11.51 (l'ultima versione offerta dal repository Mint era la 10.6x).

farbix89 ha scritto:Provato disattivando l'UTC?

Si, ma senza alcun miglioramento: provo a riavviare?

farbix89 ha scritto: Faccio una piccola indagine e vedo cosa scopro

[^] Se ti serve qualche altra informazione, sono a disposizione.

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 11:15 am
da Ale2695
developerwinme ha scritto:Grazie per l'incoraggiamento [:D] A parte lo scherzo: l'ho scelta anche per questo (oltre che per l'interfaccia grafica che mi piace e per il fatto di essere Rolling), così posso passarmi un po' di tempo smanettando per bene con Linux. In ogni caso, finora si sta comportando egregiamente, sicuramente meglio di quanto hanno fatto Ubuntu 8.04 e 8.10 nella mia ultima esperienza Linux. [;)]

[:D] di nulla [bleh]
Comunque, è naturale che ti stia trovando meglio rispetto alle versioni 8.04 e 8.10 di Ubuntu, visto che in 3 anni è migliorato praticamente tutto nel mondo Linux, a partire dal filesystem (ext4 è decisamente più robusto di ext2 ed NTFS), dal kernel, al supporto hardware, alla qualità dei programmi. E se provassi Ubuntu 11.04, secondo me rimarresti ancora più sorpreso positivamente [;)]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 11:33 am
da farbix89
per l'orario bisogna riavviare

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 11:50 am
da developerwinme
farbix89 ha scritto:per l'orario bisogna riavviare

Continua a non funzionare (e a restare un mistero); comunque non è un grande problema, perché cambiando il fuso orario si può aggirare tranquillamente.

Novità sul fronte FileSystem?

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 12:21 pm
da Ale2695
Mmm... prova a reinstallare il pacchetto "ntfs-3g", vista l'esperienza con add-apt-repository [;)]

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 1:05 pm
da Al3x
in quei dischi NTFS per caso sono presenti sistemi operativi che sono stati ibernati?

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 1:10 pm
da developerwinme
Ale2695 ha scritto:Mmm... prova a reinstallare il pacchetto "ntfs-3g", vista l'esperienza con add-apt-repository [;)]

Sto reinstallando il pacchetto: vi farò sapere. [;)]

Al3x ha scritto:in quei dischi NTFS per caso sono presenti sistemi operativi che sono stati ibernati?

No, in una delle partizioni è presente un'installazione di Windows XP ed in un'altra sono presenti i bootloader di Windows XP e quello di Windows 7.

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 1:34 pm
da developerwinme
UPDATE: Se provo a montare dal gestore dischi (come admin), mi dà questo errore:

Codice: Seleziona tutto
Error mounting: mount exited with exit code 1: helper failed with:
fuse: failed to access mountpoint None: No such file or directory


La situazione delle partizioni su quel disco è questa:
Immagine

Linux è installato sull'unica partizione non-NTFS presente (oltre alla swap), mentre le partizioni che non si riescono a montare sono tutte quelle NTFS (che danno tutte lo stesso errore di cui sopra); Sull'altro disco che si vede ci sono due partizioni (una primaria e l'altra logica), entrambe da circa 100 Gb ed entrambe NTFS, dove sulla prima è montato Windows 7. Entrambe funzionano correttamente.

Re: Piccoli problemi dopo installazione Linux Mint Debian-ba

MessaggioInviato: lun set 12, 2011 2:19 pm
da farbix89
posta il risultato di questi 3 comandi:

Codice: Seleziona tutto
sudo blkid -c /dev/null


Codice: Seleziona tutto
cat /etc/fstab


Codice: Seleziona tutto
mount