Pagina 1 di 1

Google Chrome si avvia solo da terminale

MessaggioInviato: lun giu 13, 2011 2:19 pm
da Pct
Ciao a tutti!

Ho un problemino con il mio Ubuntu 11.04

Praticamente, l'installazione va a buon fine, ma se provo ad avviarlo, non parte. L'unico modo per farlo partire è da terminale (sudo google-chrome). Qualcuno sa come risolvere?

Uso Chromium, ma preferirei chrome perché il primo mi dà alcuni problemini, per esempio è "lentino" a reagire con i video su youtube (e a volte va a scatti)

Re: Google Chrome si avvia solo da terminale

MessaggioInviato: lun giu 13, 2011 5:14 pm
da The Doctor
Come lo hai installato Google Chrome?

Re: Google Chrome si avvia solo da terminale

MessaggioInviato: lun giu 13, 2011 5:18 pm
da Pct
Avevo provato a installarlo sia da terminale tempo fa (sudo apt-get install google-chrome (o google-chrome-stable, non ricordo)), che oggi da Ubuntu Software Center; stesso risultato, non si avviava. Comunque ora ho risolto in questo modo:

mi hanno detto, da terminale, di dare questi comandi:

Codice: Seleziona tutto
sudo chown -R nome_login:nome_login ~/.config/google-chrome
google-chrome &


dove a nome_login, bisogna sostituire il vostro nome utente. Per esempio, il mio nome utente è fabry. Ho fatto così :

Codice: Seleziona tutto
sudo chown -R fabry:fabry ~/.config/google-chrome
google-chrome &


e adesso funziona anche senza bisogno di avviarlo da terminale [applauso+]

Mi hanno anche detto di non avviare mai un browser da sudo; per caso sai il perché? [uhm]

EDIT : ah, però non so se sia valido per tutti, perché prima mi avevano detto di postare cosa usciva dando questi comandi :
Codice: Seleziona tutto
ls -la .config/ | grep google-chrome
ls -la .config/google-chrome/
; non so se per darmi quella soluzione si siano basati su quello che è uscito dando quei comandi, oppure no e quindi può funzionare con tutti

Re: Google Chrome si avvia solo da terminale

MessaggioInviato: mar giu 14, 2011 9:19 am
da The Doctor
Innanzitutto grazie per aver postato la soluzione [^]

Pct ha scritto:Mi hanno anche detto di non avviare mai un browser da sudo; per caso sai il perché?


Perché il browser si avvia come amministratore, ovvero con tutti i privilegi di tale utente creando problemi di sicurezza [;)]

EDIT : ah, però non so se sia valido per tutti, perché prima mi avevano detto di postare cosa usciva dando questi comandi :
Codice: Seleziona tutto
ls -la .config/ | grep google-chrome
ls -la .config/google-chrome/
; non so se per darmi quella soluzione si siano basati su quello che è uscito dando quei comandi, oppure no e quindi può funzionare con tutti


Ti hanno fatto controllare le proprietà dei file di chrome per vedere a quale utente:gruppo appartenevano e poi te li hanno fatti modificare con il tuo [8D]

Re: Google Chrome si avvia solo da terminale

MessaggioInviato: mar giu 14, 2011 9:50 am
da Pct
The Doctor ha scritto:Innanzitutto grazie per aver postato la soluzione [^]


Di niente [^]

The Doctor ha scritto: Perché il browser si avvia come amministratore, ovvero con tutti i privilegi di tale utente creando problemi di sicurezza [;)] [7quote]


Giusto, non ci avevo pensato [acc2]

The Doctor ha scritto:Ti hanno fatto controllare le proprietà dei file di chrome per vedere a quale utente:gruppo appartenevano e poi te li hanno fatti modificare con il tuo [8D]


Figo! [8D] Linux mi piace sempre di più [std]